Bug #46953 MySQL Workbench crashes on load on MacOSX 10.6 10A432
Submitted: 27 Aug 2009 12:21 Modified: 8 Sep 2009 0:25
Reporter: David C Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.1.17, 5.2.2 OS:Mac OS X
Assigned to: Alfredo Kojima CPU Architecture:Any

[27 Aug 2009 12:21] David C
Description:
This worked fine in MacOSX 10.5.7, decided to reinstall with 10.6.0 today and found that MySQL workbench crashes 100% of the time on load, here's the error it spits out that it wants to send to Apple.

How to repeat:
1. Open MySQL Workbench on MacOSX 10.6.0 10A432
[27 Aug 2009 12:22] David C
Crash Report

Attachment: crashReport.txt (text/plain), 36.93 KiB.

[29 Aug 2009 9:44] Valeriy Kravchuk
Bug #46990 was marked as a duplicate of this one.
[29 Aug 2009 16:19] Valeriy Kravchuk
Bug #46993 was marked as a duplicate of this one.
[31 Aug 2009 7:25] Valeriy Kravchuk
Bug #47002 was marked as a duplicate of this one.
[31 Aug 2009 18:11] Alfredo Kojima
The crash has been fixed, 5.1.18 should work in Snow Leopard.
[31 Aug 2009 20:49] Johannes Taxacher
this has been fixed. fix will be included in 5.1.18 and 5.2.3
[4 Sep 2009 12:48] Tony Bedford
An entry was added to the 5.1.18 and 5.2.3 changelogs:

MySQL Workbench crashed on launch on Mac OS X 10.6.0.
[7 Sep 2009 10:28] Hugo Matinho
Fix not working i'm using 10.6 with 5.1.18 and it still crashes
[7 Sep 2009 16:33] Hugo Matinho
Hey everybody here's the link for my crash http://pastebin.org/15736
[7 Sep 2009 16:48] Mike Lischke
Hugo, thanks for the additional info.
[7 Sep 2009 17:29] Alfredo Kojima
Hi

Are you sure you're using 5.1.18? The crash log says 5.1.16 in the version info.
[7 Sep 2009 19:23] Hugo Matinho
yes i'm using the latest version on the 5.1 page 5.1.18
[7 Sep 2009 20:16] Hugo Matinho
ok i'm sorry you are correct Alfredo i'm still using 5.1.16 mirrors aren't updated yet it seems also tried using versiontracker and it goes to a mirror who still hasn't got the latest version i'll just have to wait then.
[8 Sep 2009 0:25] Alfredo Kojima
The download site is back to having 5.1.18 available for download. I'm closing this bug back.