Bug #46931 rpl.rpl_get_master_version_and_clock fails on hpux11.31
Submitted: 26 Aug 2009 7:55 Modified: 1 Apr 2010 5:30
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:mysql-next, mysql-pe OS:Any (hpux11.31 ia64 any)
Assigned to: Daogang Qu
Tags: disabled, pb2, test failure
Triage: Triaged: D3 (Medium) / R2 (Low) / E2 (Low)

[26 Aug 2009 7:55] Alexander Nozdrin
Description:
rpl.rpl_get_master_version_and_clock fails on hpux11.31:

------------------------------------------------------------
rpl.rpl_get_master_version_and_clock [ fail ]
        Test ended at 2009-08-25 10:12:26

CURRENT_TEST: rpl.rpl_get_master_version_and_clock
*** /export/tmp/pb2/test/sb_1-707446-1251180566.69/mysql-5.4.4-alpha-hpux11.31-ia64-test/mysql-test/suite/rpl/r/rpl_get_master_version_and_clock.result Mon Aug 24 21:35:03 2009
--- /export/tmp/pb2/test/sb_1-707446-1251180566.69/mysql-5.4.4-alpha-hpux11.31-ia64-test/mysql-test/suite/rpl/r/rpl_get_master_version_and_clock.reject	Tue Aug 25 11:12:26 2009
*************** *** 7,17 ****
  set global debug= 'd,before_get_UNIX_TIMESTAMP_bug45214';
  stop slave;
  start slave;
! Slave_IO_Errno= 2013
  set global debug= 'd,before_get_SERVER_ID_bug45214';
  stop slave;
  start slave;
! Slave_IO_Errno= 2013
  set global debug= '';
  reset master;
  include/stop_slave.inc
--- 7,17 ----
  set global debug= 'd,before_get_UNIX_TIMESTAMP_bug45214';
  stop slave;
  start slave;
! Slave_IO_Errno= 2003
  set global debug= 'd,before_get_SERVER_ID_bug45214';
  stop slave;
  start slave;
! Slave_IO_Errno= 2003
  set global debug= '';
  reset master;
  include/stop_slave.inc

mysqltest: Result content mismatch

Warnings from just before the error:
Note 1051 Unknown table 't1' 
Note 1051 Unknown table 't2' 
Note 1051 Unknown table 't3' 
Note 1051 Unknown table 't4' 
Note 1051 Unknown table 't5' 
Note 1051 Unknown table 't6' 
Note 1051 Unknown table 't7' 
Note 1051 Unknown table 't8'
------------------------------------------------------------

This bug seems to be different from Bug#46828.

The test has been marked experimental due to this bug.

How to repeat:
XRef2: http://pb2.norway.sun.com/web.py?template=mysql_show_test_failure&test_failure_id=2288129&...
[2 Sep 2009 12:28] Bjørn Munch
I get the exact same failure (same result diff) on my Solaris 10 x86 desktop. This is with (essentially) 5.1 main
[16 Sep 2009 7:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/83427

3093 Dao-Gang.Qu@sun.com	2009-09-16
      Bug #46931  rpl.rpl_get_master_version_and_clock fails on hpux11.31
      
      Network error happened here, but it can be caused by CR_CONNECTION_ERROR, 
      CR_CONN_HOST_ERROR, CR_SERVER_GONE_ERROR, CR_SERVER_LOST, ER_CON_COUNT_ERROR, 
      and ER_SERVER_SHUTDOWN. We just check CR_SERVER_LOST here, so the test fails.
      
      To fix the problem, check all the error numbers that cause the network error.
     @ mysql-test/extra/rpl_tests/rpl_get_master_version_and_clock.test
        Added a 'if' sentence to check all the error numbers that cause the network error.
[27 Sep 2009 9:02] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/84730

3134 Dao-Gang.Qu@sun.com	2009-09-27
      Bug #46931  rpl.rpl_get_master_version_and_clock fails on hpux11.31
      
      Network error happened here, but it can be caused by CR_CONNECTION_ERROR, 
      CR_CONN_HOST_ERROR, CR_SERVER_GONE_ERROR, CR_SERVER_LOST, ER_CON_COUNT_ERROR, 
      and ER_SERVER_SHUTDOWN. We just check CR_SERVER_LOST here, so the test fails.
      
      To fix the problem, check all errors that can be cause by the master shutdown.
     @ mysql-test/extra/rpl_tests/rpl_get_master_version_and_clock.test
        Added a 'if' sentence to check all errors that can be cause by the master shutdown.
     @ mysql-test/suite/rpl/r/rpl_get_master_version_and_clock.result
        Test result is updated duo to the patch of bug#46931
[27 Sep 2009 9:22] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/84731

3618 Dao-Gang.Qu@sun.com	2009-09-27 [merge]
      Bug #46931  rpl.rpl_get_master_version_and_clock fails on hpux11.31
      
      Network error happened here, but it can be caused by CR_CONNECTION_ERROR, 
      CR_CONN_HOST_ERROR, CR_SERVER_GONE_ERROR, CR_SERVER_LOST, ER_CON_COUNT_ERROR, 
      and ER_SERVER_SHUTDOWN. We just check CR_SERVER_LOST here, so the test fails.
      
      To fix the problem, check all errors that can be cause by the master shutdown.
     @ mysql-test/extra/rpl_tests/rpl_get_master_version_and_clock.test
        Added a 'if' sentence to check all errors that can be cause by the master shutdown.
     @ mysql-test/suite/rpl/r/rpl_get_master_version_and_clock.result
        Test result is updated duo to the patch of bug#46931
[28 Sep 2009 8:12] Daogang Qu
It is pushed to mysql-5.1-bugteam and mysql-pe.
[29 Sep 2009 11:38] Daogang Qu
the test case will not be removed from the experimental lists until the Bug #46828 is fixed.
[6 Oct 2009 9:00] Bugs System
Pushed into 5.1.40 (revid:joro@sun.com-20091006073316-lea2cpijh9r6on7c) (version source revid:dao-gang.qu@sun.com-20090927090029-4ebk2wak4j18l06v) (merge vers: 5.1.40) (pib:11)
[6 Oct 2009 11:29] Jon Stephens
Test failure/change only, nothing to document. Closed.
[17 Oct 2009 8:52] Georgi Kodinov
Still fails on mysql-pe as follows : 
rpl.rpl_get_master_version_and_clock     w7 [ fail ]  Found warnings/errors in server log file!
        Test ended at 2009-10-17 03:11:22
mysqltest: Logging to ''.
mysqltest: Results saved in ''.
mysqltest: Connecting to server localhost:13051 (socket /export/home/pb2/test/sb_0-838924-1255740968.64/tmp/KeWVetUMF3/7/mysqld.2.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-warnings.test' ...
file_name	line
/export/home/pb2/test/sb_0-838924-1255740968.64/mysql-6.0.14-alpha-linux-x86_64-test/mysql-test/var/7/log/mysqld.2.err	091017  4:10:55 [Warning] Slave I/O: Get master clock failed with error: Can't connect to MySQL server on '127.0.0.1' (111), Error_code: 2003
/export/home/pb2/test/sb_0-838924-1255740968.64/mysql-6.0.14-alpha-linux-x86_64-test/mysql-test/var/7/log/mysqld.2.err	091017  4:11:09 [Warning] Slave I/O: Get master SERVER_ID failed with error: Can't connect to MySQL server on '127.0.0.1' (111), Error_code: 2003
^ Found warnings!!
mysqltest: ... Done processing test commands.
mysqltest: Test has succeeded!
ok

and 

rpl.rpl_get_master_version_and_clock     w6 [ fail ]
        Test ended at 2009-10-17 04:40:08

CURRENT_TEST: rpl.rpl_get_master_version_and_clock
==22445== Memcheck, a memory error detector.
==22445== Copyright (C) 2002-2006, and GNU GPL'd, by Julian Seward et al.
==22445== Using LibVEX rev 1658, a library for dynamic binary translation.
==22445== Copyright (C) 2004-2006, and GNU GPL'd, by OpenWorks LLP.
==22445== Using valgrind-3.2.1, a dynamic binary instrumentation framework.
==22445== Copyright (C) 2000-2006, and GNU GPL'd, by Julian Seward et al.
==22445== For more details, rerun with: -v
==22445== 
--- /export/home/pb2/test/sb_0-838924-1255740968.64/mysql-6.0.14-alpha-linux-x86_64-test/mysql-test/suite/rpl/r/rpl_get_master_version_and_clock.result	2009-10-17 00:33:29.000000000 +0300
+++ /export/home/pb2/test/sb_0-838924-1255740968.64/mysql-6.0.14-alpha-linux-x86_64-test/mysql-test/suite/rpl/r/rpl_get_master_version_and_clock.reject	2009-10-17 05:40:08.000000000 +0300
@@ -16,11 +16,100 @@
 start slave;
 Check network error happened here
 NETWORK ERROR
-set global debug= '';
-reset master;
-include/stop_slave.inc
-change master to master_port=SLAVE_PORT;
-start slave;
-*** must be having the replicate-same-server-id IO thread error ***
-Slave_IO_Errno= 1593
-Slave_IO_Error= Fatal error: The slave I/O thread stops because master and slave have equal MySQL server ids; these ids must be different for replication to work (or the --replicate-same-server-id option must be used on slave but this does not always make sense; please check the manual before using it).
+**** ERROR: timeout after 3000 deci-seconds while waiting for slave parameter Slave_IO_Running = Yes ****
+Message: Failed while waiting for slave to start
+Current connection is 'slave'
+Note: the following output may have changed since the failure was detected
+
+[on slave]
+
+**** SHOW SLAVE STATUS on slave ****
+SHOW SLAVE STATUS;
+Slave_IO_State	
+Master_Host	127.0.0.1
+Master_User	root
+Master_Port	13060
+Connect_Retry	1
+Master_Log_File	master-bin.000001
+Read_Master_Log_Pos	767
+Relay_Log_File	slave-relay-bin.000003
+Relay_Log_Pos	914
+Relay_Master_Log_File	master-bin.000001
+Slave_IO_Running	No
+Slave_SQL_Running	Yes
+Replicate_Do_DB	
+Replicate_Ignore_DB	
+Replicate_Do_Table	
+Replicate_Ignore_Table	
+Replicate_Wild_Do_Table	
+Replicate_Wild_Ignore_Table	
+Last_Errno	0
+Last_Error	
+Skip_Counter	0
+Exec_Master_Log_Pos	767
+Relay_Log_Space	1070
+Until_Condition	None
+Until_Log_File	
+Until_Log_Pos	0
+Master_SSL_Allowed	No
+Master_SSL_CA_File	
+Master_SSL_CA_Path	
+Master_SSL_Cert	
+Master_SSL_Cipher	
+Master_SSL_Key	
+Seconds_Behind_Master	NULL
+Master_SSL_Verify_Server_Cert	No
+Last_IO_Errno	2003
+Last_IO_Error	error reconnecting to master 'root@127.0.0.1:13060' - retry-time: 1  retries: 10
+Last_SQL_Errno	0
+Last_SQL_Error	
+Replicate_Ignore_Server_Ids	
+Master_Server_Id	1
+
+**** SHOW PROCESSLIST on slave ****
+SHOW PROCESSLIST;
+Id	User	Host	db	Command	Time	State	Info
+2	root	localhost:40052	test	Query	0	NULL	SHOW PROCESSLIST
+3	root	localhost:40053	test	Sleep	469	NULL	NULL
+9	system user		NULL	Connect	444	Slave has read all relay log; waiting for the slave I/O thread to update it	NULL
+
+**** SHOW BINLOG EVENTS on slave ****
+SHOW BINLOG EVENTS IN 'slave-bin.000001';
+Log_name	Pos	Event_type	Server_id	End_log_pos	Info
+slave-bin.000001	4	Format_desc	2	107	Server ver: 6.0.14-alpha-debug-log, Binlog ver: 4
+slave-bin.000001	107	Query	1	166	BEGIN
+slave-bin.000001	166	Table_map	1	223	table_id: 25 (mtr.test_suppressions)
+slave-bin.000001	223	Write_rows	1	360	table_id: 25 flags: STMT_END_F
+slave-bin.000001	360	Query	1	420	COMMIT
+slave-bin.000001	420	Query	1	479	BEGIN
+slave-bin.000001	479	Table_map	1	536	table_id: 25 (mtr.test_suppressions)
+slave-bin.000001	536	Write_rows	1	675	table_id: 25 flags: STMT_END_F
+slave-bin.000001	675	Query	1	735	COMMIT
+
+[on master]
+
+**** SHOW MASTER STATUS on master ****
+SHOW MASTER STATUS;
+File	master-bin.000003
+Position	107
+Binlog_Do_DB	
+Binlog_Ignore_DB	
+
+**** SHOW PROCESSLIST on master ****
+SHOW PROCESSLIST;
+Id	User	Host	db	Command	Time	State	Info
+1	root	localhost:38784	test	Query	0	NULL	SHOW PROCESSLIST
+
+**** SHOW BINLOG EVENTS on master ****
+SHOW BINLOG EVENTS IN 'master-bin.000001';
+Log_name	Pos	Event_type	Server_id	End_log_pos	Info
+master-bin.000001	4	Format_desc	1	107	Server ver: 6.0.14-alpha-debug-log, Binlog ver: 4
+master-bin.000001	107	Query	1	174	BEGIN
+master-bin.000001	174	Table_map	1	231	table_id: 97 (mtr.test_suppressions)
+master-bin.000001	231	Write_rows	1	368	table_id: 97 flags: STMT_END_F
+master-bin.000001	368	Query	1	436	COMMIT
+master-bin.000001	436	Query	1	503	BEGIN
+master-bin.000001	503	Table_map	1	560	table_id: 97 (mtr.test_suppressions)
+master-bin.000001	560	Write_rows	1	699	table_id: 97 flags: STMT_END_F
+master-bin.000001	699	Query	1	767	COMMIT
+master-bin.000001	767	Stop	1	786	

mysqltest: In included file "./include/wait_for_slave_param.inc": Result content mismatch

Warnings from just before the error:
Note 1051 Unknown table 't1' 
Note 1051 Unknown table 't2' 
Note 1051 Unknown table 't3' 
Note 1051 Unknown table 't4' 
Note 1051 Unknown table 't5' 
Note 1051 Unknown table 't6' 
Note 1051 Unknown table 't7' 
Note 1051 Unknown table 't8' 
==22445== 
==22445== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 5 from 1)
==22445== malloc/free: in use at exit: 56 bytes in 1 blocks.
==22445== malloc/free: 1,076,213 allocs, 1,076,212 frees, 76,037,847 bytes allocated.
==22445== For counts of detected errors, rerun with: -v
==22445== searching for pointers to 1 not-freed blocks.
==22445== checked 2,332,328 bytes.
==22445== 
==22445== LEAK SUMMARY:
==22445==    definitely lost: 0 bytes in 0 blocks.
==22445==      possibly lost: 0 bytes in 0 blocks.
==22445==    still reachable: 0 bytes in 0 blocks.
==22445==         suppressed: 56 bytes in 1 blocks.

 - saving '/export/home/pb2/test/sb_0-838924-1255740968.64/mysql-6.0.14-alpha-linux-x86_64-test/mysql-test/var/6/log/rpl.rpl_get_master_version_and_clock/' to '/export/home/pb2/test/sb_0-838924-1255740968.64/mysql-6.0.14-alpha-linux-x86_64-test/mysql-test/var/log/rpl.rpl_get_master_version_and_clock/'
[17 Oct 2009 8:59] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/87222

3670 Georgi Kodinov	2009-10-17
      Made rpl.rpl_get_master_version_and_clock experimental and re-opened bug #46931
[18 Oct 2009 5:54] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/87234

3673 Georgi Kodinov	2009-10-18
      Disable the test bcause of bug #46931 instead of making it experimental.
[22 Oct 2009 5:54] Alexander Nozdrin
Disabled in mysql-trunk, mysql-next-mr, mysql-6.0-codebase.
[22 Oct 2009 6:01] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/87710

2913 Alexander Nozdrin	2009-10-22
      Disable the test in mysql-trunk because of Bug#46931
      instead of making it experimental.
[22 Oct 2009 6:33] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091022063126-l0qzirh9xyhp0bpc) (version source revid:alik@sun.com-20091022062154-ruamundi3ny2n7cd) (merge vers: 6.0.14-alpha) (pib:13)
[22 Oct 2009 7:05] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091022060553-znkmxm0g0gm6ckvw) (version source revid:alik@sun.com-20091022060123-6c8v3x00mdtn4uds) (merge vers: 5.5.0-beta) (pib:13)
[23 Oct 2009 2:42] Daogang Qu
We should close the bug. Because the 'rpl.rpl_get_master_version_and_clock fails on hpux11.31:' failure is fixed by the patch committed. 

The bug is reopened base on the following two errors:
1. rpl.rpl_get_master_version_and_clock     w7 [ fail ]  Found warnings/errors in server log
2. ERROR: timeout after 3000 deci-seconds while waiting for slave parameter

Actually the above two errors are addressed by bug#46828.
[29 Oct 2009 3:12] Daogang Qu
The bug#46931 is closed, because the patch for Bug#46828 is pushed.
All the errors which caused by the 'rpl_get_master_version_and_clock' 
test case will be fixed by the patch of bug#46828.
[29 Oct 2009 3:12] Daogang Qu
The bug#46931 is closed, because the patch for Bug#46828 is pushed.
All the errors which caused by the 'rpl_get_master_version_and_clock' 
test case will be fixed by the patch of bug#46828.
[11 Nov 2009 6:52] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091110093407-rw5g8dys2baqkt67) (version source revid:alik@sun.com-20091109080109-7dxapd5y5pxlu08w) (merge vers: 6.0.14-alpha) (pib:13)
[11 Nov 2009 14:54] Jon Stephens
Re-closed per Daogang's comment above.
[18 Dec 2009 10:27] Bugs System
Pushed into 5.1.41-ndb-7.1.0 (revid:jonas@mysql.com-20091218102229-64tk47xonu3dv6r6) (version source revid:jonas@mysql.com-20091218095730-26gwjidfsdw45dto) (merge vers: 5.1.41-ndb-7.1.0) (pib:15)
[18 Dec 2009 10:43] Bugs System
Pushed into 5.1.41-ndb-6.2.19 (revid:jonas@mysql.com-20091218100224-vtzr0fahhsuhjsmt) (version source revid:jonas@mysql.com-20091217101452-qwzyaig50w74xmye) (merge vers: 5.1.41-ndb-6.2.19) (pib:15)
[18 Dec 2009 10:59] Bugs System
Pushed into 5.1.41-ndb-6.3.31 (revid:jonas@mysql.com-20091218100616-75d9tek96o6ob6k0) (version source revid:jonas@mysql.com-20091217154335-290no45qdins5bwo) (merge vers: 5.1.41-ndb-6.3.31) (pib:15)
[18 Dec 2009 11:13] Bugs System
Pushed into 5.1.41-ndb-7.0.11 (revid:jonas@mysql.com-20091218101303-ga32mrnr15jsa606) (version source revid:jonas@mysql.com-20091218064304-ezreonykd9f4kelk) (merge vers: 5.1.41-ndb-7.0.11) (pib:15)
[19 Dec 2009 11:10] Jon Stephens
Setting back to Closed state. See previous comments from Daogang and me.
[24 Dec 2009 3:05] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/95610

2950 Dao-Gang.Qu@sun.com	2009-12-24
      Enable rpl_get_master_version_and clock and rpl_cross_version
      as the bug#46931 and bug#43913 have been closed.
     @ mysql-test/suite/rpl/t/disabled.def
        Enable rpl_get_master_version_and clock and rpl_cross_version
        as the bug#46931 and bug#43913 have been closed.
[12 Jan 2010 16:24] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100112162328-2sblcul1kl08bbib) (version source revid:guilhem@mysql.com-20100108092756-k0zzf4kvx9b7bh38) (merge vers: 6.0.14-alpha) (pib:15)
[12 Jan 2010 16:25] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100112162142-nrjoxn6h2nrnh2o0) (version source revid:guilhem@mysql.com-20100108092756-k0zzf4kvx9b7bh38) (pib:15)
[12 Jan 2010 23:16] Jon Stephens
Re-closing. See previous comments from Daogang and me.
[10 Feb 2010 10:25] Luis Soares
Reopening the bug. The test case is still listed in disabled.def in trunk
(revid:alik@sun.com-20100209101036-copgamva3qvs4cc8)

"rpl_get_master_version_and_clock:  # Bug#46931 2009-10-17 joro rpl.rpl_get_master_version_and_clock fails"

Please fix this and re-close the bug.
[6 Mar 2010 10:52] Bugs System
Pushed into 5.5.3-m3 (revid:alik@sun.com-20100306103849-hha31z2enhh7jwt3) (version source revid:guilhem@mysql.com-20100108092756-k0zzf4kvx9b7bh38) (merge vers: 6.0.14-alpha) (pib:16)