Bug #43913 rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
Submitted: 27 Mar 2009 14:03 Modified: 15 Mar 2010 4:20
Reporter: Andrei Elkin Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Replication Severity:S3 (Non-critical)
Version: OS:Mac OS X (10.4 PPC (32+64 bit))
Assigned to: Daogang Qu CPU Architecture:Any
Tags: disabled
Triage: Triaged: D3 (Medium)

[27 Mar 2009 14:03] Andrei Elkin
Description:
rpl.rpl_cross_version                    [ fail ]

The test could not make LOAD DATA infile, leaving

+Last_Error	Error 'The MySQL server is running with the
--slave-load-tmpdir option so it cannot execute this statement'
running LOAD DATA INFILE on table 't3'. Default database: 'test'.

The source code contains a call to report a bug

        if (strncmp(active_mi->rli.slave_patternload_file, name, 
            active_mi->rli.slave_patternload_file_size))
        {
          /*
            LOAD DATA INFILE in the slave SQL Thread can only read from 
            --slave-load-tmpdir". This should never happen. Please, report a bug.
           */

          sql_print_error("LOAD DATA INFILE in the slave SQL Thread can only read from --slave-load-tmpdir. " \
                          "Please, report a bug.");
          my_error(ER_OPTION_PREVENTS_STATEMENT, MYF(0), "--slave-load-tmpdir");

How to repeat:
See PB for powermacg5 on 5.1-pe-stage.
[10 Jun 2009 12:52] Sven Sandberg
Here: 
https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-5.1-pe-stage&order=1... powermacg5/n_mix
xref: http://tinyurl.com/lcydlu
[10 Jun 2009 12:52] Sven Sandberg
Full error log: 

rpl.rpl_cross_version                    [ fail ]
        Test ended at 2009-03-28 11:30:27

CURRENT_TEST: rpl.rpl_cross_version
--- /Users/henry/pb/bzr_mysql-5.1-pe-stage/16/mysql-5.1.34-pb16/mysql-test/suite/rpl/r/rpl_cross_version.result	Fri Mar 27 15:23:21 2009
+++ /Users/henry/pb/bzr_mysql-5.1-pe-stage/16/mysql-5.1.34-pb16/mysql-test/suite/rpl/r/rpl_cross_version.reject	Sat Mar 28 13:30:26 2009
@@ -2,11 +2,62 @@
 Setting up fake replication from MYSQL_TEST_DIR/suite/binlog/std_data/binlog_old_version_4_1.000001
 ==== Test ====
 start slave sql_thread;
-==== a prove that the fake has been processed successfully ====
-SELECT COUNT(*) - 17920 as zero FROM t3;
-zero
-0
-==== Clean up ====
-stop slave sql_thread;
-Cleaning up after setup_fake_relay_log.inc
-drop table t1, t3;
+**** ERROR: timeout after  seconds while waiting for slave parameter Exec_Master_Log_Pos = 149436 ****
+Current connection is 'default'
+Note: the following output may have changed since the failure was detected
+
+[on default]
+
+**** SHOW SLAVE STATUS on default ****
+SHOW SLAVE STATUS;
+Slave_IO_State	
+Master_Host	dummy.localdomain
+Master_User	test
+Master_Port	3306
+Connect_Retry	60
+Master_Log_File	
+Read_Master_Log_Pos	4
+Relay_Log_File	slave-relay-bin-fake.000001
+Relay_Log_Pos	149413
+Relay_Master_Log_File	
+Slave_IO_Running	No
+Slave_SQL_Running	No
+Replicate_Do_DB	
+Replicate_Ignore_DB	
+Replicate_Do_Table	
+Replicate_Ignore_Table	
+Replicate_Wild_Do_Table	
+Replicate_Wild_Ignore_Table	
+Last_Errno	1290
+Last_Error	Error 'The MySQL server is running with the --slave-load-tmpdir option so it cannot execute this statement' running LOAD DATA INFILE on table 't3'. Default database: 'test'. Failed executing load from '/tmp/pbtmp-n_mix-5/mysqld.1/SQL_LOAD-1-1-2.info'
+Skip_Counter	0
+Exec_Master_Log_Pos	149413
+Relay_Log_Space	149542
+Until_Condition	None
+Until_Log_File	
+Until_Log_Pos	0
+Master_SSL_Allowed	No
+Master_SSL_CA_File	
+Master_SSL_CA_Path	
+Master_SSL_Cert	
+Master_SSL_Cipher	
+Master_SSL_Key	
+Seconds_Behind_Master	NULL
+Master_SSL_Verify_Server_Cert	No
+Last_IO_Errno	0
+Last_IO_Error	
+Last_SQL_Errno	1290
+Last_SQL_Error	Error 'The MySQL server is running with the --slave-load-tmpdir option so it cannot execute this statement' running LOAD DATA INFILE on table 't3'. Default database: 'test'. Failed executing load from '/tmp/pbtmp-n_mix-5/mysqld.1/SQL_LOAD-1-1-2.info'
+
+**** SHOW PROCESSLIST on default ****
+SHOW PROCESSLIST;
+Id	User	Host	db	Command	Time	State	Info
+2	root	localhost	test	Query	0	NULL	SHOW PROCESSLIST
+
+**** SHOW BINLOG EVENTS on default ****
+SHOW BINLOG EVENTS IN 'master-bin.000001';
+Log_name	Pos	Event_type	Server_id	End_log_pos	Info
+master-bin.000001	4	Format_desc	1	106	Server ver: 5.1.34-pb16-log, Binlog ver: 4
+Unable to determine master connection. No debug info printed for master.
+Please fix the test case by setting  before sourcing
+show_rpl_debug_info.inc.

mysqltest: In included file "./include/wait_for_slave_param.inc": Result length mismatch

 - saving '/Users/henry/pb/bzr_mysql-5.1-pe-stage/16/mysql-5.1.34-pb16/mysql-test/var-n_mix-5/log/rpl.rpl_cross_version/' to '/Users/henry/pb/bzr_mysql-5.1-pe-stage/16/mysql-5.1.34-pb16/mysql-test/var-n_mix-5/log/rpl.rpl_cross_version/'

Retrying test, attempt(2/3)...
[18 Sep 2009 8:50] Daogang Qu
The test case is tested for three days on push build machine, but the above failure is not reproduced, but another failure happened as following:

Description:
rpl.rpl_cross_version 'row'              [ fail ]
        Test ended at 2009-09-15 18:01:18

CURRENT_TEST: rpl.rpl_cross_version
mysqltest: In included file "./include/wait_for_slave_param.inc": At line 54: Error running query 'SELECT '' = ''': 2013 Lost connection to MySQL server during query

The result from queries just before the failure was:
==== Initialize ====
Setting up fake replication from MYSQL_TEST_DIR/suite/binlog/std_data/binlog_old_version_4_1.000001
==== Test ====
start slave sql_thread;

 - saving '/home/daogangqu/mysql/bzrwork/bug43913/mysql-pe/mysql-test/var/log/rpl.rpl_cross_version-row/' to '/home/daogangqu/mysql/bzrwork/bug43913/mysql-pe/mysql-test/var/log/rpl.rpl_cross_version-row/'
 - found 'core' (0/5)

Trying 'dbx' to get a backtrace

Trying 'gdb' to get a backtrace
Core generated by '/home/daogangqu/mysql/bzrwork/bug43913/mysql-pe/sql/mysqld'
Output from gdb follows. The first stack trace is from the failing thread.
The following stack traces are from all threads (so the failing one is
duplicated).
--------------------------

warning: Can't read pathname for load map: Input/output error.
Core was generated by `/home/daogangqu/mysql/bzrwork/bug43913/mysql-pe/sql/mysqld --defaults-group-suf'.
Program terminated with signal 6, Aborted.
[New process 25387]
[New process 25324]
[New process 25329]
[New process 25386]
#0  0xb80ce430 in __kernel_vsyscall ()
#0  0xb80ce430 in __kernel_vsyscall ()
#1  0xb80a71c8 in pthread_kill () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0876404e in my_write_core (sig=6) at stacktrace.c:309
#3  0x082f8f1c in handle_segfault (sig=6) at mysqld.cc:2739
#4  <signal handler called>
#5  0xb80ce430 in __kernel_vsyscall ()
#6  0xb7df06d0 in raise () from /lib/tls/i686/cmov/libc.so.6
#7  0xb7df2098 in abort () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7de95ce in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#9  0x08366c00 in get_table_share (thd=0x9ef06e0, table_list=0xb747c4c0, key=0xb747b8b1 "test", 
    key_length=8, db_flags=8192, error=0xb747b89c) at sql_base.cc:473
#10 0x08367035 in get_table_share_with_create (thd=0x9ef06e0, table_list=0xb747c4c0, 
    key=0xb747b8b1 "test", key_length=8, db_flags=8192, error=0xb747b89c) at sql_base.cc:572
#11 0x08368675 in open_table (thd=0x9ef06e0, table_list=0xb747c4c0, mem_root=0xb747bd30, 
    ot_ctx=0xb747bd70, flags=0) at sql_base.cc:2671
#12 0x08369b1e in open_tables (thd=0x9ef06e0, start=0xb747be04, counter=0xb747bdf0, flags=0, 
    prelocking_strategy=0xb747be30) at sql_base.cc:3973
#13 0x0836a3b9 in open_and_lock_tables_derived (thd=0x9ef06e0, tables=0xb747c4c0, derived=true, 
    flags=0, prelocking_strategy=0xb747be30) at sql_base.cc:4686
#14 0x08318a15 in open_and_lock_tables_derived (thd=0x9ef06e0, tables=0xb747c4c0, derived=true, 
    flags=0) at ../../sql/mysql_priv.h:1525
#15 0x08318a52 in open_and_lock_tables (thd=0x9ef06e0, tables=0xb747c4c0)
    at ../../sql/mysql_priv.h:1535
#16 0x08494338 in mysql_load (thd=0x9ef06e0, ex=0xb747c3f8, table_list=0xb747c4c0, 
    fields_vars=@0xb747c490, set_fields=@0xb747c484, set_values=@0xb747c484, 
    handle_duplicates=DUP_ERROR, ignore=false, read_file_from_client=false) at sql_load.cc:195
#17 0x0841cb21 in Load_log_event::do_apply_event (this=0x9e1b388, net=0x0, rli=0x9edcaf8, 
    use_rli_only_for_errors=true) at log_event.cc:4691
#18 0x08423a2c in Execute_load_log_event::do_apply_event (this=0x9fa3fd8, rli=0x9edcaf8)
    at log_event.cc:6596
#19 0x084d4a31 in Log_event::apply_event (this=0x9fa3fd8, rli=0x9edcaf8) at log_event.h:1080
#20 0x084caa7e in apply_event_and_update_pos (ev=0x9fa3fd8, thd=0x9ef06e0, rli=0x9edcaf8, 
    skip=true) at slave.cc:2335
#21 0x084d32f8 in exec_relay_log_event (thd=0x9ef06e0, rli=0x9edcaf8) at slave.cc:2499
#22 0x084d3fd2 in handle_slave_sql (arg=0x9e2fe98) at slave.cc:3271
#23 0xb80a24ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#24 0xb7ea949e in clone () from /lib/tls/i686/cmov/libc.so.6

......
[18 Sep 2009 11:46] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/83714

3605 Dao-Gang.Qu@sun.com	2009-09-18
      Bug #43913  rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
      
      The MDL_SHARED lock was introduced for an object in 5.4, but the 'TABLE_LIST' 
      object was not initialized with the MDL_SHARED lock when applying event with 
      LOAD DATA INFILE into table. So the failure is caused when checking the 
      MDL_SHARED lock for the object.
      
      To fix the problem, the 'TABLE_LIST' object was initialized with the MDL_SHARED 
      lock when applying event with LOAD DATA INFILE into table.
     @ mysql-test/suite/rpl/t/disabled.def
        Got rid of the line for enabling 'rpl_cross_version' test.
[22 Sep 2009 20:11] Luis Soares
See also: BUG#42311.
[23 Sep 2009 18:39] Alexander Nozdrin
rpl.rpl_cross_version is disabled in 5.1 and mysql-trunk due to this bug.
[27 Sep 2009 10:14] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/84734

3135 Dao-Gang.Qu@sun.com	2009-09-27
      Bug #43913 rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
      
      The failure is not reproduced on 5.1, so enable the 'rpl_cross_version' test.
     @ mysql-test/suite/rpl/t/disabled.def
        Got rid of the line for enabling 'rpl_cross_version' test.
[27 Sep 2009 10:27] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/84735

3619 Dao-Gang.Qu@sun.com	2009-09-27 [merge]
      Bug #43913  rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
      
      The MDL_SHARED lock was introduced for an object in 5.4, but the 'TABLE_LIST' 
      object was not initialized with the MDL_SHARED lock when applying event with 
      LOAD DATA INFILE into table. So the failure is caused when checking the 
      MDL_SHARED lock for the object.
      
      To fix the problem, the 'TABLE_LIST' object was initialized with the MDL_SHARED 
      lock when applying event with LOAD DATA INFILE into table.
     @ mysql-test/suite/rpl/t/disabled.def
        Got rid of the line for enabling 'rpl_cross_version' test.
[28 Sep 2009 8:08] Daogang Qu
It is pushed to 5.1+.
[28 Sep 2009 8:10] Daogang Qu
It is pushed to mysql-5.1-bugteam and mysql-pe.
[6 Oct 2009 8:59] Bugs System
Pushed into 5.1.40 (revid:joro@sun.com-20091006073316-lea2cpijh9r6on7c) (version source revid:dao-gang.qu@sun.com-20090927101258-py2408aj23o5lemx) (merge vers: 5.1.40) (pib:11)
[6 Oct 2009 11:12] Jon Stephens
Test changes only, nothing to document for users. Closed without further action.
[21 Oct 2009 14:05] Joerg Bruehe
The original (!) failure still happens in the build of 5.1.40,
specific to Mac OS X 10.4.

That platform was already mentioned in the original report ("powermacg5"),
but was not set in the bug header, so I guess that info wasn't noticed.

I don't know to which machine the comment dated 18-Sep-2009 10:50 refers
("The test case is tested for three days on push build machine, ..."),
probably not to OS X (these machines are notoriously instable).

Also, it isn't obvious which of the three changesets is claimed to be pushed to 5.1.40 - from the effects on source and on the tests taken, it was the middle one: The test is re-enabled (and fails on OS X 10.4), and the test options still specify "--secure-file-priv=$MYSQL_TMP_DIR".

The test fails 108 times in the build of 5.1.40, this is *all* attempts to run it on Mac OS X, 10.4, PPC (32 or 64 bit).
[22 Oct 2009 6:35] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091022063126-l0qzirh9xyhp0bpc) (version source revid:alik@sun.com-20091019135554-s1pvptt6i750lfhv) (merge vers: 6.0.14-alpha) (pib:13)
[22 Oct 2009 7:07] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091022060553-znkmxm0g0gm6ckvw) (version source revid:alik@sun.com-20091013094238-g67x6tgdm9a7uik0) (merge vers: 5.5.0-beta) (pib:13)
[26 Oct 2009 8:39] Daogang Qu
Hi Joerg Bruehe,

Could you give me a link to the original (!) failure?

Actually, I found two kind of errors on pb2 as following:

1.
mysqltest: In included file "./include/setup_fake_relay_log.inc": At line 80: query 'select './$_fake_filename-fake.000001\n' into dumpfile '$_fake_relay_index'' failed: 1290: The MySQL server is running with the --secure-file-priv option so it cannot execute this statement

2. 
Found warnings/errors in server log file!

For error 1, I have checked mysql-5.1-rpl-merge source code, The 
'setup_fake_relay_log.inc' is updated, so the error can be fixed 
by backporting the minor part of the patch as following:

+++ b/mysql-test/suite/rpl/t/rpl_cross_version-master.opt

---replicate-same-server-id --relay-log=slave-relay-bin --secure-file-priv=$MYSQL_TMP_DIR
+--replicate-same-server-id --relay-log=slave-relay-bin

The 'MDL_SHARED lock' part can't be backported, because the feature 
was not be introduced to the 'mysql-5.1-rpl-merge' so far. I need do 
it later.

For error 2, it goes out the range of the bug.

Can the above two kind of errors cover 'the original (!) failure'?
[26 Oct 2009 12:33] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/88140

3199 Georgi Kodinov	2009-10-26
      rpl_cross_version made experimental because of bug #43913
[27 Oct 2009 7:47] Daogang Qu
An new bug is reported for finding warnings/errors in server log file!
Please refer to: http://bugs.mysql.com/bug.php?id=48340
[4 Nov 2009 9:25] Bugs System
Pushed into 5.1.41 (revid:joro@sun.com-20091104092152-qz96bzlf2o1japwc) (version source revid:kristofer.pettersson@sun.com-20091103162305-08l4gkeuif2ozsoj) (merge vers: 5.1.41) (pib:13)
[5 Nov 2009 5:26] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/89399

3192 Dao-Gang.Qu@sun.com	2009-11-05
      Bug #43913  	rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
      
      The 'slave_patternload_file' is assigned to the real path of the load data file 
      when initializing the object of Relay_log_info. But the path of the load data
      file is not formatted to real path when loading event from binary log. So the 
      error will be encountered if the path of the load data file is a symbolic link.
      
      To fix the error, the path of the load data file should be formatted to 
      real path when loading event from binary log.
[11 Nov 2009 6:51] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091110093407-rw5g8dys2baqkt67) (version source revid:alik@sun.com-20091109080109-7dxapd5y5pxlu08w) (merge vers: 6.0.14-alpha) (pib:13)
[11 Nov 2009 6:59] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091109115615-nuohp02h8mdrz8m2) (version source revid:alik@sun.com-20091105092041-sp6eyod7sdlfuj3b) (merge vers: 5.5.0-beta) (pib:13)
[12 Nov 2009 20:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/90279

3196 Dao-Gang.Qu@sun.com	2009-11-13
      Bug #43913  	rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
            
      The 'slave_patternload_file' is assigned to the real path of the load data file 
      when initializing the object of Relay_log_info. But the path of the load data
      file is not formatted to real path when executing event from relay log. So the 
      error will be encountered if the path of the load data file is a symbolic link.
      
      Actually the global 'opt_secure_file_priv' is not formatted to real path when 
      loading data from file. So the same thing will happen too.
      
            
      To fix these errors, the path of the load data file should be formatted to 
      real path when executing event from relay log. And the 'opt_secure_file_priv' 
      should be formatted to real path when loading data infile.
     @ mysql-test/suite/rpl/r/rpl_loaddata_symlink.result
        Test result for bug#43913.
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink.test
        Added the test file to verify if loading data infile will work fine 
        if the path of the load data file is a symbolic link.
     @ sql/rpl_rli.cc
        Added call 'my_realpath' function for avoiding sometimes the 'fn_format' 
        function can't format real path rightly.
[19 Nov 2009 3:41] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/90921

3196 Dao-Gang.Qu@sun.com	2009-11-19
      Bug #43913  	rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
            
      The 'slave_patternload_file' is assigned to the real path of the load data file 
      when initializing the object of Relay_log_info. But the path of the load data
      file is not formatted to real path when executing event from relay log. So the 
      error will be encountered if the path of the load data file is a symbolic link.
      
      Actually the global 'opt_secure_file_priv' is not formatted to real path when 
      loading data from file. So the same thing will happen too.
      
            
      To fix these errors, the path of the load data file should be formatted to 
      real path when executing event from relay log. And the 'opt_secure_file_priv' 
      should be formatted to real path when loading data infile.
     @ mysql-test/suite/rpl/r/rpl_loaddata_symlink.result
        Test result for bug#43913.
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink.test
        Added the test file to verify if loading data infile will work fine 
        if the path of the load data file is a symbolic link.
     @ sql/rpl_rli.cc
        Added call 'my_realpath' function for avoiding sometimes the 'fn_format' 
        function can't format real path rightly.
[20 Nov 2009 5:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/91031

3196 Dao-Gang.Qu@sun.com	2009-11-20
      Bug #43913  	rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
            
      The 'slave_patternload_file' is assigned to the real path of the load data file 
      when initializing the object of Relay_log_info. But the path of the load data
      file is not formatted to real path when executing event from relay log. So the 
      error will be encountered if the path of the load data file is a symbolic link.
      
      Actually the global 'opt_secure_file_priv' is not formatted to real path when 
      loading data from file. So the same thing will happen too.
      
            
      To fix these errors, the path of the load data file should be formatted to 
      real path when executing event from relay log. And the 'opt_secure_file_priv' 
      should be formatted to real path when loading data infile.
     @ mysql-test/suite/rpl/r/rpl_loaddata_symlink.result
        Test result for bug#43913.
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink-master.sh
        Added the test file to create a link from $MYSQLTEST_VARDIR/std_data 
        to $MYSQLTEST_VARDIR/std_data_master_link
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink-slave.sh
        Added the test file to create a link from $MYSQLTEST_VARDIR/std_data 
        to $MYSQLTEST_VARDIR/std_data_slave_link
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink.test
        Added the test file to verify if loading data infile will work fine 
        if the path of the load data file is a symbolic link.
     @ sql/rpl_rli.cc
        Added call 'my_realpath' function for avoiding sometimes the 'fn_format' 
        function can't format real path rightly.
[28 Nov 2009 4:46] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/91991

3210 Dao-Gang.Qu@sun.com	2009-11-28
      Bug #43913  	rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
            
      The 'slave_patternload_file' is assigned to the real path of the load data file 
      when initializing the object of Relay_log_info. But the path of the load data
      file is not formatted to real path when executing event from relay log. So the 
      error will be encountered if the path of the load data file is a symbolic link.
      
      Actually the global 'opt_secure_file_priv' is not formatted to real path when 
      loading data from file. So the same thing will happen too.
      
            
      To fix these errors, the path of the load data file should be formatted to 
      real path when executing event from relay log. And the 'opt_secure_file_priv' 
      should be formatted to real path when loading data infile.
     @ mysql-test/suite/rpl/r/rpl_loaddata_symlink.result
        Test result for bug#43913.
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink-master.sh
        Added the test file to create a link from $MYSQLTEST_VARDIR/std_data 
        to $MYSQLTEST_VARDIR/std_data_master_link
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink-slave.sh
        Added the test file to create a link from $MYSQLTEST_VARDIR/std_data 
        to $MYSQLTEST_VARDIR/std_data_slave_link
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink.test
        Added the test file to verify if loading data infile will work fine 
        if the path of the load data file is a symbolic link.
     @ sql/rpl_rli.cc
        Added call 'my_realpath' function for avoiding sometimes the 'fn_format' 
        function can't format real path rightly.
[28 Nov 2009 5:28] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/91992

3724 Dao-Gang.Qu@sun.com	2009-11-28 [merge]
      Bug #43913  	rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
            
      The 'slave_patternload_file' is assigned to the real path of the load data file 
      when initializing the object of Relay_log_info. But the path of the load data
      file is not formatted to real path when executing event from relay log. So the 
      error will be encountered if the path of the load data file is a symbolic link.
      
      Actually the global 'opt_secure_file_priv' is not formatted to real path when 
      loading data from file. So the same thing will happen too.
      
      To fix these errors, the path of the load data file should be formatted to 
      real path when executing event from relay log. And the 'opt_secure_file_priv' 
      should be formatted to real path when loading data infile.
     @ mysql-test/suite/rpl/r/rpl_loaddata_symlink.result
        Test result for bug#43913.
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink-master.sh
        Added the test file to create a link from $MYSQLTEST_VARDIR/std_data 
        to $MYSQLTEST_VARDIR/std_data_master_link
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink-slave.sh
        Added the test file to create a link from $MYSQLTEST_VARDIR/std_data 
        to $MYSQLTEST_VARDIR/std_data_slave_link
     @ mysql-test/suite/rpl/t/rpl_loaddata_symlink.test
        Added the test file to verify if loading data infile will work fine 
        if the path of the load data file is a symbolic link.
     @ sql/rpl_rli.cc
        Added call 'my_realpath' function for avoiding sometimes the 'fn_format' 
        function can't format real path rightly.
[28 Nov 2009 11:16] Daogang Qu
The patch is pushed to mysql-5.1-bugteam and mysql-pe.
[2 Dec 2009 8:04] Bugs System
Pushed into 5.1.42 (revid:joro@sun.com-20091202080033-mndu4sxwx19lz2zs) (version source revid:dao-gang.qu@sun.com-20091128044316-frg8qkip283odrx7) (merge vers: 5.1.42) (pib:13)
[3 Dec 2009 20:41] Paul Dubois
Test changes only, nothing to document for users. Closed without further action.
[16 Dec 2009 8:39] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091216083311-xorsasf5kopjxshf) (version source revid:alik@sun.com-20091214191830-wznm8245ku8xo702) (merge vers: 6.0.14-alpha) (pib:14)
[16 Dec 2009 8:46] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091216082430-s0gtzibcgkv4pqul) (version source revid:alexey.kopytov@sun.com-20091201145844-39gy4wmejbisbxac) (merge vers: 5.5.0-beta) (pib:14)
[16 Dec 2009 8:53] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20091216083231-rp8ecpnvkkbhtb27) (version source revid:alik@sun.com-20091212203859-fx4rx5uab47wwuzd) (merge vers: 5.6.0-beta) (pib:14)
[16 Dec 2009 16:12] Jon Stephens
Closed. See Paul's comment above.
[18 Dec 2009 10:34] Bugs System
Pushed into 5.1.41-ndb-7.1.0 (revid:jonas@mysql.com-20091218102229-64tk47xonu3dv6r6) (version source revid:jonas@mysql.com-20091218095730-26gwjidfsdw45dto) (merge vers: 5.1.41-ndb-7.1.0) (pib:15)
[18 Dec 2009 10:50] Bugs System
Pushed into 5.1.41-ndb-6.2.19 (revid:jonas@mysql.com-20091218100224-vtzr0fahhsuhjsmt) (version source revid:jonas@mysql.com-20091217101452-qwzyaig50w74xmye) (merge vers: 5.1.41-ndb-6.2.19) (pib:15)
[18 Dec 2009 11:05] Bugs System
Pushed into 5.1.41-ndb-6.3.31 (revid:jonas@mysql.com-20091218100616-75d9tek96o6ob6k0) (version source revid:jonas@mysql.com-20091217154335-290no45qdins5bwo) (merge vers: 5.1.41-ndb-6.3.31) (pib:15)
[18 Dec 2009 11:19] Bugs System
Pushed into 5.1.41-ndb-7.0.11 (revid:jonas@mysql.com-20091218101303-ga32mrnr15jsa606) (version source revid:jonas@mysql.com-20091218064304-ezreonykd9f4kelk) (merge vers: 5.1.41-ndb-7.0.11) (pib:15)
[19 Dec 2009 8:50] Jon Stephens
No new changelog entries required. Closing.
[24 Dec 2009 3:04] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/95610

2950 Dao-Gang.Qu@sun.com	2009-12-24
      Enable rpl_get_master_version_and clock and rpl_cross_version
      as the bug#46931 and bug#43913 have been closed.
     @ mysql-test/suite/rpl/t/disabled.def
        Enable rpl_get_master_version_and clock and rpl_cross_version
        as the bug#46931 and bug#43913 have been closed.
[25 Dec 2009 6:14] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/95701

2953 Dao-Gang.Qu@sun.com	2009-12-25
      Backport Bug #43913  rpl_cross_version can't pass on conflicts complainig clash with --slave-load-tm
      
      The 'rpl_cross_version' fails on mysql-next-mr-bugfixing as following:
      mysqltest: In included file "./include/setup_fake_relay_log.inc": At line 80: query
      'select './$_fake_filename-fake.000001\n' into dumpfile '$_fake_relay_index'' failed:
      1290: The MySQL server is running with the --secure-file-priv option so it cannot execute
      this statement.
      
      To fix the problem by removeing the --secure-file-priv option
      for adapting the update of the 'setup_fake_relay_log.inc'.
[12 Jan 2010 16:24] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100112162328-2sblcul1kl08bbib) (version source revid:guilhem@mysql.com-20100108092756-k0zzf4kvx9b7bh38) (merge vers: 6.0.14-alpha) (pib:15)
[12 Jan 2010 16:25] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100112162142-nrjoxn6h2nrnh2o0) (version source revid:guilhem@mysql.com-20100108092756-k0zzf4kvx9b7bh38) (pib:15)
[12 Jan 2010 22:41] Jon Stephens
Re-closing per previous comments from Paul and me.
[17 Jan 2010 7:27] Sveta Smirnova
See also bug #50373
[10 Feb 2010 10:26] Luis Soares
Reopening the bug. The test case is still listed in disabled.def in mysql-trunk
(revid:alik@sun.com-20100209101036-copgamva3qvs4cc8)

"BUG#43913 2009-10-22 luis rpl_cross_version fails with symptom in described in bug report"

Please fix this and re-close the bug.
[11 Feb 2010 12:10] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/99927

2940 Dao-Gang.Qu@sun.com	2010-02-11
      Bug #43913  rpl_cross_version can't pass on conflicts complainig clash with
      --slave-load-tm
            
      The MDL_SHARED lock was introduced for an object in 5.4, but the 'TABLE_LIST' 
      object was not initialized with the MDL_SHARED lock when applying event with 
      LOAD DATA INFILE into table. So the failure is caused when checking the 
      MDL_SHARED lock for the object.
      To fix the problem, the 'TABLE_LIST' object was initialized with the MDL_SHARED 
      lock when applying event with LOAD DATA INFILE into table.
     @ mysql-test/suite/rpl/t/disabled.def
        Got rid of the line for enabling 'rpl_cross_version' test.
[12 Feb 2010 4:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/100064

2942 Dao-Gang.Qu@sun.com	2010-02-12
      Bug #43913  rpl_cross_version can't pass on conflicts complainig clash with
      --slave-load-tm
            
      The MDL_SHARED lock was introduced for an object in 5.4, but the 'TABLE_LIST' 
      object was not initialized with the MDL_SHARED lock when applying event with 
      LOAD DATA INFILE into table. So the failure is caused when checking the 
      MDL_SHARED lock for the object.
      To fix the problem, the 'TABLE_LIST' object was initialized with the MDL_SHARED 
      lock when applying event with LOAD DATA INFILE into table.
     @ mysql-test/suite/rpl/t/disabled.def
        Got rid of the line for enabling 'rpl_cross_version' test.
[12 Feb 2010 4:16] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/100066

2998 Dao-Gang.Qu@sun.com	2010-02-12 [merge]
      Bug #43913  rpl_cross_version can't pass on conflicts complainig clash with
      --slave-load-tm
            
      The MDL_SHARED lock was introduced for an object in 5.4, but the 'TABLE_LIST' 
      object was not initialized with the MDL_SHARED lock when applying event with 
      LOAD DATA INFILE into table. So the failure is caused when checking the 
      MDL_SHARED lock for the object.
            
      To fix the problem, the 'TABLE_LIST' object was initialized with the MDL_SHARED 
      lock when applying event with LOAD DATA INFILE into table.
[12 Feb 2010 4:53] Daogang Qu
Pushed to mysql-trunk-bugfixing, mysql-next-mr-bugfixing and mysql-6.0-codebase-bugfixing.
[12 Feb 2010 17:41] Bugs System
Pushed into 5.5.2-m2 (revid:joerg@mysql.com-20100212164100-jnurxdw5z88m472s) (version source revid:joerg@mysql.com-20100212164100-jnurxdw5z88m472s) (merge vers: 5.5.2-m2) (pib:16)
[13 Feb 2010 8:36] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100213083436-9pesg4h55w1mekxc) (version source revid:alik@sun.com-20100212100039-eh6atbvijcm71eyb) (merge vers: 6.0.14-alpha) (pib:16)
[13 Feb 2010 8:39] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100213083327-cee4ao3jpg33eggv) (version source revid:alik@sun.com-20100212095912-k3fklaqrxzzls9cd) (pib:16)
[13 Feb 2010 8:50] Jon Stephens
Change affected tests only. Closed without action.
[6 Mar 2010 11:01] Bugs System
Pushed into 5.5.3-m3 (revid:alik@sun.com-20100306103849-hha31z2enhh7jwt3) (version source revid:vvaintroub@mysql.com-20100213160132-nx1vlocxuta76txh) (merge vers: 5.5.99-m3) (pib:16)
[8 Mar 2010 19:48] Jon Stephens
Closing; see my rpevious comment.
[12 Mar 2010 14:12] Bugs System
Pushed into 5.1.44-ndb-7.0.14 (revid:jonas@mysql.com-20100312135944-t0z8s1da2orvl66x) (version source revid:jonas@mysql.com-20100312115609-woou0te4a6s4ae9y) (merge vers: 5.1.44-ndb-7.0.14) (pib:16)
[12 Mar 2010 14:28] Bugs System
Pushed into 5.1.44-ndb-6.2.19 (revid:jonas@mysql.com-20100312134846-tuqhd9w3tv4xgl3d) (version source revid:jonas@mysql.com-20100312060623-mx6407w2vx76h3by) (merge vers: 5.1.44-ndb-6.2.19) (pib:16)
[12 Mar 2010 14:44] Bugs System
Pushed into 5.1.44-ndb-6.3.33 (revid:jonas@mysql.com-20100312135724-xcw8vw2lu3mijrhn) (version source revid:jonas@mysql.com-20100312103652-snkltsd197l7q2yg) (merge vers: 5.1.44-ndb-6.3.33) (pib:16)
[15 Mar 2010 4:20] Jon Stephens
Closing; see my previous comments.