Bug #46670 asp is updating value to -1 at every kind of field type when th variable is true
Submitted: 12 Aug 2009 9:21 Modified: 14 Sep 2009 6:28
Reporter: Gurhan Demirtel Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:5.0.2 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: -1, ASP, Minus, one, true

[12 Aug 2009 9:21] Gurhan Demirtel
Description:
asp is updating value to '-1' at every kind of field type when the variable has true but i need only '1' or '0' (by the way false is working correctly updating for zero) for the "select * from" operations. 

I tried to test mysql from phpmyadmin/command prompt and it makes true/false operations correctly (1 for the true). 

System Specs:
Windows Server
ASP Codes
Mysql 5.0.2

How to repeat:
when the ASP sends a true value to mysql then i saw the value is turning to '-1' in the record's field.
[12 Aug 2009 9:29] Tonci Grgin
Hi Gurhan and thanks for your report.

I do not quite understand it. Can you please attach complete test case demonstrating the error and upgrade MySQL server to most recent version (I presume 5.0.2 *is* the MySQL server version).

Afaik, -1 *is* used by MS to represent TRUE value...
[12 Aug 2009 10:05] Gurhan Demirtel
Thanks for your interests Tonci.

I think it isn't mysql server version related.

It is quite simple operation.

The Site has the Guest Book that coded with ASP. 

When a guest writes a comment to the Guestbook, the code sends this message data to mysql's guestbook table with '0' value to the 'approve' field. Everything is correctly working as yet. When a operator reads that message and click to APPROVE for the publishing on the site, the code sends a 'true' value for the message to mysql then i saw the record's approve field has turned '-1' from '0'. But the site's guestbook views only the records that have '1' in their 'approve' fields.
[12 Aug 2009 10:18] Tonci Grgin
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.

Explanation: Gurhan, so what now? Do I have to write ASP web site with appropriate forms and buttons and guess as best as I can how you wrote and run it?

Please attach full test case demonstrating this error...
[12 Aug 2009 11:12] Gurhan Demirtel
Sorry Tonci for the misunderstanding,

I'll try the forums and asp sources to fix this problem.

But also it looks like to me a kind of bug about the connection between asp's ado and mysql. 

I will prepare a test case demo that includes pictures, explanation and codes and send it within the shortest possible time..

thanks again..
[12 Aug 2009 12:16] Miguel Solorzano
Please re-open when you have the test case. Thanks in advance.
[26 Aug 2009 4:08] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/81568

2771 Christopher Powers	2009-08-25
      Bug#46670 "ALTER TABLE crashes in StorageTableShare::haveIndexes()"
      
      Rewrote StorageTableShare::haveIndexes() to more effectively check for
      the need to remap Falcon indexes
      modified:
        storage/falcon/StorageTableShare.cpp
        storage/falcon/StorageTableShare.h
        storage/falcon/ha_falcon.cpp
[12 Sep 2009 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[14 Sep 2009 6:28] Tonci Grgin
AFAIS, the patch linked is unrelated to problem.
[14 Sep 2009 6:42] Christopher Powers
Sorry, patch was intended for Bug#44670, "ALTER TABLE crashes in StorageTableShare::haveIndexes()". Bug report has been updated with correct info.
[14 Sep 2009 6:45] Tonci Grgin
Thanks Christopher.