Bug #45418 'MySQL Server 5.1 Setup Wizard ended prematurely' message during .msi install
Submitted: 9 Jun 2009 22:52 Modified: 17 Aug 2009 16:37
Reporter: Levan Jgharkava Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:Community 5.1.35+ (also verified on 5.1.36, 5.4.1-beta), Enterprise 5.1.34sp1+ OS:Microsoft Windows (2003 Server 64 bit)
Assigned to: Iggy Galarza CPU Architecture:Any
Tags: 64 bit install error, 64 bit mysql, install error
Triage: Triaged: D1 (Critical)

[9 Jun 2009 22:52] Levan Jgharkava
Description:
I just downloaded mysql-5.1.35-winx64.msi file and tried to install with default options but I was unable to do it. it showed this message:
----
MySQL Server 5.1 Setup Wizard ended prematurely

The wizard was interrupted before MySQL Server 5.1. could be completely installed.

Your system has not been modified. To complete installation at another time, please run setup again.

Click Finish to exit the wizard.
----

How to repeat:
just download 64 bit version of mysql 5.1.35 and try to install on 64 bit windows 2003

Suggested fix:
have no suggestion. maybe try to install manually with .zip package?
[10 Jun 2009 9:12] Sveta Smirnova
Thank you for the report.

I can not repeat described behavior. Please indicate step-by-step your actions during installation. Including options of Installer and Config Wizard you choose.
[10 Jun 2009 9:13] Sveta Smirnova
See also bug #45406 and bug #44410
[10 Jun 2009 15:24] Mark Land
This is occuring for me as well on a Dual-Core AMD Opeteron, 2.00GHz, 8GB RAM.  The progress bar gets to about 2/3rds complete and then displays the 'wizard ended prematurely' message.
[16 Jun 2009 21:59] Bry Web
I am installing the 64bit version mysql-5.1.35-winx64.msi and had the same problem,  installing on a 1and1 VPS III Server that is 8 CPU's,   I went back one version to mysql-5.0.83-winx64.zip and it installed fine until the very end which then could not start up the service,  but I had this issue before and figured it out so I should be able to again.

BryWeb
[16 Jun 2009 22:01] Bry Web
PS: My CPU's were 8 way Operton Quad Core 2352 Processors on a VPS (Virtual Server)
[17 Jun 2009 17:04] Roland Baer
Hi,
use 5.1.34, it's installing and running fine. There is the same problem with the 32 bit version.
[30 Jun 2009 16:59] Jason Carpenter
Same issue here.  Here is my enviroment:

Windows 2003 R2 x64 w/ SP2 running on virtual machine

Physical Server Specs:

- HP DL360 G5
- 2x 2.3 GHz Quad Core Xeon Processors
- 12 GB RAM
- RAID 5 Array
- VMware ESXi 4.0.0, 164009 embedded edition.
- 2x Network adapters teamed.

Virtual Machine Specs: 

- Virtual machine is configured for 4 vCPUs (Tried dropping down to 2 vCPU, received same errorr)
- 2 GB of RAM
- 20 GB System volume
- 60 GB Data volume
- Single virtual network adapter
- Virtual LSI Logic Parallel SCSI adapter

Version 5.1.34 appears to be installing correctly.
[1 Jul 2009 7:58] Sveta Smirnova
All reporters: please indicate your step-by-step actions during
installation. Including options of Installer and Config Wizard you choose.
[1 Jul 2009 9:39] Jim Griffiths
Running a brand new 2003 Win Server. Trying to install the mysql-5.1.35-win32.msi and I get the same error as above. The installer wizard using the Typical install option (I've tried Custom and Full and got the same error) I get the error "MySQL Server 5.1 Setup Wizard ended prematurely" .

Please help.
[1 Jul 2009 13:18] Karl Tschaepe
Installing the 32 bit version on Windows 2003, complete install, and getting the same result. I did stop the MySQL Service first. I had thought this might be a security issue in Win 2003, until I got into this string. Any thoughts?
[3 Jul 2009 0:43] Chris Hemphill
I am also running into this.  Detailed steps:

1. Download the 5.1.35.msi installer
2. Double click on the installer
3. Accept all defaults

This happens without fail every time.
[4 Jul 2009 7:49] Amol Sathe
We also faced the same problem. Better to go back to older version
[5 Jul 2009 20:20] Arnold Bailey
I had the same problem with 5.1.35 ending prematurly on Windows 2003 Standard Server. The solution in my case was to Right click on the .MSI file and at the bottom of the properties dialog click the UNBLOCK button.

Because the installer is downloaded it is automatically blocked from running by Windows security, ast least on 2003. Normally it will just ask if you want to run the file when you start the install and then install. For some reason the Block has to be removed for this install or it fails.
[8 Jul 2009 12:22] Jerry West
The "msi > Properties > Unblock" work-around does NOT work for us on a *32bit* install of 5.1.36.  We had to go back to 5.1.34 for a successful install.
[8 Jul 2009 13:06] Arnold Bailey
Yes the Unblock seems to have been a fluke. It works once in a great while so it isn't the underlying problem. This so far seems to be restricted to Windows server 2003. I tried it on a 2008 machine and it is working fine.

On the 2003 machine I had a clean install with only the Window update criticals modifying it. Very frustrating.
[8 Jul 2009 14:03] Alejandro Villarreal
Got the same error, to Fix it I just edit my Virtual machine and put a Single CPU and the installation pass without a problems...

Hope this help you all ;)
[10 Jul 2009 11:16] Andy Helsby
Same problem with 5.1.35 here on a real windows 2003 web edition server.
Typical installation or custom with a different data path.
Interesting that 5.1.35 from mysql is 100mb download, the 5.1.34 is 35mb download from filehippo (but it doesn't include documentation)
Gone back to the 5.1.34 from filehippo http://www.filehippo.com/download_mysql/tech/5525/ as the mysql page only links to the current version (that I could see)
[12 Jul 2009 12:02] Andrii Nikitin
may be related to bug #44428
[13 Jul 2009 9:27] Jon Shaw
Same problem here upgrading from 5.1.31 Enterprise to 5.1.36 (32 Bit Version)

Custom install, only difference is a different path to the default settings (Program and data). Tried with service started, and service stopped - both failed.

Hardware: Dedicated MySQL server. Windows 2003 standard, Intel Xeon 3.1Ghz (4 CPUs) and 4GB RAM.
[13 Jul 2009 15:44] Michael Therrien
Verified bug. Installing (defaults) on a 32-bit 3GHz Xeon with 6GB of RAM on physical server. Tried to "Unblock" with no positive results.
Reverted to 5.1.34 and it worked fine.
[16 Jul 2009 4:10] Roel Van de Paar
Bug verified as described.

Binary used: http://dev.mysql.com/get/Downloads/MySQL-5.1/mysql-5.1.35-winx64.msi/from/pick#mirrors

Server used: Windows Server 2003 x64, Version 5.2 (Build 3790.srv03_sp2_gdr.090319-1204 : Service Pack 2)

Issue is *always* repeatable, whichever installation option (typical, complete, custom) is selected. Even if one tries to install just the documentation (and nothing else), it fails.

Workaround: none found (using the .msi package). One could try to install manually not using the .msi installer.
[16 Jul 2009 4:40] Roel Van de Paar
Tested, and is affecting 5.1.36 and 5.4.1-beta as well, same error.

http://dev.mysql.com/get/Downloads/MySQL-5.4/mysql-5.4.1-beta-winx64.msi/from/pick
http://dev.mysql.com/get/Downloads/MySQL-5.1/mysql-5.1.36-winx64.msi/from/pick#mirrors
[16 Jul 2009 5:14] Sveta Smirnova
Bug #45406 and bug #44410 were marked as duplicates of this one.
[16 Jul 2009 23:43] Roel Van de Paar
Bug #46020 was marked as a duplicate of this one.
[17 Jul 2009 2:28] Roel Van de Paar
Verified that issue does not exist on 5.1.34
[17 Jul 2009 2:47] Roel Van de Paar
Issue exists on Enterprise 5.1.34sp1
Issue does not exist on Enterprise 5.1.34
[18 Jul 2009 14:54] Andy Helsby
Just a comment that the MySQL Team are aware of this issue and are working on it. They replied to my tweet to let me know this so hopefully something will come along soon. http://twitter.com/mysql/status/2668568954
[30 Jul 2009 16:23] Greg Jackson
I had the same issue with an 32-bit install of Windows 2003 Server running on a Dell Optiplex GX520.

Based on hints from this thread, I was able to achieve a workaround.  I disabled hyperthreading in the computer BIOS.  The installer for MySQL 5.1.36 then runs to completion.

After install, I re-enabled hyperthreading.  The MySQL instance started normally after restart with hyperthreading enabled.

I have never seen this kind of installer issue before, and I still hope for a fix in 5.1.38 as targeted.  I hope this workaround works for others.
[30 Jul 2009 19:49] Brandon Runnels
Also had this issue using clean Microsoft Windows (2003 Server) VM image. Using multiple CPU's. I had to drop it down to single CPU in order for the mysql-5.1.36-win32.msi to work.
[1 Aug 2009 6:29] Sveta Smirnova
Bug #46503 was marked as duplicate of this one.
[3 Aug 2009 15:24] AEM TISup
Just tested version 5.1.37 on Windows Server 2003-32bit and bug is still present.
[3 Aug 2009 19:56] Patrick Crews
Tested on Windows 2003 64 bit.  Verified bug with an older .msi and that the proposed patch to the .msi works as expected.  Ok to push.

I ran into one issue that needs to be discussed with Iggy (see attached picture file).

Basically, I did the following:
1)  tried installing 5.1.35 64 bit (to verify the failure)
2)  Installed 5.1.36 (test .msi)
3)  Chose both Typical and Complete (on different runs)
4)  The installation halted with ERROR 1312 Cannot Create Directory C:/Program Files/MySQL...

I have attached a log file as well as a screen shot of the error.  I was unable to just delete the directory as it is being used by other people.  However, a Custom Install using a different location worked perfectly.
[4 Aug 2009 11:09] Sai Fujiwara
I found a solution to this bug:
1,download and install orca, an editor to msi files.
2,open mysql5.135+ msi file and search "SetDateTime" and u will find a row,its target value is "CASetRegDateTime",delete this row and save(notice: don't use "save as",if use "save as",the msi file will be corrupted and u can't install)
3,double-click mysql msi file,the installation will go smoothly.

Reason:

In cmd mode, execute mysql msi installation with a log, "msiexec /i mysql.msi /lv a.txt".When the installation fails,open a.txt and search "return value 3".u will find the following:

Action start 17:31:02: SetDateTime.
MSI (s) (3C:80) [17:31:02:140]: Note: 1: 2235 2:  3: ExtendedType 4: SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM `CustomAction` WHERE `Action` = 'SetDateTime' 
MSI (s) (3C:EC) [17:31:02:140]: Invoking remote custom action. DLL: D:\WINDOWS\Installer\MSIC4.tmp, Entrypoint: CASetRegDateTime
Action ended 17:31:02: SetDateTime. Return value 3.

it is the first "return value 3" in a.txt, so it is the problem causing the setup wizard end prematurely.So I use a msi editor(ocra) to delete "SetDateTime" action in mysql msi file and the installation can go smoothly.

because I don't know what this modification will bring to mysql,please don't use this method in production.
In my private test,I don't find any problems.My method can solve this installtaion's problem, but it is a big bug indeed, especially it has existed in mysql three versions and other mysql products such as .net connector 6.0's msi.

Wish the msi error log can help the real solution to this bug. the reason causing failure is the following:

Action start 17:31:02: SetDateTime.
MSI (s) (3C:80) [17:31:02:140]: Note: 1: 2235 2:  3: ExtendedType 4: SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM `CustomAction` WHERE `Action` = 'SetDateTime' 
MSI (s) (3C:EC) [17:31:02:140]: Invoking remote custom action. DLL: D:\WINDOWS\Installer\MSIC4.tmp, Entrypoint: CASetRegDateTime
Action ended 17:31:02: SetDateTime. Return value 3.
[5 Aug 2009 4:33] LockeVN Thach Nguyen
I still have bug.

MySQL Community 5.1.37, MSI, >100MB
Windows Server 2003 R2 SP2, 32bit (clean install, and then add .NET 3.5 Framework)
Physical Xeon E5420, 4GB RAM

Download, install (typical, custom), next next next

--> ended prematurely
[5 Aug 2009 23:37] Jamie Lara
Sai Fujiwara fix worked for me!
[6 Aug 2009 15:24] MASSIMO PETRINI
Wonderful! The solution run correctly also in 32 bit version 5.1.37
[6 Aug 2009 17:11] Erik Arvidson
Alternatively, if you don't want to download Orca or don't want to modify the Windows Installer package (and you really shouldn't want to), you can apply a transform that will make the same change. I have generated a transform for mysql-5.1.37-win32.msi for my own needs; it's located at http://preview.tinyurl.com/lzfbsg.

You can apply it by executing: %SystemRoot%\System32\msiexec.exe /i mysql-5.1.37-win32.msi TRANSFORMS=mysql-5.1.37-win32.mst.

This transform may work with other Windows Installer packages; if it does not, contact me and I'll be more than happy to generate another for your needs.
[6 Aug 2009 21:40] D W
the transform program works great. Thanks to erik
[10 Aug 2009 23:16] Michael Po
I followed instruction set by Sai Fujiwara and it worked perfectly
[4 Aug 13:09] Sai Fujiwara
[13 Aug 2009 17:24] Michael (Meiki) Lev
Erik Arvidson's transform did the trick.
Thank you Erik !
Meiki
[17 Aug 2009 16:37] MC Brown
A note has been added to the respective changelogs: 

A Windows Installation using the GUI installer would fail with:

MySQL Server 5.1 Setup Wizard ended prematurely

The wizard was interrupted before MySQL Server 5.1. could be completely installed.

Your system has not been modified. To complete installation at another time, please run
setup again.

Click Finish to exit the wizard
This was due to an step in the MSI installer that could fail to execute correctly on some environments.
[17 Aug 2009 22:47] Drew Redfield
Erik's transform trick worked great on my server as well!  THANKS!
[18 Aug 2009 6:55] MC Brown
Correction to changelog versions: 

5.1.38, 5.4.4, 5.0.85, 4.1.26
[24 Aug 2009 8:43] Kei Tsuji
Bug #46879 was marked as duplicate of this one.
[24 Aug 2009 17:23] Eduardo Rihan
Thanks to Sai Fujiwara and Erik Arvidson, both solutions worked for me, with a real Windows Server 2003 Standard Edition with SP2 and Quad-core Intel Xeon X3363.
[26 Aug 2009 22:56] Steven Lim
Thanks Sai Fujiwara, you da best!  It works.
[27 Aug 2009 4:45] Paul Hirsch
Sai's solution in a quick, detailed step-by-step:
Issue 1: be sure to go with MicroSoft on Orca, don't just search google and go for the first link.

Didn't have to delete the line, just change the target to the correct one.

Able to change it to CASetDateTime instead of CASetRegDateTime and it's much happier.  

Took about 10 minutes to figure out.  
Might take you only 3-5m if you follow these steps:

1: Download the MS Orca tool:
http://www.microsoft.com/downloads/details.aspx?FamilyId=A55B6B43-E24F-4EA3-A93E-40C0EC4F6...
--- might need to start with this page: http://support.microsoft.com/kb/255905

2: Do a custom install, installing only the "Microsoft Windows Installer SDK" option.  (left click all other options and choose "Will not be available")

3: Use defaults (or custom dir if you want) and finish the install.

4: Navigate to the BIN dir of the install and double-click the Orca.msi to run.  My defaulted install dir was C:\Program Files\Microsoft Platform SDK\Bin

5: Go back to the downloaded location of any of the .msi files you downloaded (mine was mysql-essential-5.1.37-win32.msi)

6: Right click the file, choose Edit with Orca

7: Control-F to Find "SetDateTime"

8: Change the Target from "CASetRegDateTime" to "CASetDateTime"

9:  Control-S (Save)
10: Alt-F4    (Exit)
11: Run the installer (double-click on mysql-essential-5.1.37-win32.msi)

On with your evening of installing stuff.  

Thanks Sai!

P.S. had to write this up because otherwise people will end up installing an extra, likely not needed, 800+ MB of junk (that the windows SDK will make you download some of, surely taking more time).

P.P.S.
[28 Sep 2009 19:51] Megan Willesen
Thank you Erik!  The transform worked great (version 5.1.34).
[12 Oct 2009 14:11] Paul Dubois
Noted in 5.0.84sp1 changelog.
[12 Mar 2010 19:55] Paul Dubois
Noted in 5.5.3 changelog.
[27 May 2013 22:29] Roel Van de Paar
spam ^ ?