Bug #45136 log-slow-slave-statements doesn't work in 5.1.34
Submitted: 27 May 2009 15:18 Modified: 27 May 2009 19:45
Reporter: Aleksandr Kuzminsky Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.1.34-log OS:Any
Assigned to:
Tags: replication, slow log
Triage: Triaged: D3 (Medium)

[27 May 2009 15:18] Aleksandr Kuzminsky
Description:
As mentioned in http://bugs.mysql.com/?id=45014 log-slow-slave-statements can be set in 5.1.34, but it is not shown in SHOW VARIABLES;.
While being silently accepted the option doesn't work

How to repeat:
Set up master->slave replicaton.
On the slave set

long_query_time=0
slow_query_log=1
log_slow_slave_statements=1

Issue some SQL on the master:
CREATE table t1(id int);

The query isn't logged on the slave.
Queries which are run on the slave are logged in a slow.log
[27 May 2009 19:39] Sveta Smirnova
Thank you for the report.

Verified as described. Bug does not exist in version 6.0
[27 May 2009 19:45] Mats Kindahl
Duplicate of BUG#45014
[28 May 2009 6:41] Vadim TKACHENKO
I would not agree this bug is duplicate.

In BUG#45014 only variable is not shown.

This bug report is about that this functionality really does not work as expected - there is no records in slow.log from replication thread, but they should be.
[28 May 2009 7:23] Mats Kindahl
Correct, but since we cannot have multiple bugs dealing with different aspects of log-slow-slave-statements all problems with log-slow-slave-statements need to be fixed under one single bug.

Please see my comment in BUG#45136.