Bug #45014 log-slow-slave-statements does not work in in 5.1.34
Submitted: 21 May 2009 17:57 Modified: 3 Jun 2009 9:57
Reporter: Aleksandr Kuzminsky Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.1.34-log OS:Any
Assigned to:
Tags: replication, slave, slow log
Triage: Triaged: D3 (Medium) / R4 (High) / E3 (Medium)

[21 May 2009 17:57] Aleksandr Kuzminsky
Description:
As per manual(http://dev.mysql.com/doc/refman/5.1/en/replication-options-slave.html#option_mysqld_log-sl...) the option appears in 5.1.21. However it is still missing in 5.1.34.

How to repeat:
mysql> SHOW GLOBAL VARIABLES LIKE 'log%';
log     ON
log_bin ON
log_bin_trust_function_creators ON
log_bin_trust_routine_creators  ON
log_error
log_output      FILE,TABLE
log_queries_not_using_indexes   OFF
log_slave_updates       ON
log_slow_queries        ON
log_warnings    1
[22 May 2009 5:39] Sveta Smirnova
Thank you for the report.

Verified as described.
[27 May 2009 19:49] Mats Kindahl
This is actually a duplicate of BUG#23300.
[28 May 2009 7:21] Mats Kindahl
Note that BUG#45136, which is marked as a duplicate, is talking about that this option does not work while this bug report talks about it not being available in the options list.  Both issues need to be fixed with this bug.

For more information, see: BUG#45136, BUG#23300, and BUG#27492
[3 Jun 2009 9:57] Mats Kindahl
Duplicate of BUG#23300, which is already fixed in 6.0.