Bug #34650 Test suite without cluster fails on Mac OS X Leopard
Submitted: 18 Feb 2008 21:36 Modified: 28 Mar 2008 19:14
Reporter: Giuseppe Maxia Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S7 (Test Cases)
Version:5.1.24 OS:Any (32-bit)
Assigned to: Alexey Kopytov CPU Architecture:Any
Tags: regression, Tests
Triage: D3 (Medium)

[18 Feb 2008 21:36] Giuseppe Maxia
Description:
Test suite for a server compiled without cluster fails on Mac OS X Leopard.

1) the following tests fail
 main.change_user 
 main.subselect_notembedded 
 rpl.rpl_row_basic_11bugs 
 rpl.rpl_start_stop_slavemysql-test-run

2) the whole test executes in 70 minutes. The same test, with the same compiling options, takes 40 minutes on Mac OS X 10.4. Notice that the older server has also a slower processor (2.0 ghz vs 2.2 ghz) and less RAM (2 GB vs 4 GB), and thus the newer OS should be faster, but it is almost twice slower.

See attached log for a sample build + run.

Already submitted as part of Bug#33217. Re-submitted here for clarity.

How to repeat:
BUILD/autorun.sh 
./configure --with-plugins=max-no-ndb 
make 
cd mysql-test 
./mtr --force
[18 Feb 2008 21:39] Giuseppe Maxia
log of build and test suite run

Attachment: leopard_no_ndb_build.log.bz2 (application/octet-stream, text), 43.22 KiB.

[19 Feb 2008 14:09] Sveta Smirnova
Thank you for the report.

Failure of change_user subselect_notembedded verified as described.

Other tests pass with current development sources.
[6 Mar 2008 16:44] Alexey Kopytov
change_user and subselect_notembedded fail on Linux/x86 too. Should be reproducible on any 32-bit machine when the binary is built w/o --with-big-tables.
[7 Mar 2008 18:19] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/43613

ChangeSet@1.2585, 2008-03-07 21:14:34+03:00, kaa@kaamos.(none) +6 -0
  Fix for bug #34650: Test suite without cluster fails on Mac OS X
                      Leopard.
  
  The change_user test failed because results of some statements
  depended on platform and server build flags.
  
  subselect_notembedded failure was a result of a bad merge from 5.0.
  
  Fixed the corresponding test cases.
[28 Mar 2008 9:21] Bugs System
Pushed into 5.1.24-rc
[28 Mar 2008 19:14] Paul Dubois
Test case changes. No changelog entry needed.
[31 Mar 2008 13:58] Bugs System
Pushed into 6.0.5-alpha
[18 Nov 2008 19:40] BJ Dierkes
This case still fails:

System: RHEL 5.2 Server i386 fully patched
MySQL 5.1.29-rc

main.subselect_notembedded     
[ fail ]
mysqltest: At line 52: query '$start $end' failed with wrong errno 2013: 'Lost connection to MySQL server during query', instead of 0...
The result from queries just before the failure was:
purge master logs before (select adddate(current_timestamp(), interval -4 day));
ERROR 42000: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'select adddate(current_timestamp(), interval -4 day))' at line 1
purge master logs before adddate(current_timestamp(), interval -4 day);
create table t1(a int,b int,key(a),key(b));
insert into t1(a,b) values (1,2),(2,1),(2,3),(3,4),(5,4),(5,5),
(6,7),(7,4),(5,3);
5
4
3
2
1
26
25
24
23
22
21
More results from queries before failure can be found in /builddir/build/BUILD/mysql-5.1.29-rc/mysql-test/var/log/subselect_notembedded.log
Aborting: main.subselect_notembedded failed in default mode. 
To continue, re-run with '--force'.
Stopping All Servers
[19 Nov 2008 6:32] Alexey Kopytov
Please resubmit that as a separate bug report. The original test case failure reported in this bug resulted in only test case changes, whereas in your case there is a server crash ('Lost connection to MySQL server during query'). It is very unlikely that these two failures are related.
[19 Nov 2008 18:24] BJ Dierkes
Thank you.

Submitted http://bugs.mysql.com/bug.php?id=40862