Bug #32405 testsuite parts: partition_char_myisam wrong content
Submitted: 15 Nov 2007 12:58 Modified: 21 Nov 2007 20:30
Reporter: Matthias Leich Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.1 OS:Any
Assigned to: Matthias Leich CPU Architecture:Any

[15 Nov 2007 12:58] Matthias Leich
Description:
I found during bug maintenance within the partitioning
testsuite that partition_char_myisam wrong runs the
wrong tests.
 

How to repeat:
Please compare
suite/parts/t/partition_char_innodb.test
suite/parts/t/partition_char_myisam.test
suite/parts/t/partition_special_myisam.test.
[16 Nov 2007 21:04] Matthias Leich
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/37981

ChangeSet@1.2622, 2007-11-16 21:39:01+01:00, mleich@five.local.lan +121 -0
  Fix for bug
       Bug#31610 Remove outdated and redundant tests:
                 partition_02myisam partition_03ndb
       Bug#32405 testsuite parts: partition_char_myisam wrong content
  and cleanup of testsuite
    - remove/correct wrong comments
    - remove workarounds for fixed bugs
    - replace error numbers with error names
    - exclude subtests from execution which fail now because of
      new limitations for partitioning functions
    - remove code for the no more intended dual use
      fast test in regression tests/slow test in testsuite
    - analyze and fix problems with partition_char_innodb
[20 Nov 2007 17:25] Matthias Leich
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/38145

ChangeSet@1.2629, 2007-11-20 16:04:07+01:00, mleich@five.local.lan +121 -0
  Fixes for the bugs
         Bug#31610 Remove outdated and redundant tests:
                   partition_02myisam partition_03ndb
         Bug#32405 testsuite parts: partition_char_myisam wrong content
  and cleanup of testsuite
     - remove/correct wrong comments
     - remove workarounds for fixed bugs
     - replace error numbers with error names
     - exclude subtests from execution which fail now because of
       new limitations for partitioning functions
     - remove code for the no more intended dual use
       fast test in regression tests/slow test in testsuite
     - analyze and fix problems with partition_char_innodb
     - fix problems caused by last change of error numbers
     - Introduce error name to error number mapping which makes
       maintenance after next error renumbering easier
[20 Nov 2007 17:53] Matthias Leich
Pushed to
mysql-5.1-build
mysql-6.0-build

Maintenance of tests, no documentation needed.
[21 Nov 2007 18:54] Bugs System
Pushed into 5.1.23-rc
[21 Nov 2007 18:54] Bugs System
Pushed into 6.0.4-alpha
[21 Nov 2007 20:30] Paul Dubois
Test case changes. No changelog entry needed.