Bug #31610 Remove outdated and redundant tests: partition_02myisam partition_03ndb
Submitted: 15 Oct 2007 13:56 Modified: 21 Nov 2007 20:28
Reporter: Matthias Leich Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version:5.1 OS:Any
Assigned to: Matthias Leich CPU Architecture:Any
Tags: 5.1

[15 Oct 2007 13:56] Matthias Leich
Description:
The tests
   t/partition_02myisam.test
and
   ndb/t/partition_03ndb.test
and auxiliary scripts sourced by them are
- missing maintenance
  Some code sequencies are disabled because of
  old but now fixed Partitioning bugs.
- outdated
  The scripts above were a snapshot of an early stage
  of the partitioning test development and never
  intended for being part of the final 5.1 
  partitioning checks.
  The final partitioning testsuite is
  - stored within mysql-test/suite/parts
  - better (hopefully) maintained
  - covers everything checked within the tests above + more.
Therefore a removal of the scripts above does not decrease
coverage but save space and runtime.

How to repeat:
Compare the tests above with the
partitioning testsuite.

Suggested fix:
Remove the tests
   t/partition_02myisam.test
and
   ndb/t/partition_03ndb.test
and auxiliary scripts sourced by them.
[13 Nov 2007 18:39] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/37689

ChangeSet@1.2619, 2007-11-13 19:39:45+01:00, mleich@five.local.lan +10 -0
  Fix for
     Bug#31610 Remove outdated and redundant tests:
               partition_02myisam partition_03ndb
  Modification: Remove
  - toplevel test scripts (extension 'test')
  - files with expected results (extension 'result')
  - auxiliary scripts (extension 'inc') which are used
    by these tests only
  
  Note:
  1. There is no loss in testing coverage because the
     final partitioning testsuite is already stored within
     mysql-test/suite/parts.
     The tests to be removed are only an early snapshot of
     this testsuite.
  2. The unusual way (bk mv ....; bk rm ...) to drop the files
     is caused by the fact the BK failed to create a changeset
     when I used "bk rm ..." only.
[16 Nov 2007 14:38] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/37950

ChangeSet@1.2623, 2007-11-16 15:37:51+01:00, mleich@five.local.lan +112 -0
  Fix for bug
     Bug#31610 Remove outdated and redundant tests:
               partition_02myisam partition_03ndb
     Bug#32405 testsuite parts: partition_char_myisam wrong content
  cleanup
  - remove/correct wrong comments
  - remove workarounds for fixed bugs
  - replace error numbers with error names
  - exclude subtests from execution which fail now because of
    new limitations for partitioning functions
  - remove code for the no more intended dual use
    fast test in regression tests/slow test in testsuite
  - analyze and fix problems with partition_char_innodb
[16 Nov 2007 20:39] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/37981

ChangeSet@1.2622, 2007-11-16 21:39:01+01:00, mleich@five.local.lan +121 -0
  Fix for bug
       Bug#31610 Remove outdated and redundant tests:
                 partition_02myisam partition_03ndb
       Bug#32405 testsuite parts: partition_char_myisam wrong content
  and cleanup of testsuite
    - remove/correct wrong comments
    - remove workarounds for fixed bugs
    - replace error numbers with error names
    - exclude subtests from execution which fail now because of
      new limitations for partitioning functions
    - remove code for the no more intended dual use
      fast test in regression tests/slow test in testsuite
    - analyze and fix problems with partition_char_innodb
[20 Nov 2007 15:04] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/38145

ChangeSet@1.2629, 2007-11-20 16:04:07+01:00, mleich@five.local.lan +121 -0
  Fixes for the bugs
         Bug#31610 Remove outdated and redundant tests:
                   partition_02myisam partition_03ndb
         Bug#32405 testsuite parts: partition_char_myisam wrong content
  and cleanup of testsuite
     - remove/correct wrong comments
     - remove workarounds for fixed bugs
     - replace error numbers with error names
     - exclude subtests from execution which fail now because of
       new limitations for partitioning functions
     - remove code for the no more intended dual use
       fast test in regression tests/slow test in testsuite
     - analyze and fix problems with partition_char_innodb
     - fix problems caused by last change of error numbers
     - Introduce error name to error number mapping which makes
       maintenance after next error renumbering easier
[20 Nov 2007 17:21] Matthias Leich
Push to
mysql-5.1-build
mysql-6.0-build
[20 Nov 2007 17:51] Matthias Leich
Maintenance of tests, no documentation needed.
[21 Nov 2007 18:54] Bugs System
Pushed into 5.1.23-rc
[21 Nov 2007 18:54] Bugs System
Pushed into 6.0.4-alpha
[21 Nov 2007 20:28] Paul Dubois
Test case changes. No changelog entry needed.