Bug #32219 too many hosts in default grant tables 6.0.3
Submitted: 9 Nov 2007 10:39 Modified: 21 Dec 2007 16:52
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:mysql-noinstall-6.0.3-alpha-win32.zip OS:Microsoft Windows
Assigned to: Timothy Smith CPU Architecture:Any
Triage: D3 (Medium)

[9 Nov 2007 10:39] Shane Bester
Description:
the default grants contain production.mysql.com, when they shouldn't

mysql> select * from user;
+----------------------+------+----------+-------------+-------------
| Host                 | User | Password | Select_priv | Insert_priv
+----------------------+------+----------+-------------+-------------
| localhost            | root |          | Y           | Y
| production.mysql.com | root |          | Y           | Y
| 127.0.0.1            | root |          | Y           | Y
| localhost            |      |          | N           | N
| production.mysql.com |      |          | N           | N
+----------------------+------+----------+-------------+-------------
5 rows in set (0.02 sec)

How to repeat:
unzip mysql-noinstall-6.0.3-alpha-win32.zip

mysqld-debug --console --skip-name-resolve

mysql -uroot mysql
select * from user;

Suggested fix:
remove production.mysql.com
[23 Nov 2007 23:54] Paul Dubois
Bug#32686 was marked as a duplicate of this one.
[29 Nov 2007 22:17] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/38894

ChangeSet@1.2584, 2007-11-29 15:16:42-07:00, tsmith@ramayana.hindu.god +3 -0
  Bug #32219: too many hosts in default grant tables 6.0.3
  
  Fix is to remove any references to the current hostname when running
  mysql_install_db --cross-bootstrap.  (The dist-hook make target makes
  this call, and the resulting data directory is included in the source
  distribution as win/data/*.)
  
  Also, a few other clean-ups to mysql_install_db while there.
[30 Nov 2007 5:14] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/38924

ChangeSet@1.2584, 2007-11-30 06:14:43+01:00, tsmith@mysql.com +3 -0
  Bug #32219: too many hosts in default grant tables 6.0.3
  
  Fix is to remove any references to the current hostname when running
  mysql_install_db --cross-bootstrap.  (The dist-hook make target makes
  this call, and the resulting data directory is included in the source
  distribution as win/data/*.)
  
  Also, a few other clean-ups to mysql_install_db while there.
[11 Dec 2007 14:50] Bugs System
Pushed into 5.0.52
[11 Dec 2007 14:51] Bugs System
Pushed into 5.1.23-rc
[11 Dec 2007 14:51] Bugs System
Pushed into 6.0.5-alpha
[21 Dec 2007 16:52] Paul Dubois
Noted in 5.0.52, 5.1.23, 6.0.5 changelogs.

The default grant tables on Windows contained information
for host production.mysql.com, which should not be there.
[19 Mar 2008 11:47] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=35421 was marked as duplicate of this
one.