Bug #31490 The funcs_1 test "falcon_func_view" fails due to differences in a datetime col
Submitted: 9 Oct 2007 20:18 Modified: 3 Dec 2007 14:24
Reporter: Horst Hunger Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Falcon storage engine Severity:S2 (Serious)
Version:6.0.4-alpha-debug OS:Linux (Suse 10.2)
Assigned to: Christopher Powers CPU Architecture:Any

[9 Oct 2007 20:18] Horst Hunger
Description:
The value "0001-01-01 00:00:00" was changed to "2001-01-01 00:00:00" for a column of type datetime. Further tesimg shows that the range for year from 0070 to 0099 is changed to 1970 to 1999, the range from 0000 to 0069 is changed to 2000 to 2069. 
If that behaviour is desired, then a switch is necessary to have a possibility to use the ranges about without changing them and it must be described in the manual.

How to repeat:
put the attached test into "mysql-test/t" and execute
./mysql-test-run.pl --bug
[10 Oct 2007 1:05] Miguel Solorzano
Thank you for the bug report.
[19 Oct 2007 16:16] Kevin Lewis
This is a duplicate of Bug#22168
[26 Oct 2007 15:21] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/36439

ChangeSet@1.2653, 2007-10-26 10:21:08-05:00, chris@xeno.mysql.com +1 -0
  Bug#31490 "The funcs_1 test falcon_func_view fails due to differences in a datetime col"
  
  Added DATETIME testcase to Falcon suite.
[26 Oct 2007 15:23] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/36440

ChangeSet@1.2654, 2007-10-26 10:23:31-05:00, chris@xeno.mysql.com +2 -0
  Bug#31490 "The funcs_1 test falcon_func_view fails due to differences in a datetime col"
  
  Added DATETIME test to Falcon suite.
[26 Oct 2007 15:27] Christopher Powers
Testcase succeeds. Added testcase as falcon_bug_31490.test to Falcon suite.
[30 Nov 2007 17:27] Hakan Küçükyılmaz
Test passes now:

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

falcon.falcon_bug_31490        [ pass ]            173
-------------------------------------------------------
Stopping All Servers
All 1 tests were successful.
The servers were restarted 1 times
Spent 0.173 of 6 seconds executing testcases
[30 Nov 2007 20:42] Bugs System
Pushed into 6.0.4-alpha
[3 Dec 2007 14:24] MC Brown
A note has been added to the 6.0.4 changelog: 

When inserting dates into a DATETIME column with a Falcon, the values would automatically be converted with values between 70 and 99 converted to 1970-1999, and values from 00 to 69 converted to 2000 to 2069.