Bug #16178 Parse Password - Unable to Connect
Submitted: 4 Jan 2006 8:13 Modified: 3 Dec 2007 7:28
Reporter: Henrik Binggl Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:5.1 OS:Microsoft Windows (Win XP)
Assigned to: Jess Balint CPU Architecture:Any

[4 Jan 2006 8:13] Henrik Binggl
Description:
Unable to connect if password contains "special" chars.
e.g. #@ZU34;_

Only ODBC Driver is affected, "normal" connections with Client or MySQL-Admin
work.

MyODBC 3.51.12
MySQL    4.1.12 - RHEL 4.0

How to repeat:
Use "special" chars in password
e.g. #@ZU34;_

Suggested fix:
Handle "special" chars correctyl.
[4 Jan 2006 14:01] MySQL Verification Team
I noticed that the 'special character' which makes MyODBC to fails
is the semicolon ;. However the mysql client accepts.
[17 Jul 2007 12:38] Susanne Ebrecht
http://bugs.mysql.com/bug.php?id=29572 is a duplicate of this.
[27 Jul 2007 23:11] Jim Winstead
Jess looked into this a little bit, and it looked like the driver manager was screwing this up.

Perhaps we should store the password in the DSN as a hex-encoded string, or something clever like that.
[31 Jul 2007 1:09] Jim Winstead
Fixing this is going to require too many code changes to do in the 3.51 series. We'll get to it for the next major release.
[22 Sep 2007 15:06] Jim Winstead
Bug #31028 was marked as a duplicate of this bug.
[1 Oct 2007 14:34] Susanne Ebrecht
Bug #31007 is marked as duplicate of this bug
[17 Oct 2007 13:53] Susanne Ebrecht
Bug #22298 is a duplicate of this bug here.
[7 Nov 2007 16:53] Jess Balint
Fixed handling of semi-colon in escaped values.
[7 Nov 2007 16:53] Jess Balint
bugfix

Attachment: bug16178.diff (application/octet-stream, text), 1.15 KiB.

[20 Nov 2007 23:37] Jess Balint
Fix committed in rev853, will be released in 5.1.1.
[3 Dec 2007 7:28] MC Brown
A note has been added to the 5.1.1 changelog: 

Connector/ODBC would fail to connect to the server if the password contained certain characters, including the semicolon and other punctuation marks.