Bug #103680 boost.cmake does not download boost from dl.bintray.com.
Submitted: 13 May 9:56 Modified: 13 May 10:04
Reporter: Takanori Sejima Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:8.0 OS:Linux
Assigned to: CPU Architecture:Any
Tags: cmake, DOWNLOAD_BOOST

[13 May 9:56] Takanori Sejima
Description:
I think cmake's DOWNLOAD_BOOST option has stopped working in MySQL 8.0 since May 2021. This is because when DOWNLOAD_BOOST is enabled, it refers to the following URL.

https://dl.bintray.com/boostorg/release/1.73.0/source/${BOOST_TARBALL}

see the code:
https://github.com/mysql/mysql-server/blob/98b2ccb470de120d36bc4a623c814cdfded958ec/cmake/...

References:
https://jfrog.com/blog/into-the-sunset-bintray-jcenter-gocenter-and-chartcenter/
> To streamline the productivity of the JFrog Platform we will be sunsetting Bintray, GoCenter, and ChartCenter services on May 1st, 2021. 

How to repeat:
$ mkdir -p ~/src/{boost,mysql}
$ cd ~/src/mysql
$ wget https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-8.0.25.tar.gz
$ tar xvf mysql-8.0.25.tar.gz
$ cd mysql-8.0.25
$ mkdir bld
$ cd bld
$ cmake ..-DWITH_DEBUG=1 -DDOWNLOAD_BOOST=1 -DWITH_BOOST=~/src/boost        

I get the following error message.

-- Download failed, error: 22;"HTTP response code said error"
CMake Error at cmake/boost.cmake:232 (MESSAGE):
  You can try downloading
  https://dl.bintray.com/boostorg/release/1.73.0/source/boost_1_73_0.tar.gz
  manually using curl/wget or a similar tool
Call Stack (most recent call first):
  CMakeLists.txt:1147 (INCLUDE)
[13 May 10:04] MySQL Verification Team
Hello Takanori Sejima,

Thank you for the report and feedback.
Imho this is duplicate of Bug #103611, please see Bug #103611

regards,
Umesh
[13 May 10:06] MySQL Verification Team
Also - https://bugs.mysql.com/bug.php?id=103667