Bug #103667 Download Boost failed, error: 22;"HTTP response code said error"
Submitted: 12 May 7:52 Modified: 13 May 6:44
Reporter: Quella Zhang Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:branch 8.0 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[12 May 7:52] Quella Zhang
Description:
Hi All,

MySQL failed to download Boost library when running cmake command and gave error "Download failed, error: 22;"HTTP response code said error"", could you help check this? Thanks.

We try to access to website https://dl.bintray.com/boostorg/release/1.73.0/source/boost_1_73_0.tar.gz but access is forbidden.

Error info:
F:\gitP\mysql\mysql-server\build_x64>cmake -G "Visual Studio 16 2019" -A x64 -DCMAKE_SYSTEM_VERSION=10.0.18362.0 -DDOWNLOAD_BOOST=1 -DWITH_BOOST=F:\tools\mysql\boost\x64 ..
-- Running cmake version 3.19.6
-- NT_RELEASE_VERSION is Version     10.0.14393
-- CMP0073 OLD
-- CMAKE_MODULE_PATH is F:/gitP/mysql/mysql-server/cmake
-- MySQL 8.0.25
-- Source directory F:/gitP/mysql/mysql-server
-- Binary directory F:/gitP/mysql/mysql-server/build_x64
-- CMAKE_GENERATOR: Visual Studio 16 2019
-- MSVC_VERSION is 1930
-- SIZEOF_VOIDP 8
-- Packaging as: mysql-8.0.25-winx64
-- Downloading boost_1_73_0.tar.gz to F:/tools/mysql/boost/x64
-- Download failed, error: 22;"HTTP response code said error"
CMake Error at cmake/boost.cmake:232 (MESSAGE):
  You can try downloading
  https://dl.bintray.com/boostorg/release/1.73.0/source/boost_1_73_0.tar.gz
  manually using curl/wget or a similar tool
Call Stack (most recent call first):
  CMakeLists.txt:1147 (INCLUDE)

-- Configuring incomplete, errors occurred!
See also "F:/gitP/mysql/mysql-server/build_x64/CMakeFiles/CMakeOutput.log".

How to repeat:
How to repeat:
1.git clone -b 8.0 https://github.com/mysql/mysql-server.git mysql-server
2.mkdir build_x64 && pushd build_x64
3.cmake -G "Visual Studio 16 2019" -A x64 -DCMAKE_SYSTEM_VERSION=10.0.18362.0 -DDOWNLOAD_BOOST=1 -DWITH_BOOST=F:\tools\mysql\boost\x64 ..
[12 May 8:08] MySQL Verification Team
Hello Quella Zhang,

Thank you for the report and feedback.

regards,
Umesh
[12 May 8:10] MySQL Verification Team
Imho this is duplicate of Bug #103611, please see Bug #103611

regards,
Umesh
[12 May 16:03] Tor Didriksen
Assuming this is some kind of continuous build system,
you really shouldn't be using DOWNLOAD_BOOST. It is meant as a
convenience option for a one-off build. Pre-download whatever
boost versions you need, and set an environment variable
WITH_BOOST or BOOST_ROOT to point to it.
[13 May 6:44] Quella Zhang
Thank you, it is indeed better to use the pre-downloaded version of Boost in our build system, we will set an environment variable
WITH_BOOST or BOOST_ROOT to point to it.