Bug #103611 CMake boost URL update
Submitted: 6 May 12:51 Modified: 10 May 17:34
Reporter: Marcelo Altmann (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:8.0.24 OS:Any
Assigned to: CPU Architecture:Any

[6 May 12:51] Marcelo Altmann
Description:
JFrog has sunset Bintray, boost requires a new URL

How to repeat:
Try to compile the server where it has to download boots
[6 May 12:52] Marcelo Altmann
Fix:

diff --git a/cmake/boost.cmake b/cmake/boost.cmake
index e906f827c17..812caff69a7 100644
--- a/cmake/boost.cmake
+++ b/cmake/boost.cmake
@@ -41,7 +41,7 @@
 SET(BOOST_PACKAGE_NAME "boost_1_73_0")
 SET(BOOST_TARBALL "${BOOST_PACKAGE_NAME}.tar.gz")
 SET(BOOST_DOWNLOAD_URL
-  "https://dl.bintray.com/boostorg/release/1.73.0/source/${BOOST_TARBALL}"
+  "https://boostorg.jfrog.io/artifactory/main/release/1.73.0/source/${BOOST_TARBALL}"
   )

 SET(OLD_PACKAGE_NAMES
[6 May 12:53] Marcelo Altmann
(*) I confirm the code being submitted is offered under the terms of the OCA, and that I am authorized to contribute it.
[6 May 13:24] MySQL Verification Team
Hello Marcelo,

Thank you for the report and feedback.

regards,
Umesh
[10 May 17:34] Paul DuBois
Posted by developer:
 
Fixed in 8.0.26.

The URL for downloading Boost was updated. Thanks to Marcelo Altmann
for the contribution.
[12 May 8:10] MySQL Verification Team
Bug #103667 marked as duplicate of this one
[13 May 10:05] MySQL Verification Team
Bug #103680 marked as duplicate of this one
[8 Jun 6:38] Terje Røsten
Bug #103928 marked as duplicate of this one.