Bug #103026 sequence item 6: expected str instance, bytes found
Submitted: 18 Mar 2021 2:32 Modified: 2 Apr 2021 18:50
Reporter: Raj Padnani Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:8.0.23, 8.0.25, 8.0.26 OS:Windows (Microsoft Windows 10 Home)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[18 Mar 2021 2:32] Raj Padnani
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Raj Padnani\AppData\Roaming\MySQL\Workbench\log\wb.log]

After upgrading to 8.0.23 (from 8.0.18)

When choosing File->Run SQL Script from WorkBench Menu, I get this error:

sequence item 6: expected str instance, bytes found

How to repeat:
Choose File->Run SQL Script from workbench Menu
[18 Mar 2021 2:34] Raj Padnani
Also, After selecing the file from File->Run, I choose a Default Schema name, and if I choose Default Character Set to utf8mb4, the WB just crashes and exits!!
[18 Mar 2021 2:36] Raj Padnani
wb.log

Attachment: wb.log (application/octet-stream, text), 9.80 KiB.

[18 Mar 2021 2:37] Raj Padnani
wb log file

Attachment: wb.1.log (application/octet-stream, text), 9.64 KiB.

[18 Mar 2021 2:40] Raj Padnani
If I try to install an older version of WB, 8.0.20, the installer errors out stating a newer version is already installed. How can I circumvent this and install an older version of MySQL WB CE?

Thanks.
[19 Mar 2021 14:10] Raj Padnani
Hello,

Is there any update on this? Any help, pointers you can provide?

Thanks.
[22 Mar 2021 12:07] MySQL Verification Team
Hello Raj Padnani,

Thank you for the bug report.
Verified as described.

Regards,
Ashwini Patil
[22 Mar 2021 12:10] MySQL Verification Team
8.0.23 test results

Attachment: 103026_test_results.png (image/png, text), 45.44 KiB.

[22 Mar 2021 12:25] MySQL Verification Team
Bug #103053 marked as duplicate of this one.
[23 Mar 2021 0:56] Sebastian Bohn
I am having the exact same error come up using this version of the workbench.
[24 Mar 2021 14:43] Raj Padnani
Hello Ashwini,

This issue is really troubling me - CAN YOU PLEASE PROVIDE A RESOLUTION!!!!!!!!!!

Once again, to reiterate, Every time I do File -> Run SQL Script I get error similar to below:

Preparing...
Importing t2.sql...
Finished executing script
mysql: [ERROR] Failed to open required defaults file: c:\users\raj
mysql: [ERROR] Fatal error in defaults handling. Program aborted!
Operation failed with exitcode 1
[2 Apr 2021 18:50] Raj Padnani
Hello,

Can you please provide a resolution on this issue? 

Thanks,
Raj
[28 Apr 2021 10:49] Mikhail Babkin
You can try use MySQL command line client. I had the same problem.

My solve is use this command line client. There is I choose my schema and insert:

source C:\folder\with\dump\file.sql

Good day, Raj!
[14 May 2021 20:23] Charles Blake
I have the same problem with 8.0.25. Any solutions?
[21 Jun 2021 11:26] MySQL Verification Team
Bug #104064 marked as duplicate of this one.
[24 Jun 2021 20:16] Christophe LARATTE
Same issue for me. It is a blocking bug: I am unable to load large file in local.
[30 Jun 2021 19:42] Karl Meiser
If you are trying to load data (e.g. output from mysqldump), have you tried Data Import under Administration?

If you choose Import for Self-Contained File and click Start Import does it provide the desired results?
[30 Jun 2021 20:25] Charles Blake
If you are trying to load data (e.g. output from mysqldump), have you tried Data Import under Administration?

That did work for me. Thanks.
[22 Jul 2021 12:06] MySQL Verification Team
Bug #104383 marked as duplicate of this one.
[3 Sep 2021 3:11] Anshul Marele
Error: mysql sequence item 6: expected str instance, bytes found

Attachment: Error item6.png (image/png, text), 62.78 KiB.

[16 Sep 2021 14:29] Anthony Raffray
I tried the same operation as "[30 Jun 20:25] Charles Blake"
It works for me too.
[20 Oct 2021 19:59] Mark Phillips
issue still occurs for us in version 8.0.27
[25 Jan 17:50] Victor jjjk
Is this fixed? Any news? Still happening in 8.0.26
[4 Feb 6:36] a a
I created an account just to make this post.
Please fix this bug, it has been triggering me for a year or something now.

I'm sick of using the MySQL CLI to load dumps/large files instead of this convenient File -> Run SQL Script option in Workbench. This used to work for me just fine, what changed?

Also please add a dark mode built in theme. I understand the stance of the Workbench team thus far has been to let the OS decide the color scheme, but this doesn't work for dark mode on Windows for some reason...
[6 Apr 1:37] David Ayre
8.0.28 same error while importing a sql file via Run SQL Script...

One a side note, I honestly haven't used a buggier app than this one.  Someone needs to advocate for better testing.
[21 Jun 21:52] Roberto Solla
I get the same error, then looking at script I see it has a commentary /*!40101 SET NAMES utf8mb4 */;  then I create the  schema with utf8mb4 as character set  and default as collating sequence y it work fine.