Bug #102300 In the Workbench Confirming Server Status will cause RuntimeError
Submitted: 19 Jan 2021 23:10 Modified: 16 Apr 2021 7:23
Reporter: Naoya Eguchi Email Updates:
Status: Verified Impact on me:
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:8.0.23, 8.0.25, 8.0.27 OS:Microsoft Windows (version 10)
Assigned to: CPU Architecture:Any
Tags: In the Workbench, Server Status can not see also it clash the workbench

[19 Jan 2021 23:10] Naoya Eguchi
In the Workbench Confirming Server Status will cause RuntimeError and clash the workbench. After i upgraded the all MySQL Community products from v8.0.22 to v8.0.23.

How to repeat:
1.Downloads MySQL Community Installer 8.0.23.
※Windows (x86, 32-bit), MSI Installer.
2.Install MySQL as development mode.
3.Start MySQL Server.
4.Open the MySQL workbench.
5.At the Wellcome window, Connect to mysql(Local instance)
6.At the "Navigator", Click "Administration tab", then click "Server Status".
7.Error dialog has shown with below message,
 Cound not acquire management address for administration.
 RuntimeError: Unable to execute command chcp.
 Please make sure that the C:\Windows\System32 directory is in your PATH 
 enviroment variable.

8.In the message dialog press "cancel" button will crash the workbench.

※I checked, enviroment variable is set correctly.
※Also I tried uninstall all MySQL and installed as a new but same error occurs.
[20 Jan 2021 13:20] MySQL Verification Team
Hello Naoya Eguchi,

Thank you for the bug report.
I tried to reproduce your issue on windows 10 with workbench 8.0.23 but I am not seeing any issues at my end. 

Ashwini Patil
[20 Jan 2021 13:23] MySQL Verification Team
8.0.23 test results

Attachment: 102300_test_results.PNG (image/png, text), 289.64 KiB.

[21 Jan 2021 0:56] Naoya Eguchi
Hello Ashwini Patil

Thanks you for quick reply and confirmation.

OK then it may be my enveroment problems, 
If I found a reason then, I will add comment.
[25 Jan 2021 12:19] Florent Conta

I'm experiencing exactly the same issue after moving from Workbench 8.0.22 to Workbench 8.0.23.

My environment Path variable is correctly set and I can access chcp in the Windows 10 PowerShell.
I haven't found any workaround yet. This really looks like a regression in Workbench.
[25 Jan 2021 16:22] chelin jean-louis
je viens de réinstaller mon serveur en version 8.0.23 et j'ai l'erreur :
unable to execute command chcp please make sure that the C\Windows\System32 directory is in your PATH environment variable

il est présent dans mon PATH !!!!
[16 Apr 2021 7:23] MySQL Verification Team
I hit the same problem on Windows 10, MySQL Server 8.0.23, and WB 8.0.23 combination.
[16 Apr 2021 7:48] MySQL Verification Team
Bug #103339 marked as duplicate of this one.
[16 Apr 2021 8:04] MySQL Verification Team
To workaround the problem, change the system locale to English. To change the
system locale:

* Open language settings
* Click "Administrative language settings" at the right top of the Window
* Click "Change system locale"
* Select English (United States) for example
* Click OK
* Restart the system
[16 Apr 2021 8:05] MySQL Verification Team
The workaround above is not affordable, nor acceptable in many cases for compatibility reasons. Even if WB runs well, other application may face charset problems.
[16 Apr 2021 18:15] Marco Fillion
Woah !

I have switch to English(US) and the problem is gone.

Please, take consideration multi-languages.

Thank you !
[17 Apr 2021 7:16] Florent Conta

Thank you for your answer.
Unfortunately, changing the system locale is not an option in my case. It would be great that any system locale is supported by WorkBench, as it was before version 8.0.23.
[20 Apr 2021 5:33] MySQL Verification Team

It was my mistake. The work around is changing UI language, not system locale. I changed both, and I thought the wrong one as a work around. Try to use English UI.

[20 Apr 2021 8:25] Florent Conta
This new workaround may be fully acceptable for a production server. 
For the development computers on which I installed WB, I prefer sticking to WB 8.0.22 until the bug is fixed. Now that you identified the cause of the bug, do you have a target version for the bug fix?
[28 May 2021 10:51] MySQL Verification Team
Bug #103838 marked as duplicate of this one
[3 Aug 2021 15:00] Karen Arzumanyan
I have the same error. Changing the system locale is unacceptable.
Please correct the error. 
Windows 7 Pro x64 (Russian Local) + MySQL Community Server x64
[3 Aug 2021 20:43] MySQL Verification Team
Notice that Windows 7 it's an OS not supported;

[5 Sep 2021 16:47] 真也 岡野
I am using MySQL Workbench 8.0.26, same error occurs.

My enviroment is..

* Windows 10 Home
* Locale: Japanese

I can not change the locale my environment.
[8 Nov 2021 10:47] CANN Christophe
* MySQL Workbench 8.0.27
* Windows 10 Pro
* Locale fr-FR

Same error and changing the locale environment variable is not possible in my case.
Please take multilingual settings into account.
Thank you