Bug #101060 Cannot uninstall/repair/change mysql-connector-net 8.0.21 on Windows
Submitted: 6 Oct 2020 6:02 Modified: 6 Oct 2020 7:59
Reporter: Jiya Zhang Email Updates:
Status: Verified Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:8.0.21 64-bit, 8.0.22 OS:Microsoft Windows (Windows 10 Home)
Assigned to: CPU Architecture:Any

[6 Oct 2020 6:02] Jiya Zhang
Description:
Attempting to install MySql Connector .NET 8.0.21, but it keeps saying "Setup Wizard ended prematurely" without giving specific instructions. I tried a lot of different approaches, including: 

- uninstall from Control Panel (does not do anything)
- click repair/change in the msi file (because I installed and uninstalled it before, and moved files around between drives, which probably messed it up...)
- fix machine.config file in C drive 
- delete certain registry keys (did not find the keys in registry editor that seemed to solve this issue for others)
- install an older version of mysql-connector-net (did not allow because it says an older version is already installed) 

I searched everywhere for hours and hours, but could not find a solution that fixes this for me. Also, what would be the last resort option (since I moved files around in drives)? 

I'm including a verbose logging file that was output after I tried to force uninstall mysql-connector-net.8.0.21 from the command prompt:

msiexec /x "C:\Users\Downloads\mysql-connector-net-8.0.21.msi" /L*V "C:\temp\mylog.log"

However, after this step, mysql connector net is still in the control panel.

How to repeat:
Download mysql-connector-net.8.0.21.msi and install. Move the corresponding folder in C:\Program Files\ to D:\. Then, delete the folder in D:\ (or move it back to C drive and then delete it). Then, run the msi file again, trying to repair/uninstall it.
[6 Oct 2020 6:04] Jiya Zhang
Verbose logging after attempting to force uninstall in command prompt; did not succeed in uninstalling.

Attachment: mylog.log (application/octet-stream, text), 225.67 KiB.

[6 Oct 2020 7:59] MySQL Verification Team
Hello Jiya Zhang,

Thank you for the report and feedback.
Observed this on one of my testing box.

regards,
Umesh
[9 Oct 2020 19:01] Gustavo Cuatepotzo
Hello Jiya Zhang,

 As you mentioned before, this is caused by doing manual manipulation of the
files, that makes the behavior unpredictable.

At this point the only workaround you could do is trying to remove from the
registry ALL the references to the string "Connector Net" .

in some cases you will need to remove an entire group in the left side, like
in this case:
Computer\HKEY_CLASSES_ROOT\Installer\Products\5C4BB67B4E04C2D4A881C8583C400D48
, here you need to delete from Products folder the entire key and subkeys for
5C4BB67B4E04C2D4A881C8583C400D48

from all these entries: you also need to remove the entire key and subkeys
which references Connector Net
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installe
r\UserData\S-1-5-18\Components\
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installe
r\UserData\S-1-5-18\Products\
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.5.
50709\AssemblyFoldersEx\MySQL Connector Net 8.0.21 v4.5.1
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVers
ion\Uninstall\{B76BB4C5-40E4-4D2C-8A18-8C85C304D084}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\MySQL AB\MySQL Connector/Net

in other cases like in
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installe
r\Folders, you only need to remove the entries in the right side which
mention Connector Net, will be something like this:
C:\Program Files (x86)\MySQL\MySQL Connector Net 8.0.21\
C:\Program Files (x86)\MySQL\MySQL Connector Net 8.0.21\Assemblies\
C:\Program Files (x86)\MySQL\MySQL Connector Net 8.0.21\Assemblies\v4.5.2\
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MySQL\MySQL Connector
Net 8.0.21\

---Some of the mentioned registry entries can have some differences in your
system, to locate them is better to use the find option---

Keep in mind that manipulate the registry manually can be very dangerous and
can cause a severe damage of your system, you should at least take a backup
of your registry before doing any change.

Once you removed All the entries from the registry now you should remove the
installation path from Program files:  C:\Program Files (x86)\MySQL\MySQL
Connector Net 8.0.21\

After this if you run again the MSI you should be able to install and
uninstall normally.

We will keep checking this issue.
[4 Jan 13:37] MySQL Verification Team
Bug #102132 marked as duplicate of this one.
[11 Jan 6:15] MySQL Verification Team
Bug #102209 marked as duplicate of this one