Bug #102132 'Install' for product 'Connector/NET 8.0.22' failed
Submitted: 3 Jan 15:19 Modified: 4 Jan 13:35
Reporter: lee Rhodes Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:8.0.22 OS:Microsoft Windows (windows 10)
Assigned to: CPU Architecture:x86

[3 Jan 15:19] lee Rhodes
Description:
I installed mysql through mysql installer, which also installed connector net 8.0.16. However, after I uninstalled mysql, connector net 8.0.16 was not uninstalled normally. 
Today, when I installed mysql through mysql installer 8.0.22, the installation of connector net 8.0.22 failed.
Press the show detail button of mysql installer 8.0.22 to display the following information:

1: Action 22:51:06: INSTALL. 
1: 1: MySQL Connector Net 8.0.22 2: {F7CB561A-E6E8-4B53-887B-DE2215BCA4C4} 
1: Action 22:51:06: FindRelatedProducts. Searching for related applications
1: Action 22:51:06: AppSearch. Searching for installed applications
1: Action 22:51:06: LaunchConditions. Evaluating launch conditions
1: Action 22:51:06: ValidateProductID. 
1: Action 22:51:06: CostInitialize. Computing space requirements
1: Action 22:51:06: FileCost. Computing space requirements
1: Action 22:51:06: CostFinalize. Computing space requirements
1: Action 22:51:06: InstallValidate. Validating install
1: Action 22:51:06: Setv45InstallUtil. 
1: Action 22:51:06: InstallInitialize. 
1: Action 22:51:06: RemoveExistingProducts. Removing applications
1: Application: {0160C4A1-392C-4AFA-B8DB-2471FDA71425}, Command line: UPGRADINGPRODUCTCODE={F7CB561A-E6E8-4B53-887B-DE2215BCA4C4} CLIENTPROCESSID=25180 CLIENTUILEVEL=3 MSICLIENTUSESEXTERNALUI=1 REMOVE=ALL
1: The older version of MySQL Connector Net 8.0.22 cannot be removed.  Contact your technical support group.  
1: 1: MySQL Connector Net 8.0.22 2: {F7CB561A-E6E8-4B53-887B-DE2215BCA4C4} 3: 3 
1: The action 'Install' for product 'Connector/NET 8.0.22' failed.

I followed the solution in https://bugs.mysql.com/bug.php?id=101060 to delete the corresponding entries in the registry, and then installed mysql through mysql installer 8.0.22, connector net 8.0.22 still The installation fails. At this time, press the show detail button of mysql installer 8.0.22 to display the same information as above.

How to repeat:

1...Use connector net 8.0.16.msi to install connector net 8.0.16, 

2...and then remove from the registry ALL the references to the string "Connector Net" .

in some cases you will need to remove an entire group in the left side, like
in this case:
Computer\HKEY_CLASSES_ROOT\Installer\Products\5C4BB67B4E04C2D4A881C8583C400D48
, here you need to delete from Products folder the entire key and subkeys for
5C4BB67B4E04C2D4A881C8583C400D48

from all these entries: you also need to remove the entire key and subkeys
which references Connector Net
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installe
r\UserData\S-1-5-18\Components\
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installe
r\UserData\S-1-5-18\Products\
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.5.
50709\AssemblyFoldersEx\MySQL Connector Net 8.0.16 v4.5.1
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVers
ion\Uninstall\{B76BB4C5-40E4-4D2C-8A18-8C85C304D084}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\MySQL AB\MySQL Connector/Net

in other cases like in
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installe
r\Folders, you only need to remove the entries in the right side which
mention Connector Net, will be something like this:
C:\Program Files (x86)\MySQL\MySQL Connector Net 8.0.16\
C:\Program Files (x86)\MySQL\MySQL Connector Net 8.0.16\Assemblies\
C:\Program Files (x86)\MySQL\MySQL Connector Net 8.0.16\Assemblies\v4.5.2\
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MySQL\MySQL Connector
Net 8.0.16\

---Some of the mentioned registry entries can have some differences in your
system, to locate them is better to use the find option---

3...Once you removed All the entries from the registry now you should remove the
installation path from Program files:  C:\Program Files (x86)\MySQL\MySQL
Connector Net 8.0.16\

Use mysql installer 8.0.22 to install connector net 8.0.22
[4 Jan 13:35] MySQL Verification Team
Hello lee Rhodes,

Thank you for the bug report.
Imho this is duplicate of Bug #101060, please see Bug #101060.

Regards,
Ashwini Patil