Bug #97371 Edit table shows incorrect COLLATE
Submitted: 24 Oct 2019 23:52 Modified: 25 Oct 2019 6:06
Reporter: Vladimir Kussakov Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.18 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[24 Oct 2019 23:52] Vladimir Kussakov
Description:
In MySQL Workbench, when you edit table parameters (by clicking on the wrench icon) it shows incorrect COLLATE parameter.

This is Windows only. The mac version works just fine.

How to repeat:
In MySQL Workbench:

Create a table with CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci

Go to tables list and click the wrench icon to edit the table.
The COLLATE dropdown shows as utf8mb4_0900_ai_ci.

(Mac Version shows "utf8mb4_unicode_520_ci" correctly)
[24 Oct 2019 23:54] Vladimir Kussakov
Example of wrong COLLATE parameter (see the other image for correct collate parameter)

Attachment: edit_table_view.png (image/png, text), 19.80 KiB.

[24 Oct 2019 23:54] Vladimir Kussakov
This view shows the correct COLLATE

Attachment: table_info_dll_view.png (image/png, text), 18.82 KiB.

[25 Oct 2019 6:06] Ashwini Patil
Hello Vladimir Kussakov,

Thank you for the report.
Imho this is duplicate of Bug #97260, please see the Bug #97260.

Regards,
Ashwini Patil