Bug #96939 "Check For Community Updates" Fails - MySQL Notifier 1.1.8
Submitted: 18 Sep 2019 19:12 Modified: 18 Sep 2019 20:51
Reporter: Subham Satyajeet Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL for Windows: MySQL Notifier Severity:S3 (Non-critical)
Version:1.1.8 OS:Microsoft Windows (Windows 10)
Assigned to: CPU Architecture:Any (Windows 10 Home Single Language, Version 1903 (Build 18362.356))
Tags: MySQL Notifier, windows

[18 Sep 2019 19:12] Subham Satyajeet
Description:
MySQL Notifier 1.1.8
Windows 10 Home Single Language, Version 1903

The option "Check for Community Updates" present within the MySQL Notifier context menu for the MySQL Notifier taskbar icon always fails.

To reproduce the problem, open MySQL Notifier. Then right click on the taskbar icon, select "Actions" -> "Check for Community Updates..."

Nothing happens, and the error message is shown as a Windows 10 Notification. The user is not shown any possible updates. See "How to repeat" for details.

How to repeat:
Steps to reproduce issue:

1) Open MySQL Notifier, and wait for the taskbar icon to show.
2) Right-click on the taskbar icon to bring up the context menu.
3) Select "Actions" -> "Check for Community Updates..."
4) Observe the Windows Action center for the error messages.

Observation:

Two Windows notifications are shown by MySQL Notifier. The contents are as follows:
1) "We are checking for updates to your installed MySQLSoftware."
2) "Error launching the process that calls the MySQL Installer API to check for updates:"

The MySQL Installer does not open, and the user is not made aware of any possible updates.
[18 Sep 2019 20:51] MySQL Verification Team
Thank you for the bug report.
[19 Oct 2019 22:02] Gord Boisvert
exact condition occurs on Windows 7 Home Premium edition
[27 Oct 2019 6:22] Giuseppe Chiodaroli
same situation form with Win7 Pro 64
[6 Dec 2019 21:41] Alexey Goloviznin
Same here, win 10, 19035.1000, 1.1.8

moreover the instance of Notifier tries to do maybe check or something else every (some time perior) and crashes itself with the same error) - i unchecked the option - Automaicaly check for MySQL update but it continues to crash.
[17 Jun 12:37] MySQL Verification Team
Bug #99637 marked as duplicate of this one.
[21 Sep 18:17] Omer Barnir
Product under sustaining support
[23 Sep 15:36] Brian Plunkett
Generated Alerts (Windows 10)

Attachment: NotifierAlerts.png (image/png, text), 48.75 KiB.

[23 Sep 17:26] Brian Plunkett
More specific technical details have been provided to the development community for a possible "quick fix" solution.  If a work-around solution is developed, I'll provide it to the community.