Bug #96362 mysqlbackup does not recognise the option --defaults-extra-file
Submitted: 29 Jul 9:45 Modified: 2 Aug 15:02
Reporter: avinash pawar Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Enterprise Backup Severity:S3 (Non-critical)
Version:8.0.16 OS:Red Hat (Red Hat Enterprise Linux Server 7.6 (Maipo))
Assigned to: Bogdan Kecman CPU Architecture:Any (GenuineIntel, Intel(R) Xeon(R) Gold 5122 CPU @ 3.60GHz)
Tags: mysql server 8.0.16, mysqlbackup

[29 Jul 9:45] avinash pawar
Description:
MySQL Server- 8.0.16 commercial (trial)
I am using mysqlbackup 8.0.16-commercial (trial version) for backing up the databases in my environment.

I have been successfully using the option (--defaults-extra-file) with mysqldump program from community and commercial versions 5.5, 5.6, 5.7, and 8.0. I save mysql user names and passwords (and other login information in the file). When I tried to use the same with mysqlbackup, it does not recognise the option.

[root@exampledb01 logical_backup]# mysqlbackup 
--defaults-extra-file=/mysql_data/config/extra_options.cnf 
--backup-dir=/mysql_backup/physical_backup/full_backups/2019-07-21 
--with-timestamp backup-and-apply-log

MySQL Enterprise Backup  Ver 8.0.16-commercial for linux-glibc2.12 on x86_64 (MySQL Enterprise - Commercial)
Copyright (c) 2003, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Starting with following command line ...
 mysqlbackup --defaults-extra-file=/mysql_data/config/extra_options.cnf 
        --backup-dir=/mysql_backup/physical_backup/full_backups/2019-07-21 
        --with-timestamp backup-and-apply-log 

MAIN: [ERROR] unknown option '--~'.

mysqlbackup exit code: 7, Invalid Argument

mysqlbackup failed with errors!

How to repeat:
I installed the MySQL server from compressed tar.

To recreate the issue, use mysqlbackup with --defaults-extra-file option.
I save login information in the file.
[2 Aug 15:02] Bogdan Kecman
I cannot reproduce this with 8.0.17

[arhimed@localhost bin]$ ./mysqlbackup --defaults-extra-file=xx.cnf --backup-dir=/tmp --with-timestamp backup-and-apply-log
MySQL Enterprise Backup  Ver 8.0.17-commercial for linux-glibc2.12 on x86_64 (MySQL Enterprise - Commercial)
Copyright (c) 2003, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Starting with following command line ...
 ./mysqlbackup --defaults-extra-file=xx.cnf --backup-dir=/tmp
        --with-timestamp backup-and-apply-log

IMPORTANT: Please check that mysqlbackup run completes successfully.
           At the end of a successful 'backup-and-apply-log' run mysqlbackup
           prints "mysqlbackup completed OK!".

190802 16:57:53 MAIN    INFO: Starting to log actions.
190802 16:57:53 MAIN    INFO: No SSL options specified.
...