Bug #96348 mySQL Installer Web Community 8.0.17.0 unable to install mySQL Server v8.0.17 on
Submitted: 26 Jul 2019 19:12 Modified: 28 Nov 21:04
Reporter: SCOTT DELANCEY Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:8.0.17 OS:Windows (Windows 10)
Assigned to: CPU Architecture:Any

[26 Jul 2019 19:12] SCOTT DELANCEY
Description:
I am unable to install the MySQL Server Community Edition v8.0.17 to my Windows 10 machine where I have also installed Visual Studio 2019 (Community Edition) using the mysql-installer-web-community-8.0.17.0.msi windows installer. 

It seems to fail when it tries to load different language character sets to the "C:\Program Files\MySQL\MySQL Server 8.0\share\" directory. 

All of the other developer components will install successfully. Server is the only one that cannot download. 

How to repeat:
Execute the mysql-installer-web-community-8.0.17.0.msi windows installer
[26 Jul 2019 19:13] SCOTT DELANCEY
Bug #96348 Install log

Attachment: Bug #96348 install log.txt (text/plain), 22.42 KiB.

[4 Aug 2019 2:27] MySQL Verification Team
Thank you for the bug report.
[28 Nov 21:04] Jose Ramirez
As per the provided info, the error took place when the Server MSI attempted
to execute the ExecSecureObjects msi action. This is a know issue detailed in
the following official MySQL forum post:
https://forums.mysql.com/read.php?169,685186,685186#msg-685186.

The problem is at the MSI level and not related to MySQL Installer. MySQL
Server 8.0.21 removed the MSI feature that caused this failure and has proven
to fix the reported issue.