Bug #96329 sql editor does not scroll correctly
Submitted: 25 Jul 2019 12:47 Modified: 25 Jul 2019 16:24
Reporter: Christian Andersson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.17 OS:Mac OS X (Mojave 10.14.5)
Assigned to: CPU Architecture:x86

[25 Jul 2019 12:47] Christian Andersson
Description:
If the SQL Editor is smaller then the text in the editor, and you have scrolled down to the bottom (Probably happen if you also are not down at the bottom)
The cursor when pressing up will not scroll the editor up when it reaches the visual top, it will move down instead until it reaches the bottom, then up, then down, etc in a never ending loop.

see the following video https://www.youtube.com/watch?v=j4m4nlbU9Ao I am just pressing and holding the up key in this video.

How to repeat:
Enter the following "query"

select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test
select  *from test

make the sql editor window smaller then the above content
scroll down to the bottom using the mouse
press down the "up" key and continue holding up (or press the up key multiple times
[25 Jul 2019 12:48] Christian Andersson
Threr are also problems when you have scrolled the sql editor to the top and pressing down, the editor does not scroll, and the cursor will not move longer then is visible.
[25 Jul 2019 16:24] MySQL Verification Team
Thank you for the bug report. Duplicate of: https://bugs.mysql.com/bug.php?id=94151.