Bug #94151 The query window does not scroll with the cursor movements.
Submitted: 31 Jan 2019 9:38 Modified: 24 Jun 2019 18:43
Reporter: Mario Graziano Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.14 OS:Mac OS X (macOS 10.14.3)
Assigned to: CPU Architecture:x86 (2,5 GHz Intel Core i7)
Tags: cursor, Query Tab, query window, scroll, scrolling, workbench

[31 Jan 2019 9:38] Mario Graziano
Description:
If you move the cursor with the keyboard within a query window, it does not scroll following the cursor up or down, so the cursor disappears above or below the window. The only way to scroll the query window is by using the mouse wheel or by dragging the scroll bar.

How to repeat:
Open a query window and write or paste a text much longer of the window space available. Or you can press and maintain pressed the enter key as long as the cursor reach the bottom of the query window: the cursor will disappear but it will continue to insert new lines under the visible portion of the query window.
[31 Jan 2019 11:50] MySQL Verification Team
Thank you for the bug report.
[10 Mar 2019 23:28] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=94616 marked as duplicate of this one.
[24 Jun 2019 18:43] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.18 release, and here's the changelog entry:

Content within the input area of a Query tab did not scroll with the
cursor when the cursor was moved beyond the current display range (up or
down) using the keyboard.

Thank you for the bug report.
[23 Aug 2019 9:04] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=96621 marked as duplicate of this one.
[23 Aug 2019 9:36] Danny Davies
Will wait for the update, any chance of making the editor window scroll smoothly rather than the more jerky line-by-line scrolling it currently uses?
[27 Aug 2019 13:43] CRC Marketing Solutions
Ditto on Danny's comment with the jerky scrolling, this is a big complaint from our developers, albeit not functionally debilitating, still difficult when attempting to read through many lines of SQL code. A more native macOS editor would be wonderful!