Bug #95901 RENAME COLUMN Clause Not Recognized by SQL Editor
Submitted: 20 Jun 15:39 Modified: 24 Jun 20:17
Reporter: Tianyao Yue Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.16 OS:Mac OS X (High Sierra 10.13.6)
Assigned to: CPU Architecture:Any

[20 Jun 15:39] Tianyao Yue
Description:
ALTER TABLE Customers RENAME COLUMN CustPhone TO CustMobile;

# You can see the red ripple line under RENAME and red X symbol at line head.
# But actually the statement will work and will be executed successfully. 

How to repeat:
# DROP TABLE Customers;

CREATE TABLE Customers (
    CustName TEXT,
    Company TEXT,
    CustPhone TEXT
);

ALTER TABLE Customers RENAME COLUMN CustPhone TO CustMobile;

# You can see the red ripple line under RENAME and red X symbol at line head.
# But actually the statement will work and will be executed successfully.
[20 Jun 15:45] Tianyao Yue
Screenshot of the SQL Editor and Output

Attachment: Screen Shot 2019-06-20 at 8.43.46 AM.png (image/png, text), 186.12 KiB.

[20 Jun 18:15] Miguel Solorzano
Thank you for the bug report.
[24 Jun 7:53] Mike Lischke
This bug was marked as duplicate of Bug #95268.
[24 Jun 20:17] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.18 release, and here's the changelog entry:

The visual SQL editor reported a false error on the RENAME COLUMN clause
of a valid statement.

Thank you for the bug report.