Bug #95268 Workbench editor can not identify the keyword 'rename'
Submitted: 7 May 2019 1:53 Modified: 24 Jun 2019 7:53
Reporter: Lisa Song Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.15, 8.0.16 OS:Microsoft Windows (Microsoft Windows 10 Home China)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[7 May 2019 1:53] Lisa Song
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\lenovo\AppData\Roaming\MySQL\Workbench\log\wb.log]

How to repeat:
0.Click "New query tab"
1.New a database named 'test'
2.New a table named 'lisa1'
3.insert tow column, one column named num
4.alter the column num to no, like following:

alter table lisa1 rename column num to no;

Suggested fix:
The left of the editor show no error icon
[7 May 2019 5:47] MySQL Verification Team
Hello Lisa Song,

Thank you for the report and feedback.
Verified as described with WB 8.0.16 on Win7.

regards,
Umesh
[24 Jun 2019 7:53] Mike Lischke
Duplicate of Bug #95901