Bug #95742 Workbench crashes when editing trigger and focus lost
Submitted: 11 Jun 2019 23:36 Modified: 9 Jul 2019 14:17
Reporter: Bill Linder Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.16 OS:Microsoft Windows (Windows 10)
Assigned to: CPU Architecture:x86
Tags: Application Loses Focus, crash, editing, syntax error, trigger

[11 Jun 2019 23:36] Bill Linder
Description:
When I am editing a trigger in the workbench, if I do not close the view of the trigger (click on the -) and I click on another window in any program, MySQL Workbench closes if there is an error in the trigger's code.

How to repeat:
Open a trigger and put an error in it.  Click on another application or another Mysql Workbench Window.

My that crashes.   If I fix the syntax error, it does not crash.

CREATE DEFINER=`root`@`%` TRIGGER `rps_tbl_mst_BEFORE_UPDATE` BEFORE UPDATE ON `rps_tbl_mst` FOR EACH ROW BEGIN
	DECLARE tmpValue VARCHAR(8)
END
[12 Jun 2019 6:41] Umesh Shastry
Hello Bill,

Thank you for the report and feedback.
Verified as described.

regards,
Umesh
[9 Jul 2019 14:17] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.18 release, and here's the changelog entry:

MySQL Workbench exits unexpectedly during an editing session of trigger
code if the focus was shifted away from the Triggers tab and the trigger
code contained an error.

Thank you for the bug report.
[19 Aug 2019 10:00] Nick Franklin
When is 8.0.18 due for release. As of 19th August 2019, 8.0.17 is available. As of now still unable to edit triggers without workbench crashing.
[4 Oct 2019 6:57] Mike Lischke
Bug #97092 marked as duplicate of this one.
[30 Oct 2019 5:46] Umesh Shastry
Bug #97407 marked as duplicate of this one