Bug #94174 Dark Mode macOS Mojave (10.14) EER Issue
Submitted: 2 Feb 2019 3:40 Modified: 2 Oct 2019 21:52
Reporter: Griffin Rademacher Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:8.0.14, 8.0.15, 8.0.17 OS:Mac OS X (Mojave (10.14))
Assigned to: CPU Architecture:Any
Tags: Dark Mode, EER, modeling

[2 Feb 2019 3:40] Griffin Rademacher
Description:
When creating a .pdf file via File > Export as Single Page PDF... for an EER diagram (which was created via Database > Reverse Engineer), I realized that none of the arrows were visible in the diagram. I am using Workbench 8.0.14 on a MacBook running macOS Mojave (10.14), and I have Dark Mode enabled. When I disabled Dark Mode and created the EER diagram again (by running Reverse Engineer again), the arrows started showing up in the export. This appears to be because when the bug at https://bugs.mysql.com/bug.php?id=92902 was fixed and Workbench was updated to work with Dark Mode, the arrows were fixed to render as white on a black background, but the export feature was not updated to take this into account, and is exporting white arrows onto a white background. Sample output at https://photos.app.goo.gl/MWHiCe5cRrMoiKW18

How to repeat:
Launch Workbench 8.0.14 on macOS 10.14, connect to an SQL server, create a database if none exist, Database > Reverse Engineer, follow prompts to create diagram (default option if just clicking through), File > Export as Single Page PDF..., open in .pdf viewer of your choice.
[2 Feb 2019 7:52] Umesh Shastry
Hello Griffin,

Thank you for the report and feedback.
This is observed with MySQL Workbench Community (GPL) for Mac OS X version 8.0.15 CE build 14271522 (64 bit) on macOS 10.14.x Mojave.

thanks,
Umesh
[26 Feb 2019 5:51] Umesh Shastry
Bug #94466 marked as duplicate of this one
[18 Sep 2019 5:44] Umesh Shastry
Bug #96917 marked as duplicate of this one
[20 Sep 2019 16:20] steve kania
This is very annoying that the relationships are not displaying on the export whether it's white on white or not. Has anyone figured out a workaround for this?
[22 Sep 2019 14:53] Umesh Shastry
Bug #96955 marked as duplicate of this one
[2 Oct 2019 21:52] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.19 release, and here's the changelog entry:

The relationship arrows within an EER diagram were not visible when the
Dark Mode theme was enabled on a macOS host and the diagram was exported
as a single page PDF file. This fix disables the theme for connection
lines in models to prevent conflicts with the colors assigned by the model
editor.

Thank you for the bug report.
[10 Oct 2019 14:52] Matthieu Larcher
For those wondering, reverting MySQL Workbench to 8.0.13 is enough to avoid the problem, and it is available on https://downloads.mysql.com/archives/workbench/
[22 Oct 2019 12:22] Umesh Shastry
Bug #95602 marked as duplicate of this one
[26 Oct 2019 11:56] Umesh Shastry
Bug #97388 marked as duplicate of this one