Bug #94105 When text in a result set cell is selected, text shortcuts apply to row
Submitted: 29 Jan 0:00 Modified: 29 Jan 16:55
Reporter: Alex Cabal Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.14 OS:Ubuntu (18.04.1)
Assigned to: CPU Architecture:Any

[29 Jan 0:00] Alex Cabal
Description:
When a result set grid is visible, one can use the mouse to enter a cell and select text within the cell. However, if the user uses the keyboard to perform text manipulation shortcuts, for example ctrl + c to copy, or ctrl + a to select all, the operation applies to the entire row, not the selected cell.

This is a regression, as this was not an issue in the 6.* branch. If 

How to repeat:
Generate a result set in which one of the columns is a varchar or text column.

Double click on one of the varchar/text cells and observe that the cell becomes editable, with the text selected.

Press ctrl + c on the keyboard. Observe that the entire row becomes selected, and the clipboard contains the entire row, not the selected text.

This can be repeated with ctrl + a, which does not select all of the text in the  cell, but rather selects the whole row; and ctrl + v, which does not paste anything in to the cell and instead selects the entire row as well.
[29 Jan 0:07] Alex Cabal
Note: I submitted this bug for 8.0.13 but it is still present in 8.0.14.
[29 Jan 5:20] Umesh Shastry
Hello Alex Cabal,

Thank you for the report.
Imho this is duplicate of Bug#91867, please see Bug#91867.

regards,
Umesh
[29 Jan 16:55] Alex Cabal
Looks like it is a dupe, though note that this report also includes problems with ctrl + a. I'm guessing the root cause for the issue with all ctrl + * shortcuts is the same, but in case it isn't, there you are.