Bug #93792 The test case main.mysqldump failed
Submitted: 3 Jan 7:32 Modified: 3 Jan 7:43
Reporter: kfpanda kf Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version:5.7,8.0 OS:Any
Assigned to: CPU Architecture:Any

[3 Jan 7:32] kfpanda kf
Description:
Happy New Year!

As New Year 2019 arrives, the test case main.mysqldump fails.

The following warning is encountered when you run the test case main.mysqldump.

create event ee2 on schedule at '2018-12-31 21:01:23' do set @a=5;
+Warnings:
+Note   1588    Event execution time is in the past and ON COMPLETION NOT PRESERVE is set. The event was dropped immediately after creation.

How to repeat:
Happy New Year!

As New Year 2019 arrives, the test case main.mysqldump fails.

The following warning is encountered when you run the test case main.mysqldump.

create event ee2 on schedule at '2018-12-31 21:01:23' do set @a=5;
+Warnings:
+Note   1588    Event execution time is in the past and ON COMPLETION NOT PRESERVE is set. The event was dropped immediately after creation.

Suggested fix:

create event ee2 on schedule at '2018-12-31 21:01:23' do set @a=5;

You can adjust the above statement to the following statement.Then wait until the New Year of 2028 to adjust.
Happy New Year again! haha...

create event ee2 on schedule at '2028-12-31 21:01:23' do set @a=5;
[3 Jan 7:43] Umesh Shastry
Hello!

Thank you for the report and test case.
Imho this is duplicate of Bug #93788, please see Bug #93788

regards,
Umesh
[4 Jan 13:29] Erlend Dahl
Duplicate of fixed bug

Bug#93778 main.mysqldump fails with event created in the past