Bug #93778 main.mysqldump fails with event created in the past
Submitted: 2 Jan 8:25 Modified: 2 Jan 15:49
Reporter: Jon Olav Hauglid Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S7 (Test Cases)
Version:5.6 OS:Any
Assigned to: CPU Architecture:Any

[2 Jan 8:25] Jon Olav Hauglid
Description:
main.mysqldump currently fails with:
-- /export2/repo/mysql/mysql-test/r/mysqldump.result	2019-01-02 11:23:03.797413216 +0300
+++ /export2/repo/mysql/bld-clang/mysql-test/var/log/mysqldump.reject	2019-01-02 11:24:18.369971801 +0300
@@ -3907,11 +3907,12 @@
 Event	sql_mode	time_zone	Create Event	character_set_client	collation_connection	Database Collation
 ee1		UTC	CREATE DEFINER=`root`@`localhost` EVENT `ee1` ON SCHEDULE AT '2035-12-31 20:01:23' ON COMPLETION NOT PRESERVE ENABLE DO set @a=5	utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
 create event ee2 on schedule at '2018-12-31 21:01:23' do set @a=5;
+Warnings:
+Note	1588	Event execution time is in the past and ON COMPLETION NOT PRESERVE is set. The event was dropped immediately after creation.
 create event ee3 on schedule at '2030-12-31 22:01:23' do set @a=5;
 show events;
 Db	Name	Definer	Time zone	Type	Execute at	Interval value	Interval field	Starts	Ends	Status	Originator	character_set_client	collation_connection	Database Collation
 second	ee1	root@localhost	UTC	ONE TIME	2035-12-31 20:01:23	NULL	NULL	NULL	NULL	ENABLED1utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
-second	ee2	root@localhost	UTC	ONE TIME	2018-12-31 21:01:23	NULL	NULL	NULL	NULL	ENABLED1utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
 second	ee3	root@localhost	UTC	ONE TIME	2030-12-31 22:01:23	NULL	NULL	NULL	NULL	ENABLED1utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
 drop database second;
 create database third;
@@ -3919,7 +3920,6 @@
 show events;
 Db	Name	Definer	Time zone	Type	Execute at	Interval value	Interval field	Starts	Ends	Status	Originator	character_set_client	collation_connection	Database Collation
 third	ee1	root@localhost	UTC	ONE TIME	2035-12-31 20:01:23	NULL	NULL	NULL	NULL	ENABLED1utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
-third	ee2	root@localhost	UTC	ONE TIME	2018-12-31 21:01:23	NULL	NULL	NULL	NULL	ENABLED1utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
 third	ee3	root@localhost	UTC	ONE TIME	2030-12-31 22:01:23	NULL	NULL	NULL	NULL	ENABLED1utf8mb4	utf8mb4_0900_ai_ci	utf8mb4_0900_ai_ci
 drop database third;
 set time_zone = 'SYSTEM';

How to repeat:
./mtr main.mysqldump

Suggested fix:
Kick the can down the road...
[2 Jan 15:49] Paul Dubois
Posted by developer:
 
Fixed in 5.6.44, 5.7.26, 8.0.15.

Work was done for test suite. No changelog entry needed.
[1 Feb 5:13] Umesh Shastry
Bug #94149 marked as duplicate of this one