Bug #93710 Paste into editable value defaults to paste for entire row
Submitted: 21 Dec 2018 1:22 Modified: 12 Mar 2019 16:50
Reporter: Dwain Bethel Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.13 OS:Mac OS X (macOS 10.13.x High Sierra x86_64)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[21 Dec 2018 1:22] Dwain Bethel
Description:
When you run a query and attempt to edit a field within the results, the paste keyboard shortcut no longer works as expected.  If you click into a field to change the value and hit the command-v to paste the value from your clipboard, it fails and says `Cannot Paste Row: Number of fields in pasted data doesn't match the columns in the table (1 vs 5).
Data must be in the same format used by the Copy Row Content command.`

I am not trying to paste a row, just one single value.  The only workaround I have found is to paste from the context menu.  Which is much slower more difficult. 

How to repeat:
1) Run a query against a test database.
2) Click into a field to edit the value.
3) Use the command-v shortcut

Suggested fix:
Restore the paste functionality
[21 Dec 2018 7:49] MySQL Verification Team
Thank you for the bug report. Please see https://bugs.mysql.com/bug.php?id=93186 too.
[14 Jan 2019 11:57] Marcin Szalowicz
This bug has a duplicate #91066
[14 Jan 2019 13:57] Marcin Szalowicz
Bug #93533 marked as duplicate of this one.
[11 Feb 2019 9:06] Florentin Coppey
please do something about it.... unbelievable..
[21 Feb 2019 21:15] Romain Riche
This is a big and obvious mistake... The fix must be pretty quick to do. 
Please do something about it! It has been months...
[12 Mar 2019 16:50] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.16 release, and here's the changelog entry:

The Command+V keyboard shortcut on macOS returned an error indicating that
a paste-row operation was attempted, rather than the single-value paste
used to edit a field within the result grid following a successful query.

Thank you for the bug report.