Bug #93533 Cannot Paste with Command-V Shortcut
Submitted: 9 Dec 2018 23:19 Modified: 14 Jan 13:55
Reporter: Aaron Greenspan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.13 OS:Mac OS X (macOS 10.14.x Mojave x86_64)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Dec 2018 23:19] Aaron Greenspan
Description:
In MySQL Workbench 5.x for Mac OS and in previous versions, it was possible to paste a single field value into the results grid using Command-V. This is something that I happen to do a lot. (I would really love the ability to paste the same value into multiple fields simultaneously by simply selecting those fields and hitting Command-V or Edit->Paste, but this applies to the simplest case with one field.) Now, when I press Command-V or go to Edit->Paste, I get an error message saying that there is a column number mismatch with the value copied and the number of columns in the table. But I'm not trying to paste an entire row of information. I'm just trying to paste into one field. When I right click on the field and then select Paste from the context menu, then it works.

How to repeat:
Copy any text, even text with no commas or tabs (which would suggest multiple fields), and try to paste it into a field in the query results table using Command-V or Edit->Paste. An error will appear.

Suggested fix:
Allow for pasting into the results table as with prior MySQL Workbench versions.
[10 Dec 2018 6:58] Umesh Shastry
Hello Aaron,

Thank you for the report and feedback!

regards,
Umesh
[14 Jan 13:55] Marcin Szalowicz
this is a duplicate of Bug#93710