Bug #93664 Workbench display fails on additional monitors when loading model
Submitted: 18 Dec 2018 21:55 Modified: 19 Dec 2018 16:34
Reporter: B Towne Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:8.0 OS:Microsoft Windows
Assigned to: Umesh Shastry CPU Architecture:Any
Tags: display, multi-monitor

[18 Dec 2018 21:55] B Towne
Description:
The modeling tool has several issues/unexpected behaviors when the MySQL Workbench is open on a monitor other than the primary monitor.  There seem to be more issues on Monitor 3 than on Monitor 2.  The issue focused on for the filing of the bug is initial display of the EER diagram when opening the model. 

I am testing on Windows 10 Pro. 
This was observed on earlier versions and reproduced in the latest release, 8.0.13 build 13780177 CE (64 bits). 

How to repeat:
1. Create a MySQL Workbench model (.mwb) file, use an existing one, or download the attached to a known location.
2. Start / restart MySQL Workbench.
3. Drag the MySQL Workbench window to Monitor 3.  (Note: Reproducing this requires a multi-monitor setup.  Mine is with a Dell docking station that supports attaching two monitors, plus the laptop screen).
4. Open the model.
5. Observe that the EER diagram is not shown, but instead glitchy other display bits.  See screenshot.
6. Drag the window over to the primary monitor.  Now you will see what you expected to see before, and can interact with the model as desired.

Suggested fix:
The expected behavior is that MySQL Workbench works the same on any monitor where it is displayed.
[18 Dec 2018 21:56] B Towne
Expected result, and result after dragging to monitor 1

Attachment: SampleDB after dragging window to monitor 1.PNG (image/png, text), 111.33 KiB.

[18 Dec 2018 21:56] B Towne
Glitchy display when loading, when the window is on monitor 3

Attachment: SampleDB on monitor 3.PNG (image/png, text), 80.27 KiB.

[18 Dec 2018 21:57] B Towne
Sample model file used in demonstration

Attachment: SampleDB.mwb (application/octet-stream, text), 8.26 KiB.

[18 Dec 2018 21:57] B Towne
Version information used in tests, though it showed up in prior versions too

Attachment: About screen.PNG (image/png, text), 15.96 KiB.

[19 Dec 2018 0:36] Miguel Solorzano
Thank you for the bug report. Duplicate/related: https://bugs.mysql.com/bug.php?id=57043.
[19 Dec 2018 14:43] B Towne
https://bugs.mysql.com/bug.php?id=57043 is a feature request that users can display different tools/parts of the window as detachable windows arranged elsewhere on their desktop, with the motivating use case being display on two different monitors.  

The present bug does not request any ability to separate windows, but merely requests that the existing single-window setup display and function properly on monitors other than what Windows thinks is the primary monitor (which might not be in practice the "primary" monitor that is easiest for the user to interact with MySQL Workbench on).  

An example use case might be if I have a projector connected in Extend Display mode, and I want to put MySQL workbench up there to support collaborative group discussion around an ER model.  I don't need any MySQL Workbench components/windows on my primary display as requested by 57043, just on the second one.  I can have the window on the second monitor, but due to the display glitches in THIS bug (93664), it won't show properly and that collaboration isn't going to work.
[19 Dec 2018 16:34] Miguel Solorzano
Thank you for the feedback. I couldn't repeat on MacBook Pro and display Thunderbolt and Laptop LG Windows 10 and Dell Display 27". I am assignment a co-worker to double check on his side.