Bug #93647 Column auto complete not working when using table alias
Submitted: 17 Dec 2018 21:48 Modified: 18 Jan 5:31
Reporter: Tianyu Wei Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.13 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[17 Dec 2018 21:48] Tianyu Wei
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\twei\AppData\Roaming\MySQL\Workbench\log\wb.log]

when using table alias, columns are not auto completing.

How to repeat:
set a table alias in the from clause either using

TBLNAME ALIAS
or
TBLNAME as ALIAS

both these don't show auto complete column names when writing the where clause.
[18 Jan 5:31] Umesh Shastry
Hello Tianyu Wei,

Thank you for the report.
Imho this is duplicate of Bug #91859, please see Bug #91859

regards,
Umesh