Bug #91859 Auto complete not working on where
Submitted: 1 Aug 2018 20:17 Modified: 7 Mar 2019 23:14
Reporter: Benyamin Limanto Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.12 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Service Pack 1)
Assigned to: CPU Architecture:x86 (64 bit)
Tags: WBBugReporter

[1 Aug 2018 20:17] Benyamin Limanto
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Ben\AppData\Roaming\MySQL\Workbench\log\wb.log]

I tried to ctrl+space on where while typing sql query. It doesn;t work. Is there anyway to fix it? Thanks

How to repeat:
Do any select, until typing where, try ctrl+space. It won't work. No suggestion shown after try to show suggestion.

Suggested fix:
Please show any auto complete. Thanks
[2 Aug 2018 8:10] Chiranjeevi Battula
Hello Benyamin Limanto,

Thank you for the bug report.
Confirmed on various instance that autocomplete is working perfectly.
Auto-complete is enabled (and triggered) by default, and might have been disabled by un-checking Preferences->SQL Editor->Automatically Start Code Completion. Please enable it by checking and should work again.

Thanks,
Chiranjeevi.
[2 Aug 2018 9:13] Benyamin Limanto
Not working. Is mysql workbench maybe depends on java? or not? 
after tick and untick and tick again dan restart the app no autocomplete shown. Or maybe is there any ways to clean the configuration file? Thanks
[2 Aug 2018 9:47] Benyamin Limanto
When I'm using alias, the table coloumn auto complete not work. I must write the table name again then it will work.. Come on...
[2 Aug 2018 10:50] Chiranjeevi Battula
Hello Benyamin Limanto,

Thank you for the feedback.
Verified this behavior on MySQL Workbench in 8.0.12 version.

Thanks,
Chiranjeevi.
[2 Aug 2018 12:56] Benyamin Limanto
Is there any work around for now? Or maybe I could download the old version of it?
[4 Aug 2018 3:40] Benyamin Limanto
Downgrade to ver 6.3.10, it works flawlessly.. waiting ver 8 to be stable.. Thanks
[26 Sep 2018 19:08] Matthew Gabiou
Thank You Benyamin Limanto. I was encountering the same issue and downgraded.
[25 Oct 2018 3:07] Patrick Loftus
I upgraded from 6.3.10 to 8.0.12 in August, auto-complete did not work.  Uninstalled and went back to 6.3.10.  I tried the upgrade again today (8.0.13 10/24/2018), issue persists.  Going back to 6.3.10.  It is such an pain to have to type all of field names when building queries.  The table names do auto complete and non-field items will be offered after you type WHERE, but not the list of table fields.
[1 Nov 2018 14:58] James Doyle
Column name auto-complete fails to work in 8.0.12 and 8.0.13.  The simplest example is to type:

SELECT * from INFORMATION_SCHEMA.TABLES where t(ctrl-spc):

The suggested completions are Functions, not Columns
    TIME, TIMESTAMP ... tan() ... truncate()
[6 Dec 2018 9:16] NOT_FOUND Aronson
Anything new with issue? I keep hitting ctrl+space and it won't show any table columns.
[6 Dec 2018 11:59] Mike Lischke
This problem is on our radar, but atm. we have more pressing issues. We will deliver a fix in one of the following WB updates.
[18 Jan 2019 5:31] MySQL Verification Team
Bug #93647 marked as duplicate of this one
[18 Feb 2019 7:15] Enrico Troegel
Is there a rough time schedule when this bug will be fixed?

I've just updated to MySQL Workbench 8.0.15 and the auto-complete issue is still present.
[7 Mar 2019 23:14] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.16 release, and here's the changelog entry:

The code auto-completion feature in the query editor did not provide the
expected behavior.

Thank you for the bug report.
[1 Apr 2019 20:45] Praveen Kumar Velagambeti
When 8.0.16 version will be available?
[11 Sep 2019 10:22] Eysa Neme
autocomplete is not working on update statements for table fields, has anyone faced or reported this issue before ?
[13 Nov 2019 4:52] so rathavithey
Trust me:
ShemaName: DB_TEST;
TableName: TBL_BOOK;

SELECT * FROM DB_TEST.TBL_BOOK B WHERE B.ID IS NOT NULL;