Bug #93414 MySQL Server 8.0.13 uninstall problem
Submitted: 29 Nov 2018 20:13 Modified: 30 Nov 2018 7:47
Reporter: Dmytro Petrenko Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:8.0.13 OS:Microsoft Windows (10 Professional x64)
Assigned to: CPU Architecture:x86 (Intel Xeon E5 2680 v2)
Tags: uninstall

[29 Nov 2018 20:13] Dmytro Petrenko
Description:
How I could uninstall or downgrade this product which doesn't work correctly?

Uninstall progress stops at 50% - nothing helps

Log:

Beginning removal of MySQL Server 8.0.13.
1: Action 21:48:47: INSTALL. 
1: 1: MySQL Server 8.0 2: {5A1AC698-82B9-4962-9FF5-EABADBA5A124} 
1: Action 21:48:47: FindRelatedProducts. Searching for related applications
1: Action 21:48:47: AppSearch. Searching for installed applications
1: Action 21:48:47: LaunchConditions. Evaluating launch conditions
1: Action 21:48:47: ValidateProductID. 
1: Action 21:48:47: CostInitialize. Computing space requirements
1: Action 21:48:47: FileCost. Computing space requirements
1: Action 21:48:47: CostFinalize. Computing space requirements
1: Action 21:48:47: MigrateFeatureStates. Migrating feature states from related applications
1: Action 21:48:47: InstallValidate. Validating install
1: Action 21:48:48: InstallInitialize. 
1: Action 21:48:48: GenerateScript. Generating script operations for action:
1: InstallInitialize
1: Action 21:48:48: QtRemoveService. 
1: 
1: Action 21:48:48: RemoveExistingProducts. Removing applications
1: Action 21:48:48: ProcessComponents. Updating component registration
1: Action 21:48:48: UnpublishFeatures. Unpublishing Product Features
1: Feature: Unpublishing Product Features
1: Action 21:48:48: SchedSecureObjectsRollback. 
1: Action 21:48:48: ExecSecureObjectsRollback. 
1: 
1: Action 21:48:48: ExecSecureObjectsRollback. 
1: 
1: Action 21:48:48: ExecSecureObjectsRollback. 
1: 
1: Action 21:48:48: ExecSecureObjectsRollback. 
1: 
1: Action 21:48:48: RemoveRegistryValues. Removing system registry values
1: Key: Removing system registry values, Name: 
1: Action 21:48:48: RemoveShortcuts. Removing shortcuts
1: Shortcut: Removing shortcuts
1: Action 21:48:48: RemoveFiles. Removing files
1: File: Removing files, Directory: 
1: Action 21:48:48: RemoveFolders. Removing folders
1: Folder: Removing folders
1: Action 21:48:48: CreateFolders. Creating folders
1: Action 21:48:48: InstallFiles. Copying new files
1: Action 21:48:48: CreateShortcuts. Creating shortcuts
1: Action 21:48:48: WriteRegistryValues. Writing system registry values
1: Action 21:48:48: InstallServices. Installing new services
1: Action 21:48:48: RegisterUser. Registering user
1: Action 21:48:48: RegisterProduct. Registering product
1: Action 21:48:48: PublishFeatures. Publishing Product Features
1: Action 21:48:48: PublishProduct. Publishing product information
1: Action 21:48:48: InstallFinalize. 
1: Action 21:48:48: InstallInitialize. 
1: Action 21:48:48: QtRemoveService. 
1: Action 21:48:48: Rollback. Rolling back action:
1: QtRemoveService
1: InstallInitialize
1: 1: MySQL Server 8.0 2: {5A1AC698-82B9-4962-9FF5-EABADBA5A124} 3: 3 
1: The action 'Remove' for product 'MySQL Server 8.0.13' failed.

How to repeat:
Uninstall via "MySQL Installer"
[30 Nov 2018 7:47] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=93291.
[30 Nov 2018 9:59] Vlad Kanash
I was able to solve the issue and uninstall MySQL Server using this tool:

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being...
[30 Nov 2018 10:45] Miguel Solorzano
[30 Nov 10:02] Vlad Kanash

Solved.
MySQL Server was successfully removed With the help of this tool:
https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being...