Bug #93291 Cannot uninstall MySQL server 8.0.13 using MySQL Installer or control panel
Submitted: 22 Nov 2018 12:56 Modified: 30 Nov 2018 10:02
Reporter: Vlad Kanash Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:8.0.13 OS:Microsoft Windows (Windows 10 Pro )
Assigned to: CPU Architecture:x86

[22 Nov 2018 12:56] Vlad Kanash
Description:
After installing MySQL Server using web installer, I am unable to remove it.
Machine restart don't affect the issue. If I try to uninstall it from control panel, the uninstall wizard quits without any error messages.

Attaching log from MySQL Installer:

Beginning removal of MySQL Server 8.0.13.
1: Action 15:49:43: INSTALL. 
1: 1: MySQL Server 8.0 2: {5A1AC698-82B9-4962-9FF5-EABADBA5A124} 
1: Action 15:49:43: FindRelatedProducts. Searching for related applications
1: Action 15:49:43: AppSearch. Searching for installed applications
1: Action 15:49:43: LaunchConditions. Evaluating launch conditions
1: Action 15:49:43: ValidateProductID. 
1: Action 15:49:43: CostInitialize. Computing space requirements
1: Action 15:49:43: FileCost. Computing space requirements
1: Action 15:49:43: CostFinalize. Computing space requirements
1: Action 15:49:43: MigrateFeatureStates. Migrating feature states from related applications
1: Action 15:49:43: InstallValidate. Validating install
1: Action 15:49:44: InstallInitialize. 
1: Action 15:49:44: GenerateScript. Generating script operations for action:
1: InstallInitialize
1: Action 15:49:44: QtRemoveService. 
1: 
1: Action 15:49:44: RemoveExistingProducts. Removing applications
1: Action 15:49:44: ProcessComponents. Updating component registration
1: Action 15:49:45: UnpublishFeatures. Unpublishing Product Features
1: Feature: Unpublishing Product Features
1: Action 15:49:45: SchedSecureObjectsRollback. 
1: Action 15:49:45: ExecSecureObjectsRollback. 
1: 
1: Action 15:49:45: ExecSecureObjectsRollback. 
1: 
1: Action 15:49:45: ExecSecureObjectsRollback. 
1: 
1: Action 15:49:45: ExecSecureObjectsRollback. 
1: 
1: Action 15:49:45: RemoveRegistryValues. Removing system registry values
1: Key: Removing system registry values, Name: 
1: Action 15:49:45: RemoveShortcuts. Removing shortcuts
1: Shortcut: Removing shortcuts
1: Action 15:49:45: RemoveFiles. Removing files
1: File: Removing files, Directory: 
1: Action 15:49:46: RemoveFolders. Removing folders
1: Folder: Removing folders
1: Action 15:49:46: CreateFolders. Creating folders
1: Action 15:49:46: InstallFiles. Copying new files
1: Action 15:49:46: CreateShortcuts. Creating shortcuts
1: Action 15:49:46: WriteRegistryValues. Writing system registry values
1: Action 15:49:46: InstallServices. Installing new services
1: Action 15:49:46: RegisterUser. Registering user
1: Action 15:49:46: RegisterProduct. Registering product
1: Action 15:49:46: PublishFeatures. Publishing Product Features
1: Action 15:49:46: PublishProduct. Publishing product information
1: Action 15:49:47: InstallFinalize. 
1: Action 15:49:47: InstallInitialize. 
1: Action 15:49:47: QtRemoveService. 
1: Action 15:49:47: Rollback. Rolling back action:
1: QtRemoveService
1: InstallInitialize
1: 1: MySQL Server 8.0 2: {5A1AC698-82B9-4962-9FF5-EABADBA5A124} 3: 3 
1: The action 'Remove' for product 'MySQL Server 8.0.13' failed.

How to repeat:
1. Install MySQL Server using MySQL web installer.
2. Try to uninstall it.
[22 Nov 2018 16:13] Miguel Solorzano
1

Attachment: 93291_1.png (image/png, text), 168.45 KiB.

[22 Nov 2018 16:13] Miguel Solorzano
2

Attachment: 93291_2.png (image/png, text), 204.60 KiB.

[22 Nov 2018 16:14] Miguel Solorzano
3

Attachment: 93291_3.png (image/png, text), 234.81 KiB.

[22 Nov 2018 16:16] Miguel Solorzano
Thank you for the bug report. I couldn't repeat on Windows 10 Pro using MySQL web installer (see pictures attached).
[30 Nov 2018 7:48] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=93414 marked as duplicate of this one.
[30 Nov 2018 10:02] Vlad Kanash
Solved.
MySQL Server was successfully removed With the help of this tool:
https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being...