Bug #93048 mysql server 8.0.13 unistall failed
Submitted: 1 Nov 2018 18:04 Modified: 12 Dec 2018 22:35
Reporter: Diana Candolfi Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:8.0.13 OS:Microsoft Windows (windows 10)
Assigned to: CPU Architecture:x86

[1 Nov 2018 18:04] Diana Candolfi
Description:
I tried to unistall mysql server both with the mysql installer and "add remove program" but doesn't works in any way.

some details are reported here (with logs) 

https://forums.mysql.com/read.php?169,669887,669981#msg-669981

How to repeat:
Try to unistall mysql server with installer or with "add remove program"
[1 Nov 2018 19:34] Miguel Solorzano
Step 1 for removal

Attachment: 93048_1.png (image/png, text), 30.05 KiB.

[1 Nov 2018 19:35] Miguel Solorzano
Step 2 for removal

Attachment: 93048_2.png (image/png, text), 36.79 KiB.

[1 Nov 2018 19:36] Miguel Solorzano
Step 3 for removal

Attachment: 93048_3.png (image/png, text), 22.01 KiB.

[1 Nov 2018 19:36] Miguel Solorzano
Step 4 for removal

Attachment: 93048_4.png (image/png, text), 39.08 KiB.

[1 Nov 2018 19:37] Miguel Solorzano
Removal log

Attachment: 93048_log.txt (text/plain), 39.55 KiB.

[1 Nov 2018 19:41] Miguel Solorzano
Thank you for the bug report. I couldn't repeat this issue see attached files. Check if you don't have Windows Update Service issue, that was one of my experience when the MySQL Installer failed I needed to clear the Update cache action which according Microsoft should be done as last resort at own risk.
[7 Nov 2018 21:38] Alexander Telpov
Have the same problem

Attachment: mysql_removal_problem.txt (text/plain), 2.62 KiB.

[12 Nov 2018 17:50] Andrew -
The same happens on Windows 7 x64
[17 Nov 2018 3:26] Julio Aguilar
I have the same behaviour as Diana Candolfi, before and after clearing Windows Update cache.
The remove operation fails around 50% and it just says Failed with the following log in the details field

Beginning removal of MySQL Server 8.0.13.
1: Action 21:19:58: INSTALL. 
1: 1: MySQL Server 8.0 2: {5A1AC698-82B9-4962-9FF5-EABADBA5A124} 
1: Action 21:19:58: FindRelatedProducts. Searching for related applications
1: Action 21:19:58: AppSearch. Searching for installed applications
1: Action 21:19:58: LaunchConditions. Evaluating launch conditions
1: Action 21:19:58: ValidateProductID. 
1: Action 21:19:58: CostInitialize. Computing space requirements
1: Action 21:19:58: FileCost. Computing space requirements
1: Action 21:19:58: CostFinalize. Computing space requirements
1: Action 21:19:58: MigrateFeatureStates. Migrating feature states from related applications
1: Action 21:19:58: InstallValidate. Validating install
1: Action 21:19:59: InstallInitialize. 
1: Action 21:19:59: GenerateScript. Generating script operations for action:
1: InstallInitialize
1: Action 21:19:59: QtRemoveService. 
1: 
1: Action 21:19:59: RemoveExistingProducts. Removing applications
1: Action 21:19:59: ProcessComponents. Updating component registration
1: Action 21:20:00: UnpublishFeatures. Unpublishing Product Features
1: Feature: Unpublishing Product Features
1: Action 21:20:00: SchedSecureObjectsRollback. 
1: Action 21:20:00: ExecSecureObjectsRollback. 
1: 
1: Action 21:20:00: ExecSecureObjectsRollback. 
1: 
1: Action 21:20:00: ExecSecureObjectsRollback. 
1: 
1: Action 21:20:00: ExecSecureObjectsRollback. 
1: 
1: Action 21:20:00: RemoveRegistryValues. Removing system registry values
1: Key: Removing system registry values, Name: 
1: Action 21:20:00: RemoveShortcuts. Removing shortcuts
1: Shortcut: Removing shortcuts
1: Action 21:20:00: RemoveFiles. Removing files
1: File: Removing files, Directory: 
1: Action 21:20:01: RemoveFolders. Removing folders
1: Action 21:20:01: CreateFolders. Creating folders
1: Action 21:20:01: InstallFiles. Copying new files
1: Action 21:20:01: CreateShortcuts. Creating shortcuts
1: Action 21:20:01: WriteRegistryValues. Writing system registry values
1: Action 21:20:01: InstallServices. Installing new services
1: Action 21:20:01: RegisterUser. Registering user
1: Action 21:20:01: RegisterProduct. Registering product
1: Action 21:20:01: PublishFeatures. Publishing Product Features
1: Action 21:20:01: PublishProduct. Publishing product information
1: Action 21:20:01: InstallFinalize. 
1: Action 21:20:01: InstallInitialize. 
1: Action 21:20:01: QtRemoveService. 
1: Action 21:20:01: Rollback. Rolling back action:
1: QtRemoveService
1: InstallInitialize
1: 1: MySQL Server 8.0 2: {5A1AC698-82B9-4962-9FF5-EABADBA5A124} 3: 3 
1: The action 'Remove' for product 'MySQL Server 8.0.13' failed.
[21 Nov 2018 20:56] Leandro Grandinetti
Exact same problem here. Cannot uninstall, reinstall or downgrade version on system.
[3 Dec 2018 18:49] Miguel Solorzano
Please check the last comment of similar bug:

https://bugs.mysql.com/bug.php?id=93291

[30 Nov 10:02] Vlad Kanash

Solved.
MySQL Server was successfully removed With the help of this tool:
https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being...
[3 Dec 2018 19:09] Alexander Telpov
I think special tool for cleaning registry may help, but it would be nice if regular uninstall-install process works fine. I've solved the problem at the day when I found it (by manual clean up registry), but I would not recommend it as a solution.
[5 Dec 2018 15:32] Piotr Obrzut
Posted by developer:
 
According to the log given by users, the MySQL service removal action was failing which made the whole uninstall rollback.

I couldn't reproduce the problem, but I've made the service removal action failure non fatal which should allow the installer to continue. In case when the MySQL Installer will fail to remove the service the msi restart manager should still be able to cleanup (just it will require a system restart).
[12 Dec 2018 22:35] Paul Dubois
Posted by developer:
 
Fixed in 8.0.14.

MySQL Installer could fail after failure to remove an existing MySQL
service. This is now treated as nonfatal so that installation
operations can continue, but might require a system restart to permit
service cleanup.
[26 Feb 22:10] mario cristancho suarez
This solution also works to unistall mysql 5.7.25