Bug #93021 Cannot copy single column (I am able to do in Windows 10 version)
Submitted: 31 Oct 2018 7:29 Modified: 31 Oct 2018 10:40
Reporter: Burak Ueda Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.13 OS:Linux (Ubuntu 18.04 x86_64)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[31 Oct 2018 7:29] Burak Ueda
Description:
----[For better reports, please attach the log file after submitting. You can find it in /home/master/.mysql/workbench/log/wb.log]
When I run a query, I can't select a single column to copy.

In a Windows system:
When I click a particular cell in the result grid, only that cell is highlighted.
When I press SHIFT or CTRL, I can select multiple cells in the same column (or the whole column for that matter) and copy the contents.

In my current Linux Ubuntu system:
When I click anywhere on the result grid, the whole row is highlighted. 
When I double click a cell, I can edit the contents of that cell.
When I try to copy the contents of a single cell, the whole row is copied.
I cannot highlight/select a single cell or column at all. 

How to repeat:
1) Run a query resulting multiple rows and columns. 
Example:
first_name, last_name, user_id, age, location, birthday

total of 100 rows.

2) Try to select and copy the contents of the second column (all the last names) only.

Suggested fix:
Look at Windows version of the product. It is working flawlessly.
[31 Oct 2018 10:40] Umesh Shastry
Hello Burak Ueda,

Thank you for the report.
Imho this is duplicate of Bug #91867, please see Bug #91867

regards,
Umesh