Bug #92751 Can't Create Entity Data Model - using MySql and EF6
Submitted: 11 Oct 2018 13:34 Modified: 11 Oct 2018 13:51
Reporter: Mariusz Blautzik Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:2.0.5 OS:Microsoft Windows
Assigned to: CPU Architecture:x86
Tags: connector, Connector .NET, MySQL, mysql for windows

[11 Oct 2018 13:34] Mariusz Blautzik
Description:
Hello,

I have a problem with connecting my MySQL database inside my visual studio windows forms c# application.

I have tried to follow a guide: https://stackoverflow.com/questions/28241500/cant-create-entity-data-model-using-mysql-and...

But it still does not work. I'm getting an error " some updating commands could not be generated automatically the database returned the following error:   Unexpected error " and when I click "OK"  a next error occurs:" Could not retrieve schema information for table or view "table name"."

After that I get a third popup with "Error using the dropdown: Object reference not set to an instance of an object. " and Visual studio closes itself. 

I followed the guide above and i also tried it with all the latest versions.  
I'm using Visual Studio Community 2017 version. 

Does someone have a fix or any pieces of information that can be useful? I have been blocked by this error for like 2 days already. 

How to repeat:
1: Open visual studio
2: Insert a DataGridView
3: Try to connect MySQL database with Visual Studio ( Chose Data Source ) 
4: Connect to MySQL and try to select a table
5: Crash
[11 Oct 2018 13:51] Umesh Shastry
Hello Mariusz,

Thank you for the report.
Imho this is a duplicate of Bug #92681, please see Bug #92681

regards,
Umesh