Bug #90619 MySQL Installer for windows doesn't offer upgrade from 5.7 to 8.0
Submitted: 25 Apr 2018 7:15 Modified: 25 Apr 2018 8:23
Reporter: Georgi Sotirov Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:8.0.11 OS:Microsoft Windows (Windows 7 Professional SP1 (6.1.7601))
Assigned to: CPU Architecture:x86

[25 Apr 2018 7:15] Georgi Sotirov
Description:
I downloaded MySQL Installer Web Community from the official download site with the idea to upgrade my MySQL Community Server 5.7.22 installation to 8.0.11, but I wasn't offered such option. As I understand from the reference manual (see https://dev.mysql.com/doc/refman/8.0/en/upgrading-strategies.html#upgrade-paths ) upgrading from 5.7 GA to 8.0 GA is supported, so I was expecting MySQL Installer to provide me with such option. Instead, I had to add MySQL Server 8.0.11 as a separate product and so install it separately. Interestingly the installer detected that port 3306 is already used, so I had to change the port.

How to repeat:
1. Download MySQL Installer 8.0.11 from https://dev.mysql.com/downloads/installer/
2. Start it on a machine where MySQL 5.7 is installed and listening on the default port 3306.
3. Try to upgrade MySQL 5.7 to 8.0 by starting MySQL Installer.

Suggested fix:
MySQL Installer should offer the option to upgrade existing MySQL 5.7 installation.
[25 Apr 2018 7:20] Georgi Sotirov
MySQL list of prodcuts

Attachment: mysql_installer-products.png (image/png, text), 58.20 KiB.

[25 Apr 2018 7:21] Georgi Sotirov
MySQL Installer About screen showing version

Attachment: mysql_installer-about.png (image/png, text), 57.85 KiB.

[25 Apr 2018 8:23] Chiranjeevi Battula
Hello Georgi Sotirov,

Thank you for the bug report.
This is most likely duplicate of Bug #79315, please see Bug #79315

Thanks,
Chiranjeevi.