Bug #79315 Unable to upgrade MySQL to 5.7.9.1
Submitted: 17 Nov 2015 14:26 Modified: 20 Nov 2015 22:44
Reporter: Maarten Vekens Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Windows Severity:S3 (Non-critical)
Version:5.6.27 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[17 Nov 2015 14:26] Maarten Vekens
Description:
Dear I have downloaded the full installer of the community version of MySQL 5.7.9.1.
When I launch the msi, I don't have the option to upgrade the current version. The installer only suggest to reconfigure Mysqlversion on version 5.6.27.

Any idea to solve this?

How to repeat:
Launch the installer again
[17 Nov 2015 20:24] MySQL Verification Team
Installer

Attachment: upgrade.png (image/png, text), 76.23 KiB.

[17 Nov 2015 20:25] MySQL Verification Team
Thank you for the bug report.
[20 Nov 2015 22:43] Jose Gabriel Valencia Ornelas
Posted by developer:
 
This is not a bug, is working as expected

the updates only are available in the same series (5.5, 5.6 or 5.7)

There is no support for upgrade between major releases,  this means that a 5.6.25 could be upgraded to 5.6.27 but not to any 5.9.X, same for 5.5
however each MySQL server version (5.5, 5.6 and 5.7) could be installed side by side so you can install 5.7.9.1 in the same machine and use workbench to do a data migration between 5.6 to your new 5.7 

this is not a bug or an issue from installer, it depends directly with the server and how they manage their packages.

Installer team could in the future add some automated support for doing the same steps as I described here, however so far there is not an estimated time, or if will be available that feature
[4 Oct 2017 7:33] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=87957 marked as duplicate of this one.
[25 Apr 2018 8:24] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=90619 marked as duplicate of this one