Bug #89226 Unable to install MY SQL server 5.7.20
Submitted: 14 Jan 2018 22:16 Modified: 15 Jan 2018 14:54
Reporter: Ewon Gusanu Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S2 (Serious)
Version:5.7.20 OS:Microsoft Windows (WI 10 enterpirse 64bit)
Assigned to: CPU Architecture:Any

[14 Jan 2018 22:16] Ewon Gusanu
Description:
mysql server failed to install 5.7.20

1: RunPostInstall
1: Copying new files
1: Creating folders
1: Updating component registration
1: 1: MySQL Server 5.7 2: {81B27388-3733-4B65-8D84-AD9C9113B498} 3: 3 
1: The action 'Install' for product 'MySQL Server 5.7.20' failed.

Install goes to 88% then goes to 50 then Fails. 

Please help.

How to repeat:
I tried downloading both the server version and full version on my machine of 
mysql 5.7.20.

Have tried recommended fixes online still not working. 

Please advise.
[15 Jan 2018 5:03] Chiranjeevi Battula
Hello Amuktha Garimella,

Thank you for the bug report.
This is most likely duplicate of Bug #88661, please see Bug #88661

Thanks,
Chiranjeevi.
[15 Jan 2018 14:54] Ewon Gusanu
Same issue after downloading from this link, it gets to 89%, then reverts to 50%, then shows Failed

https://dev.mysql.com/downloads/installer/

This is the error

1: Key: \Software\MySQL AB\MySQL Server 5.7, Name: installed, Value: #1
1: Action 8:53:56: ExecSecureObjects. 
1: Action 8:53:56: Rollback. Rolling back action:
1: ExecSecureObjects
1: Writing system registry values
1: Creating shortcuts
1: RunPostInstall
1: Copying new files
1: Creating folders
1: Updating component registration
1: 1: MySQL Server 5.7 2: {81B27388-3733-4B65-8D84-AD9C9113B498} 3: 3 
1: The action 'Install' for product 'MySQL Server 5.7.20' failed.
[31 Jan 2018 15:50] Liamsi I
I currently have the same issue. Fresh install, here's the trace:

1: Key: \Software\MySQL AB\MySQL Server 5.7, Name: installed, Value: #1
1: Action 10:44:04: ExecSecureObjects. 
1: Action 10:44:04: Rollback. Rolling back action:
1: ExecSecureObjects
1: Writing system registry values
1: Creating shortcuts
1: RunPostInstall
1: Copying new files
1: Creating folders
1: Updating component registration
1: 1: MySQL Server 5.7 2: {3FAF469E-B671-4ED9-AB0D-CF8D41E35319} 3: 3 
1: The action 'Install' for product 'MySQL Server 5.7.21' failed.
[8 Mar 2018 5:51] Daniel Moore
I have the same issue, any resolution? 

1: Updating component registration
1: 1: MySQL Server 5.7 2: {3FAF469E-B671-4ED9-AB0D-CF8D41E35319} 3: 3 
1: The action 'Install' for product 'MySQL Server 5.7.21' failed.
[8 Mar 2018 7:14] Daniel Moore
I found a work around of sorts.
Install "MySQL Server 5.7.21" but deselect Product Feature "Server data files"
It appears everything else installs correctly except for the Server data Files.
[26 Sep 2019 19:26] Patrick Cude
Has this been resolved? I have the same problem.