Bug #88661 Cannot install mysql server but i can install everything else from installer
Submitted: 27 Nov 2017 0:21 Modified: 27 Nov 2017 6:26
Reporter: Amuktha Garimella Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.7.20 OS:Microsoft Windows (Windows 10 Pro)
Assigned to: CPU Architecture:Any

[27 Nov 2017 0:21] Amuktha Garimella
Description:
Cannot install MySQL server from the MSI installer given on the official site. I tried to install workbench, notifier, connector, and server. I successfully completed installing all those except MySQL server. It says installation failed and here are the brief log file details. Please help me.

1: Key: \Console\MySQL 5.7 Command Line Client - Unicode, Name: , Value: 
1: Key: \Software\MySQL AB\MySQL Server 5.7, Name: installed, Value: #1
1: Action 18:06:15: ExecSecureObjects. 
1: Action 18:06:15: Rollback. Rolling back action:
1: ExecSecureObjects
1: Writing system registry values
1: Creating shortcuts
1: RunPostInstall
1: Copying new files
1: Creating folders
1: Updating component registration
1: 1: MySQL Server 5.7 2: {81B27388-3733-4B65-8D84-AD9C9113B498} 3: 3 
1: The action 'Install' for product 'MySQL Server 5.7.20' failed.

How to fix this?

How to repeat:
Run the MSI installer given on the website.
Selected custom and server(x64).
Click execute and I get Installation Failed.
[27 Nov 2017 0:25] Amuktha Garimella
Log File

Attachment: mysqlserver log file.txt (text/plain), 32.30 KiB.

[27 Nov 2017 0:26] Amuktha Garimella
Screenshot

Attachment: mysql server installationfailed.png (image/png, text), 310.09 KiB.

[27 Nov 2017 6:26] Chiranjeevi Battula
Hello  Amuktha,

Thank you for the bug report.
I could not repeat the issue at our end using Windows Installer with 5.7.20 version.
Please download from here: https://dev.mysql.com/downloads/installer

Thanks,
Chiranjeevi.
[13 Dec 2017 23:49] Jens-Peter Giersch
Same for me; OS = Windows 10 Enterprise, fresh installation.
[13 Dec 2017 23:54] Jens-Peter Giersch
Oh, and the link(https://dev.mysql.com/downloads/installer) of course produces the same error.
[15 Jan 2018 5:04] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=89226 marked as duplicate of this one.
[14 Feb 2018 8:40] Eamon Kelly
I have exactly the same problem.
Has anyone figured it out?
[14 Feb 2018 20:04] Liamsi I
You can install the server manually (use the .zip version), follow the documentation online, and then use the executable to install workbench and all other components.