Bug #88044 Crush, fail, and crash again
Submitted: 10 Oct 2017 9:04 Modified: 10 Oct 2017 10:23
Reporter: Alexander Tsarev Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S5 (Performance)
Version:6.3.9 OS:Mac OS X (HighSierra 10.13)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[10 Oct 2017 9:04] Alexander Tsarev
Description:
Workbench doesn't work on macOS or linux opensuse, from any last version mac or linux

----[For better reports, please attach the log file after submitting. You can find it in /Users/kallisto/Library/Application Support/MySQL/Workbench/log/wb.log]

11:47:57 [INF][      Workbench]: Starting up Workbench
11:47:57 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /Applications/MySQLWorkbench2.app/Contents/Resources
	plugin path: /Applications/MySQLWorkbench2.app/Contents/PlugIns
	struct path: /Applications/MySQLWorkbench2.app/Contents/Resources/grt
	module path: /Applications/MySQLWorkbench2.app/Contents/PlugIns:/Applications/MySQLWorkbench2.app/Contents/Resources/plugins
	library path: /Applications/MySQLWorkbench2.app/Contents/Resources/libraries
	user data dir: /Users/kallisto/Library/Application Support/MySQL/Workbench
	open at start:
	open type:
	run at startup:
	run type:
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
11:47:57 [INF][      WBContext]: WbContext::init
11:47:57 [INF][            WBA]: Looking for extension modules for WBA...
11:47:57 [INF][            WBA]: 0 extension modules found
11:47:58 [WRN][            grt]: /Users/kallisto/Library/Application Support/MySQL/Workbench/connections.xml:27: link 'D6712940-8E2D-40A1-8A3A-87E0E4F6BE2E' <object GrtObject> key=owner could not be resolved
11:47:58 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Mac OS X version 6.3.9 CE build 10690321 (64 bit)
	Configuration Directory: /Users/kallisto/Library/Application Support/MySQL/Workbench
	Data Directory: /Applications/MySQLWorkbench2.app/Contents/Resources
	Cairo Version: 1.10.2
	OS: unknown
	CPU: 16x Intel(R) Xeon(R) CPU E5-1680 v2 @ 3.00GHz - 64.00GiB RAM
No video adapter info available

11:47:58 [INF][    WQE backend]: Found auto-save workspace /Users/kallisto/Library/Application Support/MySQL/Workbench/sql_workspaces/Local_instance_3306-1.autosave
11:47:58 [INF][    WQE backend]: Found auto-save workspace /Users/kallisto/Library/Application Support/MySQL/Workbench/sql_workspaces/core.webdesk.ru-1.autosave
11:47:58 [INF][    WQE backend]: Found auto-save workspace /Users/kallisto/Library/Application Support/MySQL/Workbench/sql_workspaces/atam-STAGING-1.autosave
11:47:58 [WRN][       WBModule]: OS detection failed, skipping OS support check.  OS string: 'unknown'
11:50:27 [INF][SQL Editor Form]: Opened connection 'Local/localhost' to MySQL Community Server (GPL) version 5.7.18

----

macOS crash report:

Process:               MySQLWorkbench [52971]
Path:                  /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
Identifier:            com.oracle.workbench.MySQLWorkbench
Version:               6.3.9.CE (1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           MySQLWorkbench [52971]
User ID:               501

Date/Time:             2017-10-10 11:42:59.033 +0300
OS Version:            Mac OS X 10.13 (17A405)
Report Version:        12
Anonymous UUID:        736CFE8E-EE20-E403-7685-98CF626A08F1

Sleep/Wake UUID:       A8F00FB0-A3A1-4F85-A965-F03DAEFD584F

Time Awake Since Boot: 340000 seconds
Time Since Wake:       270000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000200000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x200000000:
    ATS (font support)     0000000129300000-0000000129301000 [    4K] rw-/rwx SM=PRV
-->
    JS JIT generated code  0000485f6c800000-0000485f6c801000 [    4K] ---/rwx SM=NUL

... 8kb report, fuck! Full report 200 kb

How to repeat:
Run programm on macOS HighSierra 10.13
or
run programm on linux opensuse any last version

on linux crash when you try to save connections or when you try to connect to a server

on macOS crash when you try to connect to a server or close workbench or execute qsl query.

All malfunctions happen always, but not predictably which of the failures will be it this launch
[10 Oct 2017 10:23] Chiranjeevi Battula
Hello Alexander,

Thank you for the bug report.
This is most likely duplicate of Bug #83658, please see Bug #83658

Thanks,
Chiranjeevi.