Bug #87662 Catalog List has no names
Submitted: 5 Sep 2017 3:45 Modified: 16 May 2018 16:44
Reporter: Alejandro Matos Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S5 (Performance)
Version:6.3.9 OS:Mac OS X (macOS 10.12.x Sierra x86_64)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[5 Sep 2017 3:45] Alejandro Matos
Description:
After opening a Model, the list of elements in the catalog is empty (this is in the EER Diagram view), although tables are visible in the model. It's easier to explain this with an image: https://imgur.com/a/SXBVP

The log as suggested:
Although this is a MariaDB, the same behavior is being shown with MySQL Server.

22:37:50 [INF][      Workbench]: Starting up Workbench
22:37:50 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /Applications/Programación/MySQLWorkbench.app/Contents/Resources
	plugin path: /Applications/Programación/MySQLWorkbench.app/Contents/PlugIns
	struct path: /Applications/Programación/MySQLWorkbench.app/Contents/Resources/grt
	module path: /Applications/Programación/MySQLWorkbench.app/Contents/PlugIns:/Applications/Programación/MySQLWorkbench.app/Contents/Resources/plugins
	library path: /Applications/Programación/MySQLWorkbench.app/Contents/Resources/libraries
	user data dir: /Users/alejandro/Library/Application Support/MySQL/Workbench
	open at start: -psn_0_6657625
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
22:37:50 [INF][      WBContext]: WbContext::init
22:37:50 [INF][            WBA]: Looking for extension modules for WBA...
22:37:50 [INF][            WBA]: 0 extension modules found
22:37:50 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Mac OS X version 6.3.9 CE build 10690321 (64 bit)
	Configuration Directory: /Users/alejandro/Library/Application Support/MySQL/Workbench
	Data Directory: /Applications/Programación/MySQLWorkbench.app/Contents/Resources
	Cairo Version: 1.10.2
	OS: macOS 10.12.x Sierra x86_64
	CPU: 8x Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz - 32.00GiB RAM
No video adapter info available

22:38:07 [INF][SQL Editor Form]: Opened connection 'MariaDB' to mariadb.org binary distribution version 10.2.8-MariaDB-10.2.8+maria~jessie
22:38:07 [INF][  column_widths]: Initializing column width cache for MariaDB
22:38:07 [ERR][PyNotificationCenter]: Error calling notification observer for GRNSQLEditorOpened
22:38:07 [ERR][      WBContext]: Unsupported server version: mariadb.org binary distribution 10.2.8-MariaDB-10.2.8+maria~jessie

How to repeat:
Open Workbench, create model, create a table in the EER Design panel and open elements tree
[5 Sep 2017 7:27] Umesh Shastry
Hello Alejandro Matos,

Thank you for the report.

Thanks,
Umesh
[8 Sep 2017 11:49] Umesh Shastry
Bug #87706 marked as duplicate of this one
[21 Sep 2017 7:43] Umesh Shastry
Bug #87821 marked as duplicate of this one
[16 May 2018 16:44] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.12 release, and here's the changelog entry:

Catalog objects for an EER diagram were not listed, although the tables
were visible in the diagram.

Thank you for the bug report.