Bug #85973 MySQL Installer, cannot configure (No "Next" button in installer screen)
Submitted: 17 Apr 2017 12:44 Modified: 5 Dec 2017 16:03
Reporter: David Jeff Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:5.7.18 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: configuration, installation, Type and Networking, windows

[17 Apr 2017 12:44] David Jeff
Description:
I have a Windows 7 Home Premium installation.

I used "SQL Server Installer for Windows - Community". Everything is installed correctly. When I go to configure the product in the "Product Configuration" page of the installer, the first step is "Type and Networking". I am demanded to choose "Standalone MySQL Server" option or "InnoDB Cluster Sandbox" option.

Whichever option I choose, there is no "Next" button to progress beyond this part of the installation. MySQL server therefore does not work, as I cannot even start the command line clients without being able to configure (nor set a root and password if I am trying to use Workbench).

I have tried both x86 and x64 installations. Both get to the same point as described above and fail. I have tried disabling my firewall, and my AV software, still fails.

How to repeat:
+ Install SQL Server Installer for Windows.

+ Run installation; choose "Developer" or "Custom" or "Full" as the setup type (I have tried them all, and they all fail at the same place later on)

+ Verify the installation, then click the "Next" button to progress to the "Product Configuration" page. 

+ "Type and Networking" is the first step. Choose  "Standalone MySQL Server" option or "InnoDB Cluster Sandbox" option.

+ There is no "Next" button so the installation can progress. Configure, or reconfigure by uninstalling and reinstalling, always gets stuck at this point.
[18 Apr 2017 5:54] Chiranjeevi Battula
Hello David,

Thank you for the bug report.
I tried to reproduce the issue at my end using  mysql-installer-web-community-5.7.18.0.msi but not seeing any issues with "Next" button.
Could you please provide step by step (exact screenshot, stack trace etc. - please make it as private if you prefer) to confirm this issue at our end?

Thanks,
Chiranjeevi.
[18 Apr 2017 5:56] Chiranjeevi Battula
Standalone MySQL Server

Attachment: 85973_Standalone MySQL Server.JPG (image/jpeg, text), 79.61 KiB.

[18 Apr 2017 5:56] Chiranjeevi Battula
InnoDB Cluster Sandbox

Attachment: 85973_InnoDB Cluster Sandbox.JPG (image/jpeg, text), 76.76 KiB.

[18 Apr 2017 14:30] Marek Durian
Hello, 

I have the same issue - No next button on installer screen. I have Windows 7 Professional SP1 64 bit. MySQL installer for MySql Server 5.7.18. I have downloaded it today. 

I can send you a print screen - without the next/cancel buttons.
Thanks for help.

Regards,
Marek Durian
Prague, CR
[18 Apr 2017 14:35] Marek Durian
MySQL Installer  - no next button

Attachment: mySQLinstaller-no nextbutton.PNG (image/png, text), 65.08 KiB.

[18 Apr 2017 14:42] Marek Durian
I have downloaded mysql-installer-web-community-5.7.18.0.msi
I have chosen custom installation to change the installation directory.
In the attachment you can see the installed MySQL items. When I click to reconfigure server the screen in the attachment with no next button will appear.

Sorry for attaching to you bug report David, but I think I have the same issue.

Thanks.

Regards,
Marek Durian
[18 Apr 2017 14:43] Marek Durian
mySQL installer - installed options

Attachment: mySQLinstaller-installed.PNG (image/png, text), 67.83 KiB.

[18 Apr 2017 18:48] Marek Durian
Hi,

I had to change the windows text size to smaller = 100%. I had Medium(125%) before.
With 100% text size it works.

Thanks.
Regards,
Marek
[25 Apr 2017 16:00] Lisa Hart-Rabang
MySQL Installer 5.7.18 error Type and Networking screen

Attachment: MySql installer error 5.7.18.gif (image/gif, text), 26.34 KiB.

[25 Apr 2017 16:12] Lisa Hart-Rabang
Hi, 
I have the same problem as David, so also added my screen shot.  Marek's solution did not work for me, unfortunately.
Thanks,
Lisa
[26 Apr 2017 12:16] Sravan Prathipati
MySql Server Installation - No Next Button

Attachment: No Next Button.JPG (image/jpeg, text), 76.45 KiB.

[26 Apr 2017 12:22] Sravan Prathipati
Hi Chiranjeevi Battula,

colud you please help me on this.
[26 Apr 2017 18:29] Scott Meade
Screenshot of the installer

Attachment: oracle-installer.png (image/png, text), 94.20 KiB.

[26 Apr 2017 18:30] Scott Meade
Same issue - Windows 7 SP1 64 bit.
[26 Apr 2017 20:30] Miguel Solorzano
Buttons

Attachment: next.png (image/png, text), 106.00 KiB.

[26 Apr 2017 22:37] Jim Jones
No Next button for Type and Networking window

Attachment: mysql-server-not-installing.png (image/png, text), 80.49 KiB.

[26 Apr 2017 22:40] Jim Jones
good evening
I am having the same issue when I try installing MySQL. There is no next button on the Type and Networking window.
I have searched endlessly on Google and in MySQL Forums for a resolution, and there is no resolution.
At first I thought maybe it was because I use Python 3.6.1, but it is not. I downloaded and install Python 3.4 and that did not do anything.

A resolution would be very nice to have or see.
[27 Apr 2017 2:49] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86101 marked as duplicate of this one.
[27 Apr 2017 8:59] Chiranjeevi Battula
Hello David,

Thank you for the bug report.
Verified as described with screen display size 125%.

Thanks,
Chiranjeevi.
[27 Apr 2017 9:00] Chiranjeevi Battula
screen display size is 125%

Attachment: 85973.JPG (image/jpeg, text), 75.65 KiB.

[28 Apr 2017 8:55] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=86124 marked as duplicate of this one.
[2 May 2017 4:45] Lewis Jardine
I concur with the font size issue (I have 125%).  This forces the Next button off the fixed size dialog.   Unfortunately, I had to drop back and install previous version before I realized what the bug was.  (Windows 7 home premium using medium 125% fonts).

Work around = reduce font size to 100%
[2 May 2017 14:57] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86161 marked as duplicate of this one.
[11 May 2017 8:12] Frederik Cornil
Same issue here. Finally succeeded by using shortcut "N" to get to the next screen.
[11 May 2017 15:26] jimbo pruett
Alt-N gets me to "Apply Configuration" but then what? It says to hit [Execute] which I can't see?
[12 May 2017 10:50] Andrew C.
Workaround:

Frederik suggestion to use shortcut key "n" to get to the next screen works.  Then use shortcut key "x" to execute.
[12 May 2017 13:53] jimbo pruett
this worked for me... From above...

[18 Apr 18:48] Marek Durian
Hi,

I had to change the windows text size to smaller = 100%. I had Medium(125%) before.
With 100% text size it works.

Thanks.
Regards,
Marek
[12 May 2017 19:42] Michael Abair
Just an FYI for anyone hitting this bug.  I believe you can hit the next button without clicking on it by using ALT-N.

-Mike
[19 May 2017 17:51] Cherie Copeland
Same issue in Windows 10 Home x64.
[20 May 2017 6:17] Peter Grape
Same issue for me, Windows 8.0, x64, Display zoom set to 125%.

The Alt-N worked for two screens then I did not know what the shortcut was..

Solution!:
Sooo, changed the display zoom to 100% in the control panel, logged out then in again, problem solved.
Also saw that the text was cut of in some places so that was also a tell tale sign that the installer did not handle the zoom factor properly.
[22 May 2017 12:25] rodrigo olmos
Alt-N for Next, Alt-X for Execute and Alt-F for Finish will works until this is fixed
[23 May 2017 17:24] Randy Shaver
I have altered my fonts only but not to the standard 125%, but to a font size of 24 and bold.  My system is Windows 10 64 bit Home Laptop.  I am unable to see the Next button and some other functionality of several of the Installer screens.  I do not know if I can utilize Alt-N and others to complete installation.  Flying partially blind here.
[10 Jun 2017 18:09] Andrej Sokolov
for me it not working to

Attachment: Безымянный.png (image/png, text), 94.03 KiB.

[10 Jun 2017 18:09] Andrej Sokolov
for me it not working to

Attachment: Безымянный.png (image/png, text), 94.03 KiB.

[10 Jun 2017 18:18] Andrej Sokolov
Randy Shaver Alt+N worknig for me. 

Thanks!
[10 Jun 2017 19:37] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=86645 marked as duplicate of this one.
[5 Jul 2017 7:19] Yu-Hung Tsai
same issue on windows 10 x64, pls help adv when can get fixed edition, thank you
[23 Aug 2017 15:50] Pavel Perna
Is there any way this critical bug will be fixed ?
[9 Oct 2017 9:35] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=88023 marked as duplicate of this one.
[8 Nov 2017 20:18] Jorelia ANDRE
Hello Team,

I got the same issue...with 5.7.20 - mysql-installer-community-5.7.20.0.msi.
Blocked at the dialog "Type and Networking" and cannot go ahead by setting "Accounts and Roles" and so on....

So what is your plan to fix this long running bug ? any workaround ? Windows 7 Enterprise, SP1. 

Running on
[8 Nov 2017 21:13] Jorelia ANDRE
Hello Team,

Ok...a workaround....after reading most of post....

SEE post [18 Apr 18:48] Marek Durian

WORKAROUND: Set the windows font-size to 100%.

Could we have a section/header "Workaround" and a link to a clear workaround text ?

Thank you.
[19 Nov 2017 18:45] Phil Ingram-Smith
+1; 100% font size worked but now I need my glasses!

Phil.
[1 Dec 2017 17:52] Johannes Taxacher
Posted by developer:
 
fix verified in 1.4.21. Button bar is now properly displayed even when switched to larger text sizes.
[5 Dec 2017 16:03] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Installer 1.4.21 release, and here's the changelog entry:

Some DPI settings caused the Next button to become unreachable during the
server configuration step.

Thank you for the bug report.
[26 Apr 2018 20:06] Bill Papp
MySQL 8.0 GA Windows Installer - no 'Next' Button

Attachment: MySQL 8.0 GA Installer Problem - no 'Next' button.pdf (application/pdf, text), 114.43 KiB.

[26 Apr 2018 20:07] Bill Papp
Running Window 7 64-bit - looks like this bug didn't get fixed for MySQL 8.0 GA.
[28 Apr 2018 8:41] Bernard Treine
Authentication Method Dialog .jpg

Attachment: 2018-04-28 20_35_06-MySQL Installer.png (image/png, text), 67.21 KiB.

[30 Apr 2018 21:50] Luis Mora
Posted by developer:
 
Currently there is a workaround for this bug, on Windows please go to Control Panel -> All Control Panel Items -> Display settings and choose the "Smaller - 100%(default)" option, this way you can see the wizard buttons at the bottom of the screen. In case you aren't able to modify the DPI configuration, you can try the following commands: ALT+B for going back, ALT+N go to the next screen and ALT+X to execute the configuration steps.
[11 May 2018 14:20] Rafael Antonio Bedoy Torres
Posted by developer:
 
Fixed on 1.4.26 build 1
[11 May 2018 19:28] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Installer 1.4.26 release, and here's the changelog entry:

Some DPI settings caused the Next button to become unreachable during the
server configuration step. 

Workaround: Open Control Panel and select Display. Set the size to Smaller - 100% (default).
Alternatively, use the following shortcut keys within MySQL Installer:

 Alt+B to go back. 
 Alt+N to go to the next screen. 
 Alt+X to execute the configuration steps.

Thank you for the bug report.
[14 May 2018 13:51] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=90859 marked as duplicate of this one.
[15 May 2018 15:55] Rafael Antonio Bedoy Torres
Posted by developer:
 
Fixed on 1.4.26 build 2
[15 May 2018 18:42] Christine Cole
Posted by developer:
 
Fixed in MySQL Installer 1.4.26 with the same changelog entry as above.
[26 May 2018 20:06] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=91035 duplicate of this one.
[22 Jun 2018 1:54] guibin li
use shortcut key "n" to get to the next screen works. and the shortcut key "b" to the previous page. Then use shortcut key "x" to execute.